aghh, please help a newbie to wii hacking..

Discussion in 'Wii - Hacking' started by tan-tan, Nov 9, 2011.

  1. tan-tan
    OP

    tan-tan GBAtemp Regular

    Member
    107
    17
    Nov 9, 2011
    Canada
    I hacked my wii yesterday using Letterbomb. I installed the Homebrew Channel, Bootmii as IOS, (no boot2 available) and made a NAND backup.

    I loaded some emulators (vbagx, snes9xgx, genplus-gx and scummvm)

    I noticed that almost all of them (except for scumm and gens) were unable to properly locate the roms folder, (i had to do it myself) and unable to save. They said "directory not found" and then usually
    "Save failed" Since i had labeled and placed the folders correctly (as far as i know) I figured that my SDcard (dane-elec 8gb sdhc) must be to blame. I backed up everything, and reformatted the SD to fat32. I made sure that my emulators had two folders, one in the root of the sd with roms and saves.
    When i tried again to load roms with snes9x it still says "Directory not found" I went to manually select the roms folder- and snes9x crashed with some code and "rebooting in [seconds]" (but never did).

    So not only did I not fix the loading and saving problem, but I seem to have created a new one. fffffffffff- Please help. ;_;
     
  2. sweenish

    sweenish GBAtemp Advanced Fan

    Member
    704
    2
    Apr 16, 2008
    United States
    WA
    could be that the sd card has the write-protect turned on.

    i would also delete any config files that the emulators may have created.
     
  3. ddetkowski

    ddetkowski GBAtemp Maniac

    Member
    1,141
    56
    Jun 15, 2009
    United States
    United States
    re-hack with modmii
     
  4. tan-tan
    OP

    tan-tan GBAtemp Regular

    Member
    107
    17
    Nov 9, 2011
    Canada
    Deleted all the config files for the emulators, but they still all freeze/crash when selecting a game, or after leaving a game and pressing cancel on "Directory not found" message.

    ddetknowski - I'm really new to this, I've never used anything like modmii before, I don't know how to use it or what i should be doing with it in this situation. I'm really nervous about messing up my wii, i want to keep any more modifications to a minimum.

    It was loading just fine before i formatted my card and recopied the files (just not saving) I'd rather have partial functionality than none at all.
    I don't think my SD is write-protected because ScummVM loads and saves just fine.

    I also tried using a USB drive i had, but to the same result.
     
  5. The_Dragons_Mast

    The_Dragons_Mast GBAtemp Advanced Fan

    Member
    613
    19
    Apr 20, 2007
    Egypt
    Post a syscheck please . It should help locate where is the problem
     
  6. tan-tan
    OP

    tan-tan GBAtemp Regular

    Member
    107
    17
    Nov 9, 2011
    Canada
    Alright, syscheck didn't freeze at any point. Here is the sysCheck

    Warning: Spoilers inside!
     
  7. The_Dragons_Mast

    The_Dragons_Mast GBAtemp Advanced Fan

    Member
    613
    19
    Apr 20, 2007
    Egypt
    Well you have ios58 & hbc is using it so they should work probably .

    You sure you got the latest versions from wiibrew & got the file structure right ?

    If both are right then try another sd card as many sdhc cards have issues with hbc .
     
  8. tan-tan
    OP

    tan-tan GBAtemp Regular

    Member
    107
    17
    Nov 9, 2011
    Canada
    I got my files from and followed the guide on this site. (which was linked in the gbatemp guide)

    I don't have another normal SD, only a microSD adapter and a spare usb drive, but i'll try them.
     
  9. The_Dragons_Mast

    The_Dragons_Mast GBAtemp Advanced Fan

    Member
    613
    19
    Apr 20, 2007
    Egypt
    Well the emulators links are really old versions in there so try downloading the latest vbagx & snes9x .
     
  10. tan-tan
    OP

    tan-tan GBAtemp Regular

    Member
    107
    17
    Nov 9, 2011
    Canada
    Actually, the emulators I did get from that site, I believe that was where I downloaded almost all of my homebrew. The other site was just where I got the files and instructions for the softmod.

    ScummVM is now loading and playing my games, but after a couple seconds, it immediatly freezes for both SD and USB.
     
  11. shortz1994

    shortz1994 GBAtemp Maniac

    Member
    1,341
    157
    Jan 21, 2011
    United States
    Chii-chan said "I also tried using a USB drive i had, but to the same result." this is because of this little problem. IOS222 (rev 65280): Stub
    IOS223 (rev 65280): Stub
    IOS249 (rev 65280): Stub
    IOS250 (rev 65280): Stub
    with those beeing a stub. emulators are all your stuck with, you can't just simply plug a usb drive in an it works..
    do as ddetkowski said "run modmii".. if you got this far with your mod, modmii will finish. just follow directions.
     
  12. The_Dragons_Mast

    The_Dragons_Mast GBAtemp Advanced Fan

    Member
    613
    19
    Apr 20, 2007
    Egypt
    As far as I know new versions of gx emulators doesn't use any cios anymore but I might be wrong as I had all cios in my wii for as far as I can remember .
     
  13. tan-tan
    OP

    tan-tan GBAtemp Regular

    Member
    107
    17
    Nov 9, 2011
    Canada
    The USB flash drive did work for me (I loaded roms off of it when i was using emulators) Unless you're referring to something else..
     
  14. shortz1994

    shortz1994 GBAtemp Maniac

    Member
    1,341
    157
    Jan 21, 2011
    United States
    all my files for my emulators are on my sd card. an it works fine. as far as using usb you never said if it was a pen drive(flash stick), or a hdd. i only use hdd.
    so i was going on that. try an put some of the games on the sd card only an use that. see what happens.
     
  15. tueidj

    tueidj I R Expert

    Member
    2,569
    820
    Jan 8, 2009
    *sigh*
    Edit the meta.xml file for each application and remove the "" line.
     
  16. tan-tan
    OP

    tan-tan GBAtemp Regular

    Member
    107
    17
    Nov 9, 2011
    Canada
    ....it was that easy all along. *headdesk* god I feel stupid

    Thank you to everyone who has been so helpful and patient with me!