Hardware After self-repair, console not detecting Joy-Con but is still charging.

DitDit

Active Member
OP
Newcomer
Joined
May 21, 2018
Messages
31
Trophies
0
Age
18
XP
202
Country
United Kingdom
Hi all,
Yesterday I tried to repair the Joy-Con sticks as they were drifting. It went all right, a bit messy but I got there in the end, with the sticks fixed. I was testing it today, and noticed that the Switch isn’t making the normal animation when inserting the fixed Joy-Con (the right one), yet it still charges. I have linked a picture for reference. I think it’s due to a ribbon cable being detached.
All help is appreciated.
 

Attachments

  • E7BF39F5-5C62-4889-AE47-60ECA13E08E9.jpeg
    E7BF39F5-5C62-4889-AE47-60ECA13E08E9.jpeg
    848.3 KB · Views: 231

DeoNaught

I'm here to steal memes and break dreams
Member
Joined
Aug 22, 2016
Messages
2,261
Trophies
0
Location
Constant Fear
Website
Gbatemp.net
XP
2,227
Country
United States
Re-seat your cables (pretty much take everything apart and put it back together again), double check your ribbon cables.
Also not sure if that's a charging, and not just charged. I'm pretty sure it's just your Joycon rail, so check the two connectors on the side that connect to it to the joycon board.
 

DitDit

Active Member
OP
Newcomer
Joined
May 21, 2018
Messages
31
Trophies
0
Age
18
XP
202
Country
United Kingdom
Re-seat your cables (pretty much take everything apart and put it back together again), double check your ribbon cables.
Also not sure if that's a charging, and not just charged. I'm pretty sure it's just your Joycon rail, so check the two connectors on the side that connect to it to the joycon board.

This is what the connectors looks like:
 

Attachments

  • image.jpg
    image.jpg
    901 KB · Views: 199
  • image.jpg
    image.jpg
    1.1 MB · Views: 195

You may also like...

General chit-chat
Help Users
    M4x1mumReZ @ M4x1mumReZ: Alright, well take care.