After hardmod N3DS XL with A9LH no longer works

Discussion in '3DS - Console, Accessories and Hardware' started by Smynos, Jun 26, 2016.

  1. Smynos
    OP

    Smynos Member

    Newcomer
    39
    10
    Oct 29, 2015
    Australia
    Hello,

    I have sent a new 3DS XL to a guy to do a hardmod.
    The N3DS was basically new and I have successfully installed A9LH and Luma3DS following the instructions of Plailect's Guide (https://github.com/Plailect/Guide/wiki) before I sent it for hardmod.

    Unfortunately I didn't tell the guy doing the hardmod that A9LH was installed.
    So, after he installed the hardmod he tried to use it without the SD card inserted. And this didn't work like expected because of A9LH. The blue LED turns on and turns off immediately within a second and nothing else happens.
    He tried a few things like installing the main board into another N3DS just to check if the board has a problem and of course, it didn't work. Then he gave up thinking he had ruined the N3DS.

    After I told him all about A9LH he tried to use it again with the SD card inserted but to no avail.
    Even when the SD card is inserted when the N3DS is switched on the blue LED turns on and goes out immediately and nothing happens.
    He then did send it back to me.
    And now I have it with this condition.
    I checked the contents of the SD card and everything looks ok to me. The file arm9loaderhax.bin is present and all the other files are untouched.

    What can be the cause of the problem?
    What can I check?
     
  2. yacepi15

    yacepi15 GBAtemp Advanced Fan

    Member
    894
    178
    Aug 15, 2015
    Antarctica
    1. The ribbon cables of the motherboard are connected properly and undamaged? Looks like that.
    2. The SD reader is damaged.
    3. Try with another SD and/or recopy the Arm9loaderhax.bin to the SD, reinsert it to the PC and check if the file is still there.
     
  3. zoogie

    zoogie simple pimp tool

    Member
    6,345
    8,044
    Nov 30, 2014
    United States
    Did he complete the nand mod? You should just be able to reflash the old backup nand and it'll work.

    As long as you have the otp.bin, it should be extremely easy to re-install a9lh after the backup restore.
     
  4. voddy

    voddy No Title Available

    Member
    271
    80
    Jul 14, 2013
    United States
    had the same problem when i tried to do the nandmod myself.
    i accidentally broke one small connector when i tried to open it.
    it is a really soft one that got slightly almost non visible damage.

    Well end of story: i threw it away and bought a new one.... maybe he broke the connector too. its a super small one and really had the same problem (long before A9LH was even imagined xD)
     
  5. Smynos
    OP

    Smynos Member

    Newcomer
    39
    10
    Oct 29, 2015
    Australia
    Yes, all ribbon cables are connected properly. I don't see any damage.
    Maybe; I will try to swap the SD reader with another N3DS.

    — Posts automatically merged - Please don't double post! —

    I cannot test the hardmod because the N3DS immediately turns off after I turn it on. Even when the SD frankenconnector is connected.

    — Posts automatically merged - Please don't double post! —

    Can you please be a little bit more specific what connector you mean?
    Notice, that my system is a new N3DS XL not an old one.

    Thanks.
     
  6. gamesquest1

    gamesquest1 Nabnut

    Member
    14,135
    9,478
    Sep 23, 2013
    It will probably be the back light ribbon cable, and it's almost defiantly a ribbon issue as even with a9lh installed if you connect the console with the SD adapter to a pc it would bsod before a9lh kicks in

    The most common issue is people trying to pry up the connector for the bottom screen back light this is a small 2 pin connector at the top of the board
     
    Last edited by gamesquest1, Jun 26, 2016
    Smynos likes this.
  7. Smynos
    OP

    Smynos Member

    Newcomer
    39
    10
    Oct 29, 2015
    Australia
    Thanks.
    That was it. The small 2 pin connector. I have inserted a foil together with the small ribbon cable into the ZIF connector and the N3DS did power on.

    Now after some tests I found out that:

    - microphone
    - home button
    - NFC (amiibo)

    were not working.

    The usual ZIF connector problem.

    I could successfully repair the microphone and NFC connections inserting a foil together with the cable.
    But the home button connector did break on the left side using this method.
    So, I guess I have now ruined it.
    Or is there anything I can do to repair this useless ZIF connector?

    Anyway, thanks for your suggestion to find the problem.