After flashing A9LH, I cant access HBL in my emuNAND 9.2

Discussion in '3DS - Flashcards & Custom Firmwares' started by stebrick, Apr 6, 2016.

  1. stebrick
    OP

    stebrick Advanced Member

    Newcomer
    61
    5
    Mar 6, 2016
    Hong Kong
    First of all, the whole A9LH process has been perfect and now I can cold boot into sysNAND 10.7 and install all cias stuff there. I am using AuReiNAND to boot up the system.

    I have unlinked system before I did A9LH stuff. I am also keeping the EmuNAND and having flashed it with my 9.2 sysNAND backup, i.e. the backup I did before flashing A9LH. In order words, basically I have reversed my previous EmuNAND 10.7 and SysNAND 9.2. Now it is SysNAND 10.7 and EmuNAND 9.2.

    I know it may be meaningless to keep EmuNAND 9.2. I just keep it maybe one day I could use it to access my HBL....or doing other stuff if necessary (not sure at this moment), or maybe I could upgrade it at a later time.

    Whilst everything is now perfect, it comes to my notice that I cant access HBL in both systems, neither at sysNAND 10.7 nor EmuNAND 9.2...I checked that I have firmware 9.0 from AuReiNAND in my SD card at the appropriate place. I also placed one firmware.bin (as the one from AuRei for NTR) in my SD card. But nothing changed.

    The result is simply that I can scan the QR code of yellow8 in EmuNAND 9.2. I can see the ninjhax debug screens with several colours screen flashing a few time, and at last I always saw a red bottom screen and then blackscreen forever...I simply cant go into HBL, just like the way it stuck in my Sys 10.7.

    Any suggestion and help would be much appreciated.
     
  2. squee666

    squee666 Advanced Tech Pleb

    Member
    1,592
    897
    Sep 17, 2010
    Belfast
    try removing the HBL files and adding them again
     
  3. Docmudkipz

    Docmudkipz Novice

    Member
    327
    219
    Mar 16, 2016
    United States
    Staring at my computer case's window
    Use FBI on your sysnand and install Homebrew Launcher Loader. Remember you can still dump and inject the H&S thru decrypt 9 if you don't have it
     
  4. migles

    migles Mei the sexiest bae

    Member
    GBAtemp Patron
    migles is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    7,069
    4,750
    Sep 19, 2013
    Saint Kitts and Nevis
    my dad works for nintendo.
  5. stebrick
    OP

    stebrick Advanced Member

    Newcomer
    61
    5
    Mar 6, 2016
    Hong Kong
    Thanks for the prompt reply!!!
    The result is still the same. Still stuck at the red screen at the bottom and blackscreen forever...
     
  6. Docmudkipz

    Docmudkipz Novice

    Member
    327
    219
    Mar 16, 2016
    United States
    Staring at my computer case's window
    Did you do what the others said? Try just deleting the current hbl files on the sd and retry.
     
  7. astronautlevel

    astronautlevel Finding a reason, waiting for a miracle

    Member
    4,044
    5,090
    Jan 26, 2016
    United States
    That Nightly Siteā„¢
    Do you have boot.3dsx?
     
    Ammako likes this.
  8. stebrick
    OP

    stebrick Advanced Member

    Newcomer
    61
    5
    Mar 6, 2016
    Hong Kong
    I tried to delete a few but nothing changed, though I am not sure which file shall I delete, and reinstall. Do you mind teaching me how to do that? No doubt I would be grateful.:bow:
     
  9. linuxares

    linuxares GBAtemp Psycho!

    Member
    3,274
    1,405
    Aug 5, 2007
    Can you screenshot your SDCard setup?
     
  10. Filo97

    Filo97 Zelda's totally my sister! Not lying!

    Member
    3,742
    1,240
    Oct 8, 2015
    Italy
    Hyrule Castle
    Red screen means no boot.3dsx
     
  11. squee666

    squee666 Advanced Tech Pleb

    Member
    1,592
    897
    Sep 17, 2010
    Belfast
    Yeah do boot 3dsx like i said remove your hombrew loader files and install them again
    You can get the starter kit from here http://smealum.github.io/3ds/
     
  12. stebrick
    OP

    stebrick Advanced Member

    Newcomer
    61
    5
    Mar 6, 2016
    Hong Kong
    This is absolutely correct, I love you man~~~~~~

    Although I already figured it out myself yesterday after taking a shower, your answer is absolutely straight right to the point, even though it is such a short answer!!!

    The reasons are actually two-folded and it was due to my dam silly mistake:-

    1. I forget to replace the boot.3dsx of CTRbootmanager with the one HBL requires.

    2. the menuhax was still intact even though I already changed the theme because of this: https://gbatemp.net/threads/aureinand-menuhax-lesshax-99-99-boot-rate.419862/
    Step 3 in this thread:- Go to the AuReiNAND download folder on your PC and find the "menuhax" folder. Enter it and rename "boot.3dsx" to "cfw.3dsx".

    So, it means that when I launched hbl_loader.cia, or used the QR code, the following happened: booting using CTRbootmanager >> triggering menuhax and launching AuReiNand to boot into a non-existing EmuNand (with zero seconds countdown, and so I couldn't choose Homebrew Menu, and I wasn't able to identify the problem immediately).

    One thing I do not understand is that I only figured out this problem after I selected "Updated SysNAND mode (A9LH) and "Use 9.0 Firm as default" in the AuReiNand startup menu. But I do not have to select them in order for me to enter into HBL. Strange!!

    Dam, I am so stupid!!
    So, all in all, those who have flashed A9LH should take one more extra step to reverse the CTRbootmanager and the menuhax setup, if any.
     
    Last edited by stebrick, Apr 7, 2016
    astronautlevel and FenrirWolf like this.
  13. stebrick
    OP

    stebrick Advanced Member

    Newcomer
    61
    5
    Mar 6, 2016
    Hong Kong
    One more thing, I could now also access HBL in my sysNAND 10.7 by using hblauncher_loader.cia, which is fantastic as supposingly this could not be done in 10.7 system....And I dun know why it could do that.
     
  14. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,347
    329
    Nov 19, 2008
    United States
    Sandy, UT
    You can definitely use the hblauncher_loader cia on 10.7.