Acekard 2i isn't loading my save games from an R4.

Discussion in 'Acekard' started by xenobreak, Apr 14, 2010.

  1. xenobreak
    OP

    Newcomer xenobreak Member

    Joined:
    Jan 31, 2008
    Messages:
    30
    Country:
    United States
    So i just got an Acekard 2i today and put AKAIO 1.6 RC2 on it... everything works fine except none of my save games load up. I'm coming from an original R4 so all the save games are ".SAV" files. Also they ARE the same name as the ".NDS" equivalent. I have tried converting the saves within the Acekard OS to ".sav" lower case and ".nds.sav" but they never show up when i boot the game. I have also tried using that online converter but it says the files are already the correct type and it does nothing. I'm not sure how to change the filetype in windows as it does not show file extensions in the folders. If i add a ".sav" at the end of the file in winodws it ends up being ".SAV.sav"... Also the games and saves are in the same folder on the sdcard.

    Only new saves within Acekard seem to load... it names them ".sav" in lower case so i assume the problem here is the fact that the R4 saves are capitol instead. Im just confused how when i convert the save within the Acekard OS is DOES change it to lowercase but it still doesn't load. I have also tried changing the save file type to .nds.save within the system settings of the Acekard but that didn't work either. Once again only new saves created with the Acekard loaded...

    I tried using the search funcion on the forums to find people with similar problems but i kept getting an error when trying to search. Also looked on google but i only found results talking about the online converter and the lowercase/capitol issues... both which i have already tried.

    Any ideas?
     
  2. tk_saturn

    Member tk_saturn GBAtemp Psycho!

    Joined:
    Jan 26, 2010
    Messages:
    3,327
    Country:
    United Kingdom
    "ren *.nds.sav *.sav"

    or " ren *.SAV *.sav" from the command prompt should rename them.

    If the file name is in 8.3 format, then both the rom and the save should entirely be in uppercase, not just the extension.

    you can load a command prompt by holding down the windows key and press R, then type CMD and press enter.
     
  3. tk_saturn

    Member tk_saturn GBAtemp Psycho!

    Joined:
    Jan 26, 2010
    Messages:
    3,327
    Country:
    United Kingdom
  4. xenobreak
    OP

    Newcomer xenobreak Member

    Joined:
    Jan 31, 2008
    Messages:
    30
    Country:
    United States
    OK what i did was turn off the hide file extensions thing in the windows folder options. I changed the file type from ".SAV" to ".sav". Unfortunately this made no difference as when i load the game, the save still doesn't show up.

    I'm not sure what you mean about the 8.3 format thing... for example the files on the R4 are "Mario.NDS" and "Mario.SAV". Everything worked fine that way... The games boot up fine on the Acekard without being all uppercase also.

    Still stuck on the save thing though =/
     
  5. xenobreak
    OP

    Newcomer xenobreak Member

    Joined:
    Jan 31, 2008
    Messages:
    30
    Country:
    United States
    The renamesav.bat file did the trick [​IMG]

    Thank you sooo much ^ ^
     
  6. Gvaz

    Member Gvaz GBAtemp Fan

    Joined:
    May 24, 2007
    Messages:
    384
    Location:
    United States
    Country:
    United States
    Yeah they're the same format but apparently something is "wrong" with the way the R4/M3 Simply saves that's incompatible with the AceKard2i (they shouldn't be)

    When I used my m3 simply it would save in .SAV and my cyclods loaded this up just fine and saved as .sav but I don't believe it messed with the format of those .SAV so when I put it in my Acekard2i it refused to read them from renaming them or anything.

    I had to use that online converter to convert it to no$GBA and back to ace/cyclo/m3 for the acekard to read it
     

Share This Page