About playing PSX games on Adrenaline-3

Discussion in 'PS Vita - Hacking & Homebrew' started by Entonghibang, Apr 16, 2017.

  1. Entonghibang
    OP

    Entonghibang Member

    Newcomer
    38
    2
    Nov 22, 2015
    Just noticed something when loading save states from psx games, sounds become messed up, someone here experienced it?

    games I played that has sound issue when loading save states.
    -Digimon world
    -Suikoden 1
     
    leonmagnus99 likes this.
  2. Bonestorm

    Bonestorm GBAtemp Fan

    Member
    397
    151
    Jan 15, 2017
    Canada
    Midgar, Sector 5
    This happens when you load the save state before actually loading the game or when loading a savestate for a game while playing another. So start your ps1 game normally from psp menu then load the save state it it should be fine. Hopefully flow fixes that.
     
  3. Entonghibang
    OP

    Entonghibang Member

    Newcomer
    38
    2
    Nov 22, 2015
    Thanks for the solution man!
     
  4. stargoonman

    stargoonman Advanced Member

    Newcomer
    70
    2
    Apr 12, 2007
    United States
    Even if you load the game properly, sometimes sound effects will never play until you completely restart. Loading the save state will break the audio again.
     
    leonmagnus99 likes this.
  5. Count Duckula

    Count Duckula .

    Member
    625
    161
    Aug 17, 2008
    Australia
    I've had the sound stop working, but unrelated to save states.
    Sometimes after you exit a PS1 game there is no sound in the XMB or further games you load, closing adrenaline and re-opening it gets it going again.
     
  6. laharl22

    laharl22 GBAtemp Advanced Maniac

    Member
    1,584
    163
    Dec 19, 2014
    France
    How to make Harry Potter and the sorcerer stone work? Because pops native of adrenaline are shit compatibility compared to retroarch
     
  7. leonmagnus99

    leonmagnus99 GBAtemp Addict

    Member
    2,456
    611
    Apr 2, 2013
    Seinegald
    same thing happening to me recently :l

    it is not just with a single game, i also have suikoden as a save state.
    1st is suikoden, 2nd is threads of fate.

    and the 3rd save state i have ,and play the most is vagrant story.
    i just now loaded up the save state of vagrant story (i previously had my save states vanish on me with the first adrenaline release /after updating to the latest i think that is when the save states vanished) despite knowing the risks i still find myself in need of save states..

    as they become really useful at times, when i am in a hurry i can just quickly save wherever i am.
    but it seems to have its flaws, i am more afraid of losing the save states than the no sound issue though :C

    atm. all 3 of the save states i load up have no sound, first there is abit of sound, then it gets glitchy and then it becomes muted.
    i hope a reboot of the vita fixes this *sigh*

    and to the other guys, is there any way to backup the save states that adrenaline creates? it'd be nice to be able to back them up, i'd do this every once in a while just in case.
     
  8. Zukov

    Zukov Dinosaur

    Member
    200
    48
    Oct 2, 2016
    Chile
    Somebody told me: try to do the savestates in a audioless place. It could be in the pause menu, or something like that.
    My solution: just play untill reach a normal save ingame, and reload from that point in the original Load data screen.
     
    leonmagnus99 likes this.
  9. leonmagnus99

    leonmagnus99 GBAtemp Addict

    Member
    2,456
    611
    Apr 2, 2013
    Seinegald
    i'll try that now, as that is the only option i have left.
    the game keeps loading up with no sound (even when i tried powering off and reloading henkaku/adrenaline).

    i love save states, i wish it was less buggy though ..
    now also to see how to back up these save states before they vanish on me completely :l

    @Zukov what you said, i did and that fixed the issue , so yay for that ! thanks.
    but how do we avoid running into this sound issue again ?
    i usually do not load up the game ,then loading save state.
    i usually load up save states directly from the psp menu , i do not launch game prior to loading save state.

    would launching game /then loading save state help avoid this sound issue ?
    if yes i'll do that.
     
    Last edited by leonmagnus99, May 18, 2017
    Zukov likes this.
  10. Zukov

    Zukov Dinosaur

    Member
    200
    48
    Oct 2, 2016
    Chile
    I don't think that process is gonna help at all. The bug is with the sound and the savestate, not with the way you load the game. I tell you this because I did both loading ways in the past and none of them helps to fix the sound. Is just some bug that needs a doctor.
     
  11. leonmagnus99

    leonmagnus99 GBAtemp Addict

    Member
    2,456
    611
    Apr 2, 2013
    Seinegald
    and it happened so randomly , it was working fine all the time for me.
    hmm, i hope the save states become more stable with future updates.