[a9lh]unable to access eshop: 005-0958

Discussion in '3DS - Homebrew Development and Emulators' started by xdrz, Jun 16, 2016.

  1. xdrz
    OP

    xdrz Member

    Newcomer
    45
    3
    Aug 8, 2015
    Hong Kong
    I have done the a9lh hacking recently but I cannot access eshop
    with error code 005-5958

    I am wondering if I have not format the sysnand before enough (I have format 2 times) following the tutorial in github.
    I find that on the internet other similar case is solved by formating the NAND,
    but how can I format the NAND after a9lh is done?
    Or is there any alternative solution?

    (I am now in 11.0.0-33U with a9lh)
     
    Last edited by xdrz, Dec 5, 2016
    Olmectron likes this.
  2. Olmectron

    Olmectron GBAtemp Addict

    Member
    2,095
    1,300
    Dec 31, 2012
    Mexico
    A game
    I would advise you to backup your SD contents, and a NAND backup, then format using System Settings.

    Using TinyFormat made me lose my NNID, I still don't know how. Anyway, try doing that, after formatting try to access the eShop. If it works, restore everything back.
     
  3. MeatieMeat

    MeatieMeat Advanced Member

    Newcomer
    98
    11
    Jan 6, 2016
    Canada
    I think I had the same error I know it was the same issue though.
    how I fixed it was formatted sysnand and then emunand and then sysnand again.
    I think it was because I didn't unlink my NNID from the sysnand but for whatever reason it fixed it.

    By the way I am far from a pro at this so you might want to confirm with someone who knows more then me
     
  4. xdrz
    OP

    xdrz Member

    Newcomer
    45
    3
    Aug 8, 2015
    Hong Kong
    I have formatted it in system setting
    but I found that the file in SD is still staying there
    and the same error occured when I try to go to eshop

    what had I done wrong?
    PS: my NAND is sys 11.0.0-33U which is in sysnand
     
  5. Olmectron

    Olmectron GBAtemp Addict

    Member
    2,095
    1,300
    Dec 31, 2012
    Mexico
    A game
    How is it that the "file in SD is still staying there"?
     
  6. xdrz
    OP

    xdrz Member

    Newcomer
    45
    3
    Aug 8, 2015
    Hong Kong
    the old file in SD had not been removed
    should I put the NAND in emunand and format it again?
     
  7. Olmectron

    Olmectron GBAtemp Addict

    Member
    2,095
    1,300
    Dec 31, 2012
    Mexico
    A game
    I'm not sure what you should do now. I don't have EmuNAND since some time ago. Let's wait for someone else to comment about it.

    People has said formatting EmuNAND and SysNAND twice could work, but I'm not really sure, sorry.
     
  8. Pandaxclone2

    Pandaxclone2 Pokemon Sprite Artist Hobbyist

    Member
    1,000
    394
    Aug 17, 2015
    noun; a particular place or position.
    Pretty sure you have to format the system twice not with system settings but with TinyFormat instead. Doing so should wipe the system enough to make it work. (Although I'm not sure if this will help, it was part of the A9LH guide.)
     
    Xiphiidae likes this.
  9. Lia

    Lia is this the real life

    Member
    1,502
    2,931
    Jan 29, 2016
    United Kingdom
    What cfw are you using? If you're using lima3ds make sure you update to the latest version if you haven't
     
  10. Dorimori

    Dorimori professional lurker

    Member
    409
    1,090
    Mar 17, 2016
    United States
    possibly in your closet
    Make sure you aren't using the dev version of luma.
     
  11. nero99

    nero99 GBAtemp Advanced Maniac

    Member
    1,906
    866
    Sep 18, 2014
    United States
    Restart your system while pressing the select button until the luma config shows up. You may have dev mode enabled. If you do, simply turn dev mode off and you'll be good to go.
     
  12. ih8ih8sn0w

    ih8ih8sn0w Koreaboo

    Member
    1,656
    720
    Aug 22, 2015
    United States
    Hell
    Do you know if you linked an NNID to your sysnand? There was an issue a while back that I had where after I unlinked my nands, the NNID was still linked to emunand, but nintendo servers had my NNID flagged as unlinked or something.
     
  13. xdrz
    OP

    xdrz Member

    Newcomer
    45
    3
    Aug 8, 2015
    Hong Kong
    I am not in dev version of luma3ds and I had checked that the luma3ds is the latest version (5.5) already...

    As I had done until the final step of the github's guide,
    which means I have only sysnand of 11.0.0-33U in the 3ds,
    is it effective to format it by Tinyformat?
    I need to backup nand and sd card file and format by Tinyformat and put all the things back in sd card?

    PS: What I found is that after I format by system setting, the information of NNID is still can be seen after I restore the nand and file back, had I unlinked the NNID?

    PS: I had try to use tiny format but why the file in SD had not been removed?
     
    Last edited by xdrz, Jun 17, 2016
  14. xdrz
    OP

    xdrz Member

    Newcomer
    45
    3
    Aug 8, 2015
    Hong Kong
    actually why my file in sd card had not been removed after formating?
    (both Tinyformat and system setting way)
     
  15. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,868
    5,020
    Mar 17, 2010
    Norway
    Alola
    This happens when you format through system settings with a NNID linked. That's one of the reasons you are supposed to use TinyFormat.
    If you have a spare SD card you can set up an emuNAND on it, format the emuNAND through system settings and link your NNID, which should get it working again on your sysNAND. Or if you don't have a spare SD card, back up your SD card contents and do the same thing.
     
  16. xdrz
    OP

    xdrz Member

    Newcomer
    45
    3
    Aug 8, 2015
    Hong Kong
    I have set up an emunand on the same sd card, format emunand in system setting and link NNID on emunand,
    then I found that both emunand and sysnand cannot access eshop,
    should I then format the sd card and restore all the things back?
    or should I link the NNID in sysnand?

    I am just wondering if it is the problem of NNID?
    I found that even I sign for another NNID, I still cannot access eshop with the same error code
    but even the sysnand and emunand were both formatted for one time and I still cannot access eshop
     
    Last edited by xdrz, Jun 18, 2016
  17. xdrz
    OP

    xdrz Member

    Newcomer
    45
    3
    Aug 8, 2015
    Hong Kong
    Although it has already a long time,
    Any solution to this problem?
    What I have tried more:
    1. Use Decrypt9 dump the nnidsav.bin and modify the content to FFFF...., And inject back. =>Still same error code
    2. Delete NNID => still same error code

    Any other way to solve this problem?

    Ps: I just found that other people who had done region change would encounter this error code. Although I had done region change on emunand 2 years ago to play before a9lh hack, I had not changed region now with 11.2U
     
    Last edited by xdrz, Dec 5, 2016
  18. Kinnayan

    Kinnayan Member

    Newcomer
    13
    0
    Oct 18, 2016
    Gibraltar
    So what was it originally, U, E or J

    Sent from my A0001 using Tapatalk
     
  19. xdrz
    OP

    xdrz Member

    Newcomer
    45
    3
    Aug 8, 2015
    Hong Kong
    it is originally U,
    is my problem of secure_info_A? Do I need to inject another U secure_info in case make sure it is right secure_info?

    Actually, I do not care losing original data,
    Can I set up a completely fresh emunand?
     
    Last edited by xdrz, Dec 6, 2016