[a9lh] DS Mode not working in Emunand

Discussion in '3DS - Flashcards & Custom Firmwares' started by GothicIII, May 17, 2016.

  1. GothicIII
    OP

    GothicIII GBAtemp Fan

    Member
    499
    137
    Jan 4, 2015
    Gambia, The
    I've got two N3DS. On the first one everything is working as expected. Its setup is a9lh+luma3ds(emunand). DS Games working without problems.

    On the other one its a9lh+ctrboot9+luma3ds/cakesfw/gateway (all emunand).
    On this one DS Games are not working on Emunand :/ Neither on luma3ds nor cakesfw nor gateway.
    They only work when I load up cakesfw/luma3ds on Sysnand.

    I thought maybe twl firm got broken on sysnand because I installed a9lh and restored emunand on it. So I loaded up 0004013820000102.cia for fw9.2.0 (which my sysnand is) and installed it. Still not working.
    If I understand correctly when entering DSMode from emunand the 3ds loads the sysnand twl_firm

    Got anyone an idea whats wrong here? I can't remember installing any twl firm patches. Wtf is wrong. Its working on the first 3DS without problems.
     
  2. Davidosky99

    Davidosky99 Eevee :3

    Banned
    2,582
    1,570
    Jun 7, 2015
    Porto
    first, you have ctrboot9 so it might not work, as it is known to break twl firm.
    second, you should update to 11.0 and do a system format to delete the patched twl firm.
    It should work if you do both of those things
     
  3. Naendow

    Naendow Brick-Master

    Member
    284
    95
    Jan 4, 2016
    Germany
    The best solution is to use your sysnand instead of an emunand. There is no reason for anyway as long as you have a9lh.
    My sysnand is on 11.0.0-33 without any problems. Every function works perfectly. ;)

    Sorry, I do not have any other solution for you. But that is the better way.
     
  4. Davidosky99

    Davidosky99 Eevee :3

    Banned
    2,582
    1,570
    Jun 7, 2015
    Porto
    he patched twl firm and he's using luma3ds so that can't do anything
     
  5. GothicIII
    OP

    GothicIII GBAtemp Fan

    Member
    499
    137
    Jan 4, 2015
    Gambia, The
    Thanks for the reply. I won't switch to sysnand. I have my reasons to stay there :) Please I don't want another thread messed up with a discussion about sysnand is better than emunand.

    So you mean that CTRBOOT9 is the culprit? Why its working on sysnand then?
     
  6. Davidosky99

    Davidosky99 Eevee :3

    Banned
    2,582
    1,570
    Jun 7, 2015
    Porto
    both patched twl firm and ctrboot9 is the culprit.
     
  7. GothicIII
    OP

    GothicIII GBAtemp Fan

    Member
    499
    137
    Jan 4, 2015
    Gambia, The
    @Davidosky99: It's not Im not believing you but I cannot find a source that sais Ctrboot9 breaks twl_firm :unsure:
    And I still didnt understand it.
    Do you mean that ctrboot9 patches twl_firm on the fly and then cakesfw/luma3ds patch it again so it breaks? I want to understand the problem. It also doesn't explain it why it works on sysnand (Im loading cfw when entering sysnand).

    EDIT: Ctrboot9 is indeed the culprit. Thanks
     
    Last edited by GothicIII, May 17, 2016