A Weird EZ Flash IV Problem - SD Cards Stop Working

Discussion in 'GBA - Flashing Hardware and Software' started by MogKnight, May 6, 2016.

  1. MogKnight
    OP

    MogKnight Newbie

    Newcomer
    1
    0
    Feb 8, 2007
    United States
    So, I'm gonna try to best explain this as much as I can because thinking about it right now makes my head hurt.

    I bought a EZ Flash IV which supports microSD and has the 1.77 kernel already installed. I also bought me a SanDisk 32gb microSD. I used the EZ4 Client to transfer one game over, popped it into the EZ Flash, and it worked just fine. Then I decided to throw in about 60 some odd games, popped it back into the EZ Flash and I get an "Unknown Operation" error when I try to access the folder.

    So all right, pop the SD card back into my compy, delete all the files, go back to square one with just one game and it still gives me the error. Reformatted FAT32 with 32kb allocation, put a game in and nothing. Put it in without a game in just to see if it would do anything different and nothing.

    "Well, maybe I somehow messed up my SD card?" but the SD card still works on everything else (including a DS flash cart that I have). All right, lemme try another SD card: A toshiba 4gb that came with the New 3DS that I have laying around. Put a game in, works fine. Decided to reflash the 1.77 firmware just in case and that works fine. Again, one game, works fine. Put more games in, stops working. Erased everything, still doesn't work. Formatted, still doesn't work.

    Whatever is going on, whenever I put in a bunch of games, it seems to completely render the SD card unusable. But no matter how I format it (even with SDformatter) and no matter what i do, none of the SD cards I mentioned works. I formatted it on another computer (of note: I run Windows 10, the other Windows 7), I even shoved it in an Android phone and formatted it there. I'm hesitant on ordering another SD card in fear that it would do the same thing where it'll work for a short bit and then suddenly stop working.

    Does anyone know what could be going on here? Maybe a bug with EZ4 Client that causes something to happen to the SD card?
     
  2. mech

    mech ♥️♥️♥️♥️♥️♥️♥️♥️

    Member
    4,590
    2,871
    Oct 26, 2014
    Tuvalu
    sounds like a fake sd card.
     
  3. Boured

    Boured The most perverted furry

    Member
    GBAtemp Patron
    Boured is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    532
    383
    Sep 25, 2015
    United States
    Wherever I log in at ^w^
    Try this

    1.Open Start Menu and click Run
    2. Type diskpart and press okay
    3. wait for it to load
    4. type "list disk" without the ""
    5. select your sd card using the command "select disk (insert disk number here, should be the one that is small than the other if you are running a system with a big hard drive)
    6. type "clean" without ""
    7. type "convert mbr" without ""
    8. type "create partition primary" without ""
    9. type "format quick" without the ""

    You should have made a new partition on the sd that is good, so if the old partition was bad this will fix it. Though it is best to do a format without diskpart as a FAT32 without selecting Quick Format, It may take awhile but it will check and fix all bad sectors of the sd card. Let me know if that fixed it for you.