"A system update is required to use the microsdxc memory card" - what to do

dandandan

Member
OP
Newcomer
Joined
Jul 30, 2012
Messages
18
Trophies
0
XP
98
Country
Hi, I've finally gotten around to hacking my Switch. I got it when it first came out and have barely touched it since.

I'm on version 5.1.0

I've tried a couple of different guides, but when I get to the payload injection stage I get a fatal error

When I boot back into the regular homescreen, it tells me I need to format the SD card (512gb, FAT32), and when I try to format it in the Switch, it says:

"a system update is required to use the microsdxc memory card"

I assume it's because MicroSDXC cards weren't originally compatible. But if I let it update, will I be put straight onto the latest firmware or will it happen incrementally?

I want to update it just enough to recognise MicroSDXC cards without updating it enough to fix the exploit

All the threads I've seen here blame this error message on exFAT, but my card is definitely FAT32, and I've tried a few different cards. The only one that works is a measly 32gb
 

Shadow#1

Wii, 3DS Softmod & Dumpster Diving Expert
Member
Joined
Nov 21, 2005
Messages
11,590
Trophies
1
XP
7,013
Country
United States
Hi, I've finally gotten around to hacking my Switch. I got it when it first came out and have barely touched it since.

I'm on version 5.1.0

I've tried a couple of different guides, but when I get to the payload injection stage I get a fatal error

When I boot back into the regular homescreen, it tells me I need to format the SD card (512gb, FAT32), and when I try to format it in the Switch, it says:

"a system update is required to use the microsdxc memory card"

I assume it's because MicroSDXC cards weren't originally compatible. But if I let it update, will I be put straight onto the latest firmware or will it happen incrementally?

I want to update it just enough to recognise MicroSDXC cards without updating it enough to fix the exploit

All the threads I've seen here blame this error message on exFAT, but my card is definitely FAT32, and I've tried a few different cards. The only one that works is a measly 32gb
Its still exFAT if u get this msg
 
Last edited by Shadow#1,
  • Like
Reactions: Lacius

Lacius

Well-Known Member
Member
Joined
May 11, 2008
Messages
17,885
Trophies
2
XP
17,838
Country
United States
You're receiving this error message because your SD card is not formatted as FAT32. Use guiformat to reformat the SD card as FAT32. If you get an error message on Windows, you probably need to restart Windows Explorer from the Task Manager.

If you want to use an exFAT SD card (not recommended), you either need to update to the latest version from the system settings, or you need to add exFAT support using a different SD card that's formatted as FAT32 and the homebrew application Daybreak while running Atmosphere.

If you're using fusee-gelee, then the system version of your Switch really doesn't matter as long as it's supported by the latest version of Atmosphere. The latest system version that's exploitable without fusee-gelee or a modchip is 4.1.0. In other words, unless you're using something other than fusee-gelee or a modchip, there's no reason not to update to the latest system version for game compatibility, etc.
 

OrGoN3

Well-Known Member
Member
Joined
Apr 23, 2007
Messages
3,164
Trophies
0
XP
2,584
Country
United States
You're receiving this error message because your SD card is not formatted as FAT32. Use guiformat to reformat the SD card as FAT32. If you get an error message on Windows, you probably need to restart Windows Explorer from the Task Manager.

If you want to use an exFAT SD card (not recommended), you either need to update to the latest version from the system settings, or you need to add exFAT support using a different SD card that's formatted as FAT32 and the homebrew application Daybreak while running Atmosphere.

If you're using fusee-gelee, then the system version of your Switch really doesn't matter as long as it's supported by the latest version of Atmosphere. The latest system version that's exploitable without fusee-gelee or a modchip is 4.1.0. In other words, unless you're using something other than fusee-gelee or a modchip, there's no reason not to update to the latest system version for game compatibility, etc.
Or if he has a clean sysnand, boot clean sysnand, make sure it's online, go to System settings, go to format microSD card. You might have to keep clicking a few times, or say you want exFAT. It'll download the exFAT driver before you have to format anything.

Also, doesn't just inserting an exFAT formatted SD card into clean sysnand while it's online prompt the same thing?

Lastly, please do not use guiformat. This isn't the 3DS days. Please use either Hekate, or a real program such as minitool partition or diskgenius.
 

Lacius

Well-Known Member
Member
Joined
May 11, 2008
Messages
17,885
Trophies
2
XP
17,838
Country
United States
I can't use guiformat. For some reason, I click on it and it doesn't do anything. I used EASEUS though, and that formatted it to FAT32. Windows even says it's FAT32
Use guiformat. If you are having issues, open Task Manager, restart Windows Explorer, and then try again.
 

dandandan

Member
OP
Newcomer
Joined
Jul 30, 2012
Messages
18
Trophies
0
XP
98
Country
I was using the version from CNET, but I downloaded it straight from the Dev's website (Ridgecrop Consultants) and that actually launched the app. Formatted the card, everything at default, followed all the same instructions as before, and I still get this message:

A fatal error occurred when running Fusée.
Failed to mount the SD card.

Press POWER to reboot.
 

dandandan

Member
OP
Newcomer
Joined
Jul 30, 2012
Messages
18
Trophies
0
XP
98
Country
Like I said, it was definitely FAT32. The 32 gig card (also FAT32) does boot into Atmosphere but then it drops and continues to the regular Switch home menu 🤷🏻‍♂️
 

OrGoN3

Well-Known Member
Member
Joined
Apr 23, 2007
Messages
3,164
Trophies
0
XP
2,584
Country
United States
There is no reason not to use guiformat, and with it, we know it's going to result in a properly formatted FAT32 SD card, since that's the only option.
I've had a lot of people with the Switch not reading their SD cards properly after using guiformat. Since then, I always recommend Hekate, or a real partition program.
 

Lacius

Well-Known Member
Member
Joined
May 11, 2008
Messages
17,885
Trophies
2
XP
17,838
Country
United States
I was using the version from CNET, but I downloaded it straight from the Dev's website (Ridgecrop Consultants) and that actually launched the app. Formatted the card, everything at default, followed all the same instructions as before, and I still get this message:

A fatal error occurred when running Fusée.
Failed to mount the SD card.

Press POWER to reboot.
Do you know that your SD reader works on the Switch?
 
  • Like
Reactions: OrGoN3

dandandan

Member
OP
Newcomer
Joined
Jul 30, 2012
Messages
18
Trophies
0
XP
98
Country
Do you know that your SD reader works on the Switch?
How would I test this? A 32gb card worked fine, if that's any indication (was also FAT32)

I've barely used it, and never inserted an SD card into it before, so I don't know how it could be damaged, unless it came like that already
 

Lacius

Well-Known Member
Member
Joined
May 11, 2008
Messages
17,885
Trophies
2
XP
17,838
Country
United States
How would I test this? A 32gb card worked fine, if that's any indication (was also FAT32)

I've barely used it, and never inserted an SD card into it before, so I don't know how it could be damaged, unless it came like that already
To be clear, can you run Atmosphere using the working SD card?
 

GamingTable

Active Member
Newcomer
Joined
Nov 4, 2021
Messages
27
Trophies
0
Age
102
XP
42
Country
United States
  • Like
Reactions: Lacius
General chit-chat
Help Users
    NeoGaming @ NeoGaming: https://www.youtube.com/watch?v=IMxuHJoi4RA