A question about playing nds games on a 3ds xl w/flashcard.

Discussion in 'NDS - Flashcarts and Accessories' started by Scyris, Feb 26, 2013.

  1. Scyris
    OP

    Newcomer Scyris Advanced Member

    Joined:
    May 31, 2009
    Messages:
    79
    Country:
    Canada
    So I hear the Supercard DSTwo can play nds games on a 3ds with no issues, is that true even on the most recent update? I currently have an acecard 2.1 w/akaio firmware, heard it don't work though.

    Anyway on with the questions. One is a general question.

    1)If I have a 3ds XL and play a nds game on it, will it use the full screen as if it was a dsi-xl? This is the major decision maker on whether I'll buy a new flashcard to play my nds games on my 3ds. If it still uses the default nds screen size, I might as well just keep using my nds, but, if it will use the XL's full screensize, then its probally worth me getting a Supercard DSTwo.

    2) As I asked orignally does the supercard DSTwo work for playing nds games even on the newest firmware? I am the type who never updates firmware on these hand-helds unless I have to, to play something, if it works why fix it right?

    Thanks for answering these, on the 28th of feb I am thinking of buying a 3ds and getting Etrian odyssey 4 with it at my local future shop.

    Edit: I forgot to ask, where can I buy a supercard DSTwo from a online store that is based in canada so I don't get stuck paying the stupidly high import tax/duty on the items I am bringing in.
     
  2. Foxhounder

    Banned Foxhounder Banned

    Joined:
    Jan 20, 2013
    Messages:
    102
    Country:
    United States
  3. Garro

    Member Garro Pendulum of souls!

    Joined:
    Aug 15, 2009
    Messages:
    530
    Location:
    Somewhere
    Country:
    Chile
    1) You can play on both full screen or default DS screen (by holding select when running the game). This is for any DS game including the DSTwo and any other flashcart.

    2) Yeah, DSTwo works with the last version up to date. You are never forced to update, but the eShop and some games ask for the 3DS to be on the last version.

    And for where to puchase it, I guess you could look into Shoptemp for a list of stores.
     
  4. Rydian

    Member Rydian Resident Furvertâ„¢

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Yes the DSTwo works on the latest 3DS firmware.

    The Acekard 2.1 does not work on anything past the DS Lite. The Acekard 2i was the followup product for later DS models, but that stopped getting updates for technical reasons.

    http://www.modchipcentral.com/store/
    I've ordered from here to the US a few times, apparently they're somewhere in CA, couldn't tell you specifically.
     
  5. Scyris
    OP

    Newcomer Scyris Advanced Member

    Joined:
    May 31, 2009
    Messages:
    79
    Country:
    Canada
    Ahh thanks Rydian, yeah they are in Waterloo ontario in canada, that place is perfect for what I need. Thanks.
     

Share This Page