1. snam11

    snam11 GBAtemp Regular
    Member

    Joined:
    Jan 10, 2007
    Messages:
    108
    Country:
    United States
    @mattytrog i did my homeworks:

    original uf2 (sx loader)
    d0 vol+
    d3 joy
    at power up it autoboots on cfw,but as soon i press reset button (i.e to reflash u2l), the vol- button doesn't work anymore (it rises vol at max like i was keep on pressing vol+)
    usbc connected and power off,(powering up) with double tap on reset button the drive doesn't show up.


    original uf2 loader with your pinout
    d0 joy
    d3 vol+
    at power up it autoboots on cfw,but vol- doesn't work (no need to press reset button, it doesn't work at all)
    usbc connected and power off, the switch doesn't power up


    your mode2 trinket uf2

    d0 vol+
    d3 joy
    no boot at all
    removing vol+, it boots on ofw. power+vol doesn't boot a thing
    usbc connected the flash drive shows up

    d0 joy
    d3 vol+
    no boot at all
    removing vol+, it boots on ofw, power+vol doesn't boot a thing
    usbc connected the flash drive doesn't show up

    i've noticed the original flash was named TRINKETBOOT, once i've flashed the mode2 uf2 file is now SWITCHBOOT.
    And it keeps that name also after flashing back original uf2.
     
  2. mattytrog

    mattytrog You don`t want to listen to anything I say.
    Member

    Joined:
    Apr 27, 2018
    Messages:
    3,708
    Country:
    United Kingdom
    Thanks. More homework needed then...
    The manufacturer states it uses Trinket files. I find this strange as the chip is a non-crystalled SAMD21-G18 (48 pin). Trinkets / rebug use the E18 (32 pin). So I think what I`m going to do is build based on the ItsyBitsy M0 which is closer.
     
    snam11 likes this.
  3. snam11

    snam11 GBAtemp Regular
    Member

    Joined:
    Jan 10, 2007
    Messages:
    108
    Country:
    United States
    thanx for your hard work mate
     
    mattytrog likes this.
  4. snam11

    snam11 GBAtemp Regular
    Member

    Joined:
    Jan 10, 2007
    Messages:
    108
    Country:
    United States
    @mattytrog a little update on the "mistery" chip quest.

    using your mode2 uf2 files actually works (first flash using Version_2_trinket_rebug_both_straps.uf2, than 2nd flash with 4A3C_Trinket_Rebug_mode2.UF2)
    the no boot was actually a problem loading the payload.bin on sd (probably a bad copy).
    replacing the bin was the solution, but i have with same issues of original uf2:
    d0 vol+/d3 joy: broken vol- as soon i press reset
    d0 joy/d3 vol+: always broken vol-, no flash connection

    i'm 100% positive the vol+ strap soldering is good, also because the button works fine, the issue happens after the reset trigger...

    i hope it can help you to find a fix..

    thanx

    EDIT: i did a try also with the joy strip soldering on the motherboard (bridging both pads, and just with the left pad) but the result is the same, so is not a wire issue.
     
    Last edited by snam11, Dec 6, 2018
  5. xxxacexxx

    xxxacexxx Advanced Member
    Newcomer

    Joined:
    Mar 14, 2009
    Messages:
    50
    Country:
    United States
    respect to you sir excellent job, but maybe you should have incorporated subtitles for us who find it difficult to understand what your saying. thank you.....
     
    vincentallen2 likes this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - AliExpress, Nintendo, Modchip