Hacking Question A little EmuMMC problem...

Kunzel

Member
OP
Newcomer
Joined
May 9, 2021
Messages
8
Trophies
0
Age
25
XP
48
Country
Brazil
Hello there! I'm new to the HB scene so I'm not quite sure about what's going on. About a week or two ago I successfully ran Atmosphere and Hekate on my switch (Atmosphere 0.19.2 & Hekate 5.5.5, which are the versions I'm currently using.) I was following the "switch.homebrew.guide" and by the end, it was written that creating an EmuMMC was the safest way to get around bans and whatnot. Since I only had a 32gb card, I bought a 128gb SD Card. I tested it through h2testw and it seems like it's neither defective nor fakem but ever since partitioning it and trying to boot into emuMMC/Atmosphere, it simply won't work.

If I try to boot straight into Atmosphere through its payload on my PC, I just get the "Failed to mounnt emuMMC from sd card partition!" error. If I try to do it through Hekate, I get the "Unknown pkg1 Version. HOS version not supported! Or emuMMC corrupt! Trying backup bootloader...". It then says "Found pkg1 (´´)", then goes into "unknown pkg1 versoin. HOS version not supported! Or emuMMC corrupt! Failed to launch HOS!". Then if I press any key, it sends me back to Hekate.

Anybody got a clue as to what's possibly going on? I read about some people saying that they never really created an EmuMMC on their SD Cards and that it could be the key to solving this problem, but I never really understand how they ended up fixing it since they never give out the details proper. Could you guys please help? Thanks in advance.
 
Last edited by Kunzel,

petspeed

Well-Known Member
Member
Joined
Nov 13, 2009
Messages
827
Trophies
0
Age
47
XP
722
Country
Denmark
I used the guide on https://nh-server.github.io/switch-guide/ myself back when I modded my Switch and it worked fine. I compared it to the EmuMMC guide on switch.homebrew.guide and noticed that is doesn't mention the part where you press 'Change emuMMC' and select the RAW 1 partition. I am not sure but it might be needed to create the emummc.txt file so try to do that. It's in the EmuMMC screen in Hekate.
 

Kunzel

Member
OP
Newcomer
Joined
May 9, 2021
Messages
8
Trophies
0
Age
25
XP
48
Country
Brazil
I used the guide on [LINK] myself back when I modded my Switch and it worked fine. I compared it to the EmuMMC guide on switch.homebrew.guide and noticed that is doesn't mention the part where you press 'Change emuMMC' and select the RAW 1 partition. I am not sure but it might be needed to create the emummc.txt file so try to do that. It's in the EmuMMC screen in Hekate.

I just tried that, but unfortunately the same error keeps popping up. :( I'm not quite sure about what's going on here, but thank you for the suggestion!

The funny thing is, if I don't partition my SD card and just boot into atmosphere through fusee-payload normally, everything works fine. It's when I try to boot to emuMMC that the problem starts occurring, at which point I can't even boot into Atmosphere anymore.
 

petspeed

Well-Known Member
Member
Joined
Nov 13, 2009
Messages
827
Trophies
0
Age
47
XP
722
Country
Denmark
If you put your sd card in your computer can you see an extra partition? It usually pops up sayingg that the drive cnnot be read and ask you to format it. Don't do that. If you have created an EmuMMC you should have that extra partition. You should also have a file called emuMMC\emummc.ini on your SD card. That file contains the info that Atmosphere needs to boot EmuMMC. If you paste the contant of that file here I or someone else can validate whether it is correct.
 

Kunzel

Member
OP
Newcomer
Joined
May 9, 2021
Messages
8
Trophies
0
Age
25
XP
48
Country
Brazil
It automatically boots into the accessible partition (which is 95gb in size), but if I access the Windows Disk Manager, I can see that it is indeed partitioned (with the emuMMC partition being 29gb in size). Btw here's what's in the file:

[emummc]
enabled=1
sector=0xbfb8800
path=emuMMC/RAW1
id=0x0000
nintendo_path=emuMMC/RAW1/Nintendo

And... weirdly that's all there is to it now. Which is really weird! I checked it yesterday a while before starting this thread and it had a lot more stuff in it... I did do a fresh reinstall of the files on my SD Card (to see if it would fix things, but it didn't), so that could possibly be the cause of this. In any case, all help is greatly appreciated. Thank you for taking your time to help.

EDIT: I tried taking a picture of the error I keep getting when trying to boot into CFW emuMMC from Hekate. I tried taking a better picture but it's a little dark around here, so I'm really sorry about the bad quality. But I hope it can help in at least visually identify what can be going on...

20210509_160420.jpg

Unknown pkg1 version.
HOS version not supported!
Or emuMMC corrupt!
Trying backup bootloader...

Found pkg1 (´´)

Unknown pkg1 version.
HOS version not supported!
Or emuMMC corrupt!

Failed to launch HOS!


Press any key...
 
Last edited by Kunzel,

Kunzel

Member
OP
Newcomer
Joined
May 9, 2021
Messages
8
Trophies
0
Age
25
XP
48
Country
Brazil
I did try to use fusee-primary as payload, but when I try doing that it just goes into a black-ish screen saying "[ ERROR ] Fatal error: Nxboot failed to mount emuMMC from SD card partition!" :(

IMG_20210509_171435394.jpg


And here's what's on my hekate_ipl.ini:

[config]
autoboot=0
autoboot_list=0
autohosoff=1
autonogc=1
backlight=100
bootwait=3
updater2p=0

[CFW (sysMMC)]
emummc_force_disable=1
fss0=atmosphere/fusee-secondary.bin
icon=bootloader/res/icon_payload.bmp

[CFW (emuMMC)]
emummcforce=1
fss0=atmosphere/fusee-secondary.bin
icon=bootloader/res/icon_payload.bmp

[Stock]
emummc_force_disable=1
fss0=atmosphere/fusee-secondary.bin
icon=bootloader/res/icon_switch.bmp
stock=1

[Fusee]
icon=bootloader/res/icon_payload.bmp
payload=bootloader/payloads/fusee-primary.bin

EDIT: Ran h2testw again just to be sure, and sure enough it gave me the "drive may be defective" message. I'm gonna get a new SD card (thankfully I can still send this one back and get a refund) and try again ASAP.
 
Last edited by Kunzel,

Draxzelex

Well-Known Member
Member
Joined
Aug 6, 2017
Messages
17,127
Trophies
1
Age
27
Location
New York City
XP
11,427
Country
United States
Hello there! I'm new to the HB scene so I'm not quite sure about what's going on. About a week or two ago I successfully ran Atmosphere and Hekate on my switch (Atmosphere 0.19.2 & Hekate 5.5.5, which are the versions I'm currently using.) I was following the "switch.homebrew.guide" and by the end, it was written that creating an EmuMMC was the safest way to get around bans and whatnot. Since I only had a 32gb card, I bought a 128gb SD Card. I tested it through h2testw and it seems like it's neither defective nor fakem but ever since partitioning it and trying to boot into emuMMC/Atmosphere, it simply won't work.

If I try to boot straight into Atmosphere through its payload on my PC, I just get the "Failed to mounnt emuMMC from sd card partition!" error. If I try to do it through Hekate, I get the "Unknown pkg1 Version. HOS version not supported! Or emuMMC corrupt! Trying backup bootloader...". It then says "Found pkg1 (´´)", then goes into "unknown pkg1 versoin. HOS version not supported! Or emuMMC corrupt! Failed to launch HOS!". Then if I press any key, it sends me back to Hekate.

Anybody got a clue as to what's possibly going on? I read about some people saying that they never really created an EmuMMC on their SD Cards and that it could be the key to solving this problem, but I never really understand how they ended up fixing it since they never give out the details proper. Could you guys please help? Thanks in advance.
Also what is your firmware? That may be a problem as well if its really low or high.
 
General chit-chat
Help Users
    Psionic Roshambo @ Psionic Roshambo: Eventually I will be back to just meth like a normal Florida Man lol