A few questions regarding CFW, emuNAND and CIAs

Discussion in '3DS - Flashcards & Custom Firmwares' started by Clothahump, Sep 4, 2015.

  1. Clothahump
    OP

    Clothahump Advanced Member

    Newcomer
    71
    29
    Aug 28, 2015
    All right, here's the deal.
    I'm about to receive my New 3DS XL and I'm currently praying it comes with a fw <= 9.2.
    In case it does, I want to get the most out of it, modification-/freedom-wise.
    I already own a Sky3DS, what I am looking for is a custom firmware that allows installation of unsigned CIAs (my guess would be Pasta).
    On the other hand I'd really like to have a 9.5 emuNAND and I think that's only possible with a Gateway, right?
    In addition to that, I've read a few things about CIAs and that they could potentially brick one's device (when installed to sysNAND). As Pasta runs in sysNAND, could a certain malformed / corrupted CIA brick my system?
    Next question would be: to boot into emuNAND, do I absolutely need a Gateway? Or would a new 3ds <= 9.2 and a Sky3DS be enough to get the most out of my device?

    Sorry about the bad structure of this post. All I'm really looking for is advice from experienced users on what my options are, basically.
     
  2. lemanuel

    lemanuel Maxconsole's All-Knowing Lurker

    Member
    2,095
    1,093
    Dec 11, 2014
    Portugal
    CFW for N3DS that can use emunand:

    Gateway
    rxTools (still in development but available in nightlies already)
    Reinand
    CakesFW (not sure)

    Not sure if there's any other but that already gives you plenty of alternatives to try ;)
     
  3. Clothahump
    OP

    Clothahump Advanced Member

    Newcomer
    71
    29
    Aug 28, 2015
    Sounds like I gotta look out for an rxTools nightly then, I've read lots of positive things about that one.
    I do still need a Gateway card to boot into emuNAND, don't I?
    Also I should've noted in the OP that I also have a Supercard DSTwo, just in case.
     
  4. usernametaken

    usernametaken GBAtemp Maniac

    Member
    1,250
    345
    May 13, 2015
    United States
    You don't need a gateway cart to setup emunand. You can do it with Cubic Ninja / Youtubehax (If you have the app already).
    You can use the DSTwo to install the profile launchers exploit for whichever cfw you choose.
     
  5. lemanuel

    lemanuel Maxconsole's All-Knowing Lurker

    Member
    2,095
    1,093
    Dec 11, 2014
    Portugal
    You need GW launcher to create (format) emunand but you don't actually need the card to use it.
    So, no. When using a different CFW, you don't need to have GW card to boot into emunand or to create it.
     
  6. Just3DS

    Just3DS GBAtemp Fan

    Member
    440
    109
    Jan 31, 2015
    You need to have firmware on or below 9.2 with browser (only JPN 8.1don't have it) and Cubic Ninja or OOT (you got Sky3DS for that). You can then just get the GW launcher.dat file to create emuNAND.
     
  7. Clothahump
    OP

    Clothahump Advanced Member

    Newcomer
    71
    29
    Aug 28, 2015
    So just to make sure I got that right, given my setup, I would only need a Gateway card if I wanted to boot the Gateway custom firmware?
    Any other setup goes without a Gateway card?
     
  8. Just3DS

    Just3DS GBAtemp Fan

    Member
    440
    109
    Jan 31, 2015
    I have heard good about Rei's CFW and RxTools.
     
  9. lemanuel

    lemanuel Maxconsole's All-Knowing Lurker

    Member
    2,095
    1,093
    Dec 11, 2014
    Portugal
    Exactly. If you want to use GW Mode you need the GW card. If you want to do anything else, you don't need it.

    So to format emunand, you just need to access the GW launcher and it's a one time process anyway without requiring the card. And to boot into emunand, any of the mentioned CFWs can do it just like GW would but without needing any card.
     
  10. Clothahump
    OP

    Clothahump Advanced Member

    Newcomer
    71
    29
    Aug 28, 2015
    So that ReiNAND CFW combined with rxTools?

    This is awesome. Thanks a bunch!
     
  11. lemanuel

    lemanuel Maxconsole's All-Knowing Lurker

    Member
    2,095
    1,093
    Dec 11, 2014
    Portugal
    He was saying he heard good things about both of them, not that they're together ;)

    And you're welcome.
     
  12. Clothahump
    OP

    Clothahump Advanced Member

    Newcomer
    71
    29
    Aug 28, 2015
    I see. Was confused for a minute. I'll manage though. Thanks again :)
     
  13. Clothahump
    OP

    Clothahump Advanced Member

    Newcomer
    71
    29
    Aug 28, 2015
    Reporting back. Got the device, it came with 9.4 (bummer :( )
    Seeking advice again. Update to 9.9 or stay on 9.4? How likely would you consider the chances of a possible new vulnerability to be compatible with 9.4 but not with 9.9? Are the teams generally looking into the latest firmware or just about any firmware currently "un"hacked?
     
  14. lemanuel

    lemanuel Maxconsole's All-Knowing Lurker

    Member
    2,095
    1,093
    Dec 11, 2014
    Portugal
    Usually if some exploit is found for the latest firmware, it also exists for the firmwares before that one. But that doesn't mean they don't look to others aside from the latest.
    But there's really no way to know when a new exploit will appear to allow what you want. Might happen next week or might happen in a year. So the best to do is really not to wait for it.

    You don't really have advantages in staying in 9.4 anyway so updating to the latest firmware is probably the best. At least you'll be able to access eShop that way and maybe also install the youtube app which allows you to run Tubehax. You can play homebrew and use the save manager that exists right now.

    But if you really want to play roms and everything else that an exploitable firmware allows, your only choice is to get another console.
     
  15. Clothahump
    OP

    Clothahump Advanced Member

    Newcomer
    71
    29
    Aug 28, 2015
    All right, updating then. Once again, I appreciate your advice.

    Already got an old 3ds on 9.9 rocking smea's userland homebrew (mainly for the savegame manager) so I guess there's no real need to put that thing on my new 3ds as well. Would've gone for emuNAND and a CFW, but I guess I'm out of luck :D

    Let's see what future has, and hope for the best.
     
    lemanuel likes this.