A Couple of questions in regards to hacking the O3dsXL

Pl4yst4tionRox

Active Member
OP
Newcomer
Joined
Feb 16, 2021
Messages
37
Trophies
0
Age
43
XP
176
Country
United States
Hello Everyone,

I recently bought a O3DSXL and today i have been doing alot of research on how to hack my O3DSXL which is on 4.4.0-10
I just upgraded my N3DSXL with lumas3DS 10.2.1 along with the latest OFW. I followed the 3DS Hack guide. As I was doing research on how to put the homebrew channel on my O3DSXL i stumbled on Boot NTR and realized that Lumas 10,2.1 cannot use ntr bootloader anymore and i have to use 3gx loader instead. The problem with that Is that I have a .plg for Fantasy Life and it won't work with the 3gx loader. Years ago I had a Gateway card and sadly I lost it. I would like to stay away from having to spend any money for a flash card but I am NOT totally against the idea. I was able to find a heck of alot on firmware 4.4.0-10 except in regards to flashcards especially Gateway So with all that said here are my questions. I would like to use plug-ins.

1) What is the best homebrew exploit for this version software?

2) I would like to upgrade my system from 4.4.0-10 to 9.2 as I have read that is the golden firmware where almost all CFW apps will work. How would I go about doing this?

3) Is there a way to downgrade from Lumas3DS 10.2.1 to 10.0? (N3DSXL)

4) What Flash Card would you guys recommend if i decide to go that route?

I would like to say thanks in advance for any help that I may recieve from this post
 

lilyuwuu

Well-Known Member
Newcomer
Joined
Sep 7, 2020
Messages
69
Trophies
0
XP
444
Country
Antarctica
1. What is the best homebrew exploit for this software?
The method on 3ds.hacks.guide is Installing boot9strap (Soundhax), which as the page suggests would install boot9strap (basically, the exact same setup as your N3DS).

2. I would like to upgrade my system from 4.4.0-10 to 9.2 as I have read that is the golden firmware where almost all CFW apps will work. How would I go about doing this?
Well... you're both right and wrong. Some homebrew applications (particularly anything made in 2016 and earlier) were made in the *hax days with older firmwares in mind and may not work properly on the latest firmwares. I would like to stress that staying on older firmwares is not recommended for the following reasons:

- Genuine security risk (such as the streetpass exploit that allows for arbitrary code execution without any user action on the 3DS)
- Lack of eShop (including game updates) and online play functionality
- Update nag that will keep coming back unless you permanently go offline
- Missing features (9.6 was the last actual feature update, even though it was relatively small)
- Newer cartridges will contain newer updates which will force you to update before you can play them
- Potential incompatibilities with modern homebrew that don't expect an old firmware

If you're really interested, you might be able to hunt down a 9.2.0 ctrtransfer image somewhere, but I think it would be more productive to go over the homebrew that doesn't work on latest firmware (use your N3DS to test that) and see if the benefits of that homebrew outweigh the drawbacks.

3. Is there a way to downgrade Luma3DS 10.2.1 to 10.0?
Yes - Luma3DS is just a file on your SD card or internal memory (boot.firm), so replacing Luma 10.2.1 with Luma 10.0 will result in Luma3DS being 'downgraded' to 10.0. That being said, if you're on firmware 11.14 or 11.15, you won't be able to boot due to a change in the pm process. Luma3DS 9.1 still works, though.

No, you shouldn't downgrade to <=11.13 just to use Luma 10.0.

4. What flashcart would you guys recommend if I decide to go that route?
Ideally, NONE!!! It's 2021 and 3DS flashcarts are not a good idea (for most people).

- Button-based cartridges (Sky3DS, Stargate) require you to physically press a button to cycle between your games.
- Gateway cartridges will require you to get experimental with your setup and run the risk of bricking your console if you're not careful.

If you really want to use a Gateway cartridge, there's a thread where you can get help with making it work with boot9strap, but you're at the mercy of whoever participates in that thread because not that many people in the overall homebrew community will support Gateway cartridge usage.

---

Could you go into a bit more detail about your Fantasy Life plugin not working? There seems to be a non-Gateshark plugin for it, so I don't see why it wouldn't work as expected. Remember, the 3GX loader is required to run NTR but the 3GX loader does not run the plugin itself - you have to put it in plugins directory specified in BootNTR Selector and not /luma/plugins.
 
Last edited by lilyuwuu,
  • Like
Reactions: KleinesSinchen

Pl4yst4tionRox

Active Member
OP
Newcomer
Joined
Feb 16, 2021
Messages
37
Trophies
0
Age
43
XP
176
Country
United States
Thank you so much for your in depth replies to my questions lillyuwuu. I have a couple of replies to your replies. First in regards to installing bootstrap on 4.4 i read somewhere that 4.4 wasn't compatable even though the 3ds guide that t was. I can't seem to find that article.

In regards to your reply on not staying on older firmware I agree with what you say but I already do not use street pass nor do i use cartridges. I was really happy with the time that I did have a Gateway Card. Is it really bad that I have to press a button to navigate my games on a Card?

In reply to your reply on downgrading Lumas 3ds i understand that it is just a file on my sd card but by using the 3ds hack guide i made it where i am not booting off the sd card but the system itself and that is one of the reasons why i was wondering if i can 'downgrade' Lumas 3d. Also there is the fact that I did upgrade to the latest FW after i installed Lumas 3d but since Lumas 3ds is a CFW wouldn't I revert back to 11.7 (the FW that I was on before I updated) Also in order to 'downgrade' Lumas 3ds is it as easy as just copying Lumas 3ds10.0 over 10.2.1 or do I have to go through the whole process of uninstalling Lumas by following the 3ds hack guide?

Finally in regards to the Fantasy Life Plugin apparently Lumas 10.2.1 doesn't seem to work with Boot NTR Selector. i downloaded the FL Plug-in from the same website that you linked to. I went to download the latest Boot NTR Selector and i was greeted with the message that this release is currently broken with official Lumas 3ds! I come to realizee that it didn't really mater as I am on 11.15 and even if the latest boot NTR Selector wasn't compatable my current firmwaresure isn't. Also the FL plug-in is a .plg and I tried to use it by following the proper steps on installing it to my sd card but it didn't work. Either because I am using a 3gx program (the plug-in is not a .3GX or because of the fact that I am on 11.15. FW.

On a side note. I may be getting a N3DS XL with a FW of 11.13.45. Does anyone know if this is downgradeable. I have google this question but i seem to get his and miss when it comes to an answer.

Thanks again for replying Lillyuwuu
*Edit* The only thing that I want to do is use plug-ins with my games.
 
Last edited by Pl4yst4tionRox,

lilyuwuu

Well-Known Member
Newcomer
Joined
Sep 7, 2020
Messages
69
Trophies
0
XP
444
Country
Antarctica
- I read somewhere that 4.4 wasn't compatible...

Well, technically speaking, homebrew launcher access doesn't exist on 4.4 because *hax payloads don't exist below 9.0. So, you can't really do much on older firmwares except install boot9strap via Soundhax (after which you would ordinarily update to latest firmware).

- I was really happy with the time that I did have a Gateway Card. Is it really bad that I have to press a button to navigate my games on a Card?

At the time, Gateway was effectively the only option for running backups (that people couldn't easily make, so... piracy). While its software features are generally pretty okay, they simply aren't supported by most people in the modern homebrew community - any time you get help anywhere someone will ask you "why are you using a 3DS flashcart".

Another issue is that Gateway had a tendency to do things a bit dangeorusly - while you could technically install an old Gateway setup on your current firmware (4.4), it would be a lot more dangerous to anything boot9strap-based and should a brick occur you would need to buy a compatible DS flashcart to fix it (ntrboot).

Sky3DS cartridges do not allow you to run any homebrew, are subject to region locking on unmodded consoles, and will likely still force you to update on older firmware. Thus, there are no benefits to Sky3DS these days over just installing your games to SD (in fact, there are detriments such as bans if you don't get a donor private header). Older Sky3DS cartridges also had an arbitrary limit of games you could ever install to one card.

- In reply to your reply on downgrading Lumas 3ds i understand that it is just a file on my sd card but by using the 3ds hack guide i made it where i am not booting off the sd card but the system itself and that is one of the reasons why i was wondering if i can 'downgrade' Lumas 3d

The booting off the system thing is actually just another file - boot.firm on the root of SYSNAND CTRNAND. You can use GodMode9 to make changes to that.


- Also there is the fact that I did upgrade to the latest FW after i installed Lumas 3d but since Lumas 3ds is a CFW wouldn't I revert back to 11.7 (the FW that I was on before I updated)

3DS FW has nothing to do with your Luma3DS FW. Luma3DS is, quite literally, just one file on your SD card with its own separate versioning. Your 3DS will not upgrade or downgrade to any system version unless you explicitly do so (usually via CTRTransfer or restoring an old NAND backup).

- Also in order to 'downgrade' Lumas 3ds is it as easy as just copying Lumas 3ds10.0 over 10.2.1 or do I have to go through the whole process of uninstalling Lumas by following the 3ds hack guide?

It's as easy copying Luma3DS 10.0 over 10.2.1. As I mentioned earlier, Luma 10.0 does not boot on the latest firmware and will cause your console to fail to boot until you use Luma 10.2.1 or 9.1.


- I come to realizee that it didn't really mater as I am on 11.15 and even if the latest boot NTR Selector wasn't compatable my current firmwaresure isn't

BootNTR Selector is compatible with 11.14 and 11.15, but the 3GX Luma build fixes an issue that ordinarily causes it to break. You can ignore the 3GX loading capability of the 3GX Luma build, as you are loading PLG files.
What do you mean by "it didn't work"? Did Fantasy Life crash? Did you see a green screen when opening the game? Did NTR still not work as expected?

- On a side note. I may be getting a N3DS XL with a FW of 11.13.45. Does anyone know if this is downgradeable. I have google this question but i seem to get his and miss when it comes to an answer.

Technically speaking a downgrade is hypothetically possible, but the recommended course of action is to update to 11.15.0 (the latest firmware) and follow https://3ds.hacks.guide/seedminer. There's not really anything waiting for you on 11.13.0, and if you have the ability to downgrade then you also have the ability to install custom firmware and therefore there is no reason to downgrade.

BootNTR Selector is compatible with 11.14 and 11.15 if you use the 3GX Luma build.
 

Pl4yst4tionRox

Active Member
OP
Newcomer
Joined
Feb 16, 2021
Messages
37
Trophies
0
Age
43
XP
176
Country
United States
I guess that I am having problems with 3gx Luma build as i cant seem to get the damn thing to work Thank you once again Lillyuwuu for you in depth answers. I load boot ntr and i get an error that says Loading 3.6.... Load failed! #Firmware unknown #Detected firm: 2.57.0 Press any key to reboot
 

Pl4yst4tionRox

Active Member
OP
Newcomer
Joined
Feb 16, 2021
Messages
37
Trophies
0
Age
43
XP
176
Country
United States
i installed the fonzd banner for my 3ds xl the original XL the non mode 3 one i also put the boot.firm from that page into the root of my sd card and it still fails to load
 
Last edited by Pl4yst4tionRox,

lilyuwuu

Well-Known Member
Newcomer
Joined
Sep 7, 2020
Messages
69
Trophies
0
XP
444
Country
Antarctica
The error you're getting usually occurs when you have an old BootNTR Selector and you're on a newer firmware (hence "firmware unknown" - it doesn't know what 11.14 or 11.15 is). I don't know exactly what you might be doing wrong, though. Make sure you don't have multiple BootNTR Selectors for whatever reason, try deleting and installing rather than installing on top of the existing one, try holding SELECT while opening BootNTR Selector...
 

Pl4yst4tionRox

Active Member
OP
Newcomer
Joined
Feb 16, 2021
Messages
37
Trophies
0
Age
43
XP
176
Country
United States
I am on 10.6.0-31 for my o3ds and I am on 11.15.0-47 on my new 3ds xl I am using 10.2.1 Lumas on both machines and I ALWAYS delete
old files before installing new ones and holding select doesn't help. I don't know what the hell I am doing wrong
 
General chit-chat
Help Users
    Psionic Roshambo @ Psionic Roshambo: https://youtu.be/d4b3eM3FQ0A