A couple of games stopped working after 3.3U update

Discussion in 'Wii - Hacking' started by Knocks, Jun 28, 2008.

  1. Knocks
    OP

    Knocks GBAtemp Advanced Fan

    Member
    559
    0
    Jun 12, 2006
    The following games have stopped working on my NTSC-U system after updating to 3.3U.

    Naruto Shippuuden: Gekitou Ninja Taisen EX (J) - This game worked fine on 3.2U. It was patched with RegionFrii from NTSC-J to NTSC-U with language forced to Japanese.

    Pro Yakyuu Family Stadium (J) - Also worked on 3.2U. This was originally a scrubbed ISO. Before burning, I used BrickBlocker to remove the Japanese weather/news channel update, then patched it with WiiFree (used "do not change" for language)

    As far as I know, 3.3U only affects Trucha signed discs. Do RegionFrii, BrickBlocker, WiiScrubber, or WiiFree use Trucha to re-sign ISOs? All my other U.S. and Japanese games work fine, btw.
     
  2. samsam12

    samsam12 Test

    Banned
    818
    0
    May 13, 2008
    United States
    A House
    try booting through GeckoOS
     
  3. Shuny

    Shuny I'm in yr forum, reading yr postz

    Member
    1,019
    54
    Nov 15, 2006
    France
    Somewhere in the world
    Both of your modifications uses a Trucha signature . Boot these discs throught Gecko OS as samsam12 said.
     
  4. trent_fox

    trent_fox GBAtemp Regular

    Member
    166
    0
    Apr 4, 2007
    United States
    BrickBlocker and RegionFrii modify the ISOs and thus need to Trucha sign them. WiiScrubber depends on what mode you use, but in most cases does not trucha sign them.

    You'll need to use GeckoOS to boot these discs.

    EDIT: Damn, beaten to it.
     
  5. dexmaus

    dexmaus Member

    Newcomer
    36
    2
    Jun 28, 2008
    United States
    do you have to buy Gecko Free Loader to use GeckoOS??
     
  6. Knocks
    OP

    Knocks GBAtemp Advanced Fan

    Member
    559
    0
    Jun 12, 2006
    So both RegionFrii and WiiFree use Trucha?

    I am actually unable to test the GeckoOS method, because the Wii crashes as soon as the disc is initialized.
     
  7. DaveMode

    DaveMode Advanced Member

    Newcomer
    72
    0
    Oct 29, 2007
    United States

    Sorry, but this is wrong. Brickblocker and RegionFrii do not use Trucha. If that was all that he had used then the games would still boot the same with 3.3 as with 3.2. The reason these games don't work is because they were Trucha'd to get the language to English.
     
  8. Shuny

    Shuny I'm in yr forum, reading yr postz

    Member
    1,019
    54
    Nov 15, 2006
    France
    Somewhere in the world
    OBJECTION !

    RegionFrii allows you to force a language, and this option needs the Trucha Sign !
     
  9. DaveMode

    DaveMode Advanced Member

    Newcomer
    72
    0
    Oct 29, 2007
    United States

    Oh yeah? Didn't know you could set language with RegionFrii. I don't see the option in mine but maybe there was an update after the version I use (ver 1.21)?
     
  10. Knocks
    OP

    Knocks GBAtemp Advanced Fan

    Member
    559
    0
    Jun 12, 2006
    OK, so the first game used RegionFrii and forced to Japanese, so that's probably affected by Trucha. What about the second one? I left the language unchanged in that one. Did BrickBlocker screw it up?

    I would like to re-burn the original ISOs without using Trucha applications. Is that possible?
     
  11. DaveMode

    DaveMode Advanced Member

    Newcomer
    72
    0
    Oct 29, 2007
    United States
    Although I haven't used it before, I believe WiiFree uses the Trucha bug to patch the game. That would explain why the second disc doesn't work. So in your case, considering you still have the original untouched ISO's, I would just use brickblocker and regionfrii (without any language override settings) and the discs shoot boot up just fine. If you're really interested in language patching, then just use Gecko OS to boot the games, as this is the workaround for Trucha signed discs in firmware 3.3
     
  12. flobo

    flobo GBAtemp Regular

    Member
    114
    2
    Apr 17, 2007
    France
    Are you sure it's not the fact that it's scrubbed. I've got only one scrubbed game : mario kart, and it's the only one that does not work anymore since 3.3E update. (it works with gecko)
     
  13. RyuKakashi

    RyuKakashi GBAtemp Fan

    Member
    450
    0
    Mar 18, 2006
    United States
    scrubber does not use trucha
    wiifree is outdated, you should update to yaosm, and no it doesnt use trucha
     
  14. Knocks
    OP

    Knocks GBAtemp Advanced Fan

    Member
    559
    0
    Jun 12, 2006
    I re-burned the second game. Used Brickblocker to remove the update and RegionFrii 1.21 to change Region from JAP 00 to USA 01. The Wii doesn't crash upon initializing the disc anymore, which means neither of those programs use Trucha, so that's good news. But when I launch the disc, I get a black screen and that's it. That usually happens with games that require forced region patching but haven't been patched properly. Any ideas?

    Haven't tried re-burning Naruto yet.
     
  15. manias

    manias GBAtemp Maniac

    Member
    1,258
    0
    Aug 7, 2007
    Netherlands
    wiifrii is an application, not a modchip
     
  16. darkangel5000

    darkangel5000 GBAtemp Fan

    Member
    358
    41
    Apr 26, 2008
    Gambia, The
    Unna, ~Dortmund :3
    http://s8.directupload.net/images/080629/jq56skch.jpg
    So it isn't? [​IMG]
     
  17. Knocks
    OP

    Knocks GBAtemp Advanced Fan

    Member
    559
    0
    Jun 12, 2006
    I have re-patched both original ISOs with RegionFrii from JP to US and left the language settings intact. Both give me a blank screen now. I was able to boot the new discs from GeckoOS with language forced to Japanese, but Family Stadium does not work because you can't select Yes or No at the save file create prompt--seems like a GeckoOS bug that doesn't initialize the D-pad.