6.2.0 How to get newer games?

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by kolosus, Feb 15, 2019.

  1. kolosus
    OP

    kolosus GBAtemp Regular

    Member
    3
    Jul 14, 2010
    United States
    So I'm updated to the latest 6.2.0. Wondering about how to play the latest games. Are there any special steps that I need to take or can I update to the latest version firmware. I'm sure that the latest games will need the latest firmware versions? Can I spoof it?
     
  2. Kubas_inko

    Kubas_inko "Something funny goes here."

    Member
    14
    Feb 3, 2017
    Czech Republic
    I gues on earth.
    Which game requires 7.0.0?
    You can't spoof it. You would have to update. Or "recompile" the games.
     
  3. jorgesd

    jorgesd GBAtemp Regular

    Member
    4
    Dec 28, 2018
    East Timor
    Do you think smash 3.0 or the games announced in the direct will need 7.0.0?
     
  4. kolosus
    OP

    kolosus GBAtemp Regular

    Member
    3
    Jul 14, 2010
    United States
    I'm thinking the new Zelda will.
     
    Kubez likes this.
  5. Kubas_inko

    Kubas_inko "Something funny goes here."

    Member
    14
    Feb 3, 2017
    Czech Republic
    I gues on earth.
    Can't tell and I don't want to guess.
     
    azoreseuropa likes this.
  6. YodaXY

    YodaXY Member

    Newcomer
    5
    Jan 26, 2009
    Germany
    dude u mean zeldas awakening????
    the release is not even fixed until then firmware 7.0 runs under cfw.
     
    Kubez likes this.
  7. Nezztor

    Nezztor GBAtemp Fan

    Member
    6
    Nov 8, 2016
    Mexico
    Its a few months months away ,by the time its get out we will be on a far superior fw and you will be still unable to play the .xci so probably better to look for other games I guess?
     
  8. natkoden

    natkoden GBAtemp Maniac

    Member
    6
    Jul 25, 2006
    Argentina
    no current game needs 7.0, so just wait and see
     
    Kubez likes this.
  9. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    As of this post, the highest system version that supports CFW is 6.2.0. For the time being, 7.0.0 should be avoided at all costs.

    A game or game update that "requires" 7.0.0 can be bypassed by using the "ignore system version" option when installing with Tinfoil. The new update for Captain Toad, which "requires" 7.0.0, works this way.

    If a game or game update also requires the new 7.0.0 master key, however, you're screwed until custom firmware becomes compatible with 7.0.0.
     
    Kubez likes this.
  10. tbb043

    tbb043 Member

    Member
    8
    Jan 30, 2008
    United States
    by the time anything worthwhile needs 7.0 to run, they'll have sorted it out so cfw works with it, or else they'll shift into overdrive looking for a way to make it work, so unless you're one of the people actually making this stuff, you as an end user should just wait and not worry about it.
     
  11. 8BitWonder

    8BitWonder Small Homebrew Dev

    Member
    11
    Jan 23, 2016
    United States
    47 4F 54 20 45 45 4D
    I tried to play the free demo of Daemon X Machina and install the Momodora update the other day, both built with keygeneration 8 and require 7.0.0.
     
    Last edited by 8BitWonder, Feb 15, 2019
    Lacius likes this.
  12. azoreseuropa

    azoreseuropa GBAtemp Guru

    Member
    11
    Nov 6, 2002
    United States
    Azores/Portugal
    Hey, I can't tell. I just don't want to guess.
     
  13. natkoden

    natkoden GBAtemp Maniac

    Member
    6
    Jul 25, 2006
    Argentina
    apparently they work with SX OS and 6.2
     
  14. stephrk398

    stephrk398 GBAtemp Fan

    Member
    6
    May 29, 2018
    United States
    Captain Toad Treasure Tracker's new update + DLC requires 7.0 but can be bypassed with tinfoil's ignore FW or sx installer.
     
  15. Kubas_inko

    Kubas_inko "Something funny goes here."

    Member
    14
    Feb 3, 2017
    Czech Republic
    I gues on earth.
    So it is not decrypted with new keys. So it does not require 7.0.0, just wants it.
    (can't remember how it is with DLCs and updates in general)
     
  16. stephrk398

    stephrk398 GBAtemp Fan

    Member
    6
    May 29, 2018
    United States
    So you can spoof it. ;)
     
  17. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    One can use Switch Backup Manager to see what the requirements are for a particular NSP file.

    As I said earlier, if something requires the 7.0.0 key, then you can't do anything with it until CFW is compatible with 7.0.0.
     
  18. Philliyxx

    Philliyxx GBAtemp Regular

    Member
    4
    Sep 21, 2018
    United States
    You can't use nsc rebuild without 7.0 keys though to decrypt and patch 7.0 required games afaik
     
Quick Reply
Draft saved Draft deleted
Loading...