1. pdiddy007

    OP pdiddy007 Member

    Jun 3, 2018
    Hi all

    Thanks for having a read of my long-is thread. A little background - I hacked my Wii U in 2017 and its been going strong. I don't play it too much but its been rock solid when I do turn it on. I had another flurry of activity with it in 2018 when I added some gamecube games onto the Wii U external hard drive - but have never played them.

    Currently my Wii U is running 5.5.1. It has Haxchii (via exploitable virtual console games) and Mocha CFW. I hacked it using the Wii U hacks guide website and followed all the instructions at the time. When I boot up the Wii U, I click on Haxchi and it runs, then I need to chose Mocha to allow me to run my roms. From what I have read on the topic this week - this method is outdated. The Wii U hacks website itself now states you can chose a custom firmware - either Haxchi or Mocha. This is quite different to my Wii U set up. Im getting old now and am totally confused with the situation. I have a couple o questions regarding this:

    1. Should I update my Wii U and get rid of Mocha? The wii U hacks website says mocha needs to be launched via browser website but mine is launched after running haxchi. Does anyone know how I can go about doing ditching mocha if I no longer need it?
    2. My Wii U is on 5.5.1 → should I upgrade to 5.5.3 or 5.5.4?

    In addition to all of that - I have recently bought an used copy of just dance for my Wii U (the little ones in my family love it). I have secured the rom and am struggling to get it onto the external hard drive that holds all my games. I have followed a few YouTube videos but the steps are not working for me (It was all so easy a few years ago - but i have just forgotten how to do it). I mean I now own the game so could just leave it in the drive - but I am keen to get a working copy onto my external hard drive. The steps I have taken involve placing the rom into the install directory on my SD (This is the SD that lives in my Wii U). After that when I load WUP installer GX2 it states that "No installable content found". I do remember in 2017 using Wup installer Y mod. When I boot this up - it sees the rom but when I try to install it to my external hard drive it says "MCP_InstallGetInfo 0xFFFBF3E2". Ive tried googling it and it appears I may be missing files.

    3. Anyone know how I can rectify the situation? (SOLVED)
    —> after reading and reading and reading one thread mentioned not to have any uncommon characters in the name of the game. I have a registered trademark after just dance. After ditching that the game copied across.

    Thank you to anyone reading this thread - the community has been excellent to me over many years and I appreciate it

    Last edited by pdiddy007, Jan 4, 2021
  2. neoninteger

    neoninteger Member

    Apr 22, 2020
    One of the things I don't like about most Wii U tutorials is that they simplify things too much, which can be good for getting less experienced users up and running but as a result, a lot of important background information is skipped over. So let's go over a few things:

    Mocha is not "installed" on your console - there is a launcher app on your SD card that you run to reboot into Mocha. In your case, you have Haxchi configured to run this launcher app. The browser exploit can also launch Mocha (by running the Homebrew Launcher first). Uninstalling Mocha is as simple as just not launching it again, and optionally deleting the Mocha files on your SD card.

    Haxchi, however, is installed on your console. What it actually does is up to you - in later versions of Haxchi there's a configuration file which defines what Haxchi will do if no buttons are pressed, and what it will do if a certain button on the GamePad is held while it starts.

    Later versions of Haxchi also have a built-in custom firmware that can be used instead of Mocha. There are some features in Mocha that are missing in Haxchi's firmware, however these are insignificant to most people who only use custom firmwares to run pirated games.

    Mocha is not any more outdated than Haxchi (both were released shortly after IOSU exploits were publicly implemented, and only received a few updates), its up to you as to whether or not you continue to use Mocha or switch to Haxchi's built-in custom firmware.

    Because you said that you installed Haxchi in early 2017, it may be worth running the Haxchi installer again just to make sure you are using the latest version, if you want to use Haxchi's custom firmware functionality instead of Mocha still.

    Honestly, the biggest piece of advice I can give you is "don't fix what isn't broken" - if what you currently have serves your purposes, why change it?

    It doesn't really matter whether you update or not, most things should work regardless. 5.5.2 only updated the web browser to fix an exploit (new exploits have since been implemented and remain unpatched) and certain message files (in advance of the closure of Miiverse), 5.5.3 and 5.5.4 (the latter of which was only released on European region consoles) only updated legal text to comply with GDPR. The base OS is the same across all of these system versions, and so Mocha/Haxchi work fine on all of them.
    pdiddy007 and jeannotte like this.
Draft saved Draft deleted

Hide similar threads Similar threads with keywords - forgotten, hacked, having