1. SickPuppy

    SickPuppy New Member
    Member

    Joined:
    Jul 29, 2009
    Messages:
    1,827
    Country:
    United States
    Find the thread for the 3DS NUS, they talk about updating the browser.
     
  2. Jaitsu

    Jaitsu Yet Another GBATemp Furry
    Member

    Joined:
    Jun 2, 2015
    Messages:
    152
    Country:
    United States
    The problem here is that you need something to update the browser WITH. It's a circular issue, you need the updated browser to install the exploit that allows you to install the updated browser.
     
  3. VerseHell

    VerseHell GBAtemp Psycho!
    Member

    Joined:
    Jun 29, 2014
    Messages:
    3,070
    Country:
    France

    Once you installed the pbt-cfw, download the 4.5.0-10 update with 3DNUS and install it with sysupdater.
     
  4. Jaitsu

    Jaitsu Yet Another GBATemp Furry
    Member

    Joined:
    Jun 2, 2015
    Messages:
    152
    Country:
    United States
    Quoting you to make sure this pings you: I just realized, there may be a way to get the browser exploit working even on an older browser. Go to http://whatsmyuseragent.com/ in your 3DS browser - what does it say? Either in the box, or the red useragent in the list. We're looking for the "Version/1.7###.US" bit. Hopefully 1.7455 or 1.7498?

    Edit: Ethersoul, you too, if you're reading this. I'm wondering if GW17455.dat or GW17412.dat from this thread: https://gbatemp.net/threads/release-custom-rop-loader-html.379531/ will help either of you. If it does, I think you can use the GW launcher to install mset and do the rest with no need for any further browser exploits. I'm not sure, but it's a theory.
     
    Last edited by Jaitsu, Jun 5, 2015
    tonybologna likes this.
  5. kof91

    kof91 Member
    Newcomer

    Joined:
    Nov 25, 2005
    Messages:
    13
    Country:
    Malaysia
    Any guide on how to install FBI? I am already up to step 4 with spider code running?
     
  6. Myth

    OP Myth Advanced Member
    Newcomer

    Joined:
    Jun 3, 2015
    Messages:
    86
    Country:
    United States
    The easiest way is to use cubic ninja, install the cubic ninja fbi version and then use it to install the fbi cia, all after running Pasta or PBT of course.
     
  7. kof91

    kof91 Member
    Newcomer

    Joined:
    Nov 25, 2005
    Messages:
    13
    Country:
    Malaysia
    okay got it, thanks!
     
    Last edited by kof91, Jun 11, 2015
  8. Myth

    OP Myth Advanced Member
    Newcomer

    Joined:
    Jun 3, 2015
    Messages:
    86
    Country:
    United States
    After this if you can get a cubic ninja .cia then I'd recommend installing that to your system nand as well.
     
  9. kof91

    kof91 Member
    Newcomer

    Joined:
    Nov 25, 2005
    Messages:
    13
    Country:
    Malaysia
    with the exploit already installed, any reason to install cubic ninja cia?
     
  10. tonybologna

    tonybologna GO VOLS!
    Member

    Joined:
    Dec 8, 2008
    Messages:
    258
    Country:
    United States
    Missed this reply of yours. When I go to the useragent page I don't see any numbers. On the bottom 3DS screen I see the writing What's My User Agent but not any numbers. There's a box beside the writing but I don't see any numbers. Where should this be & should I see numbers regardless of where it's at?

    I don't think my browser is working hardly at all. Check that, I'm able to visit webpages so I guess it is working right. It's just not showing up any numbers to check for from the useragent page. What now bud? Thanks again!

    BTW, while trying to load the page(useragent) I got 2 error messages. One was "failed to load part of the page". Isn't this the error you get when trying to load the profile exploit? Also got terminated script execution error as well. What are those about?

    Takes a couple minutes to even the load the page after these error messages. Something isn't working right from my browser. Is it because of being on 4.5 FW or what? Thanks!
     
    Last edited by tonybologna, Jun 14, 2015
  11. Jaitsu

    Jaitsu Yet Another GBATemp Furry
    Member

    Joined:
    Jun 2, 2015
    Messages:
    152
    Country:
    United States
    Well, "failed to load part of the page" isn't necessarily the exploit, it just means something's doing something the browser doesn't support. Weird. Uh... Here, try this - with the launcher.dat on your SD card, point the 3DS browser to http://dukesrg.no-ip.org/3ds/go/ . That page is designed to detect the firmware of your 3DS and use the appropriate exploit if there is one. If it doesn't work, try clearing cookies and history and trying again, but if it's still not getting you anywhere, I don't know. You're on 4.5 FW at this point, though, right?
     
  12. tonybologna

    tonybologna GO VOLS!
    Member

    Joined:
    Dec 8, 2008
    Messages:
    258
    Country:
    United States
    Yes, I'm on 4.5 FW. I'll give your instructions a try later this evening when I have enough time. Thanks!
     
  13. Jiro2

    Jiro2 GBAtemp Advanced Fan
    Member

    Joined:
    Mar 28, 2011
    Messages:
    776
    Country:
    United States
    If you're on a firmware less than 4.x, you have to update to 4.x. You *cannot* use 9.2, because the 9.2 hack depends on the browser, and you'd have to update to 9.2 using a cart, and cart updates don't include the browser. Even Ninjhax depends on the browser as well as on Cubic Ninja.

    Get a cart with 4.x, update to 4.x from it, and use the profile exploit (mset), either with Gateway, Pasta, or signature patched RXtools.

    Once you have a hacked system you can then use hacks to install a proper browser, but that means that you have to use a hack that doesn't need the browser in the first place, and the only such hack is mset on 4.x.
     
    Last edited by Jiro2, Jun 15, 2015
  14. Jaitsu

    Jaitsu Yet Another GBATemp Furry
    Member

    Joined:
    Jun 2, 2015
    Messages:
    152
    Country:
    United States
    What I'm wondering is if @tonybologna can use the custom ROP launcher I linked ( http://dukesrg.no-ip.org/3ds/go/ ) to get the Gateway launcher up, then use that to install mset (which is what the "NVRAM" option does, as far as I know?) and emuNAND (maybe save that for later), then I can guide him through getting PBT or Palantine running to install FBI, then possibly updating that browser through 3DNUS, and finally getting the new patched rxTools on it to boot emuNAND.

    Dear god things have gotten complicated in the last month or so, hahah
     
    tonybologna likes this.
  15. Myth

    OP Myth Advanced Member
    Newcomer

    Joined:
    Jun 3, 2015
    Messages:
    86
    Country:
    United States
    Yes, RxTools for newer games (use the patched version...)

    I'd recomend using the non online only ninjahax expolite, instead of the web browser expolite for rxtools.


    (Side note)

    I prefer a pasta through ds profile and rx tools through ninja .cia instead of rx tools through ds profile, though both work...
     
  16. tonybologna

    tonybologna GO VOLS!
    Member

    Joined:
    Dec 8, 2008
    Messages:
    258
    Country:
    United States
    Complicated for you & overly complicated for me as a newbie in trying to get hacks working on my 3DS. This stuff on the 3DS is NOTHING like hacking/homebrew on the original DS. It's so confusing to read all of this stuff posted on these forums & where to even start. I'll get around to testing your instructions later today on my 3DS. Thanks again.

    Edit: Just received my R4i Gold 3DS in the mail today. Now, I can install the mset profile exploit that way instead of the other way without a flashcart. Of course, that still doesn't address the outdated browser problem.

    I'll still try your instructions for that as well. I'll PM you if I need more help. I don't want to clog this thread up with irrelevant information. Thanks!
     
    Last edited by tonybologna, Jun 15, 2015 - Reason: added information
  17. tonybologna

    tonybologna GO VOLS!
    Member

    Joined:
    Dec 8, 2008
    Messages:
    258
    Country:
    United States
    Well, I tried your instructions again with no success again. I cleared cookies & history as well. I get my ISP(Charter) page(page not found) message when trying to go to the ROP launcher page from above.

    I don't know what's going on here but it would be really nice to get my browser updated. Thanks! BTW, when you said to have the launcher.dat file on SD Card this is the one from Pasta CFW right?

    Do I need to have any other files on the SD Card besides the launcher.dat file? I've also not tried the GW Installer yet from SD flashcart either to get the mset profile installed. I just now got the R4i Gold 3DS ready to go.
     
  18. Jaitsu

    Jaitsu Yet Another GBATemp Furry
    Member

    Joined:
    Jun 2, 2015
    Messages:
    152
    Country:
    United States
    Keep trying, it seems like the site is having stability issues right now. (On and off... maybe it's being DOS'd?) And for right now, no, use the Gateway launcher.dat from the 3.2.2 package: http://www.gateway-3ds.com/downloads/ It's in the "GW_Ultra_3.2.2(Public Beta)" folder in that.

    Also, back up everything on your SD card, because it's gonna get wiped. If you can get that running, then hit "INSTALL NVRAM" and wait for that to finish (should work - I've never needed it). Then hit "FORMAT EMUNAND". That'll wipe your SD card and create the emuNAND, which resides in 1 GB of unpartitioned space at the beginning of the card. If you get all that working, let me know. If http://dukesrg.no-ip.org/3ds/go/ still won't work, even after you clear history/cookies and try a few times (and get it to load) I'm not sure what to suggest; I think that SHOULD work though. In a desktop browser when you try to load the page you should just see a dot.
     
    tonybologna likes this.
  19. tonybologna

    tonybologna GO VOLS!
    Member

    Joined:
    Dec 8, 2008
    Messages:
    258
    Country:
    United States
    I placed the launcher.dat from the GW download onto the SD Card. That's all I have on the SD Card. Do I then go to browser & then ROP launcher page you provided from there? Is this what you're talking about to create my emuNAND on SD Card or is this something different all together than the ROP page?

    I can't seem to get anything running/working from my browser. I know it's at least partially functional because I can go to the Nintendo pages & Google for sure. :( Do I need to go ahead & install the mset profile exploit with the GW Installer.nds file?
     
  20. Jaitsu

    Jaitsu Yet Another GBATemp Furry
    Member

    Joined:
    Jun 2, 2015
    Messages:
    152
    Country:
    United States
    Basically, yes. Loading that page causes the Launcher.dat on your SD card to launch, and the Gateway launcher.dat brings up a menu with options like "install NVRAM" and "format emuNAND". It doesn't need anything else to be on the SD card. If that's NOT working... I'm not sure. I THOUGHT that page was essentially universal to all 3DS browser versions up to 9.2... That's why I was asking about the user-agent, to find out what your 3DS' browser version is.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Flashcard, Firmware, Without