4.xx Firmware Without Any Kind Of Flashcard?

Discussion in '3DS - Flashcards & Custom Firmwares' started by Myth, Jun 3, 2015.

  1. Myth
    OP

    Myth Advanced Member

    Newcomer
    86
    14
    Jun 3, 2015
    United States
    Is it possible to install the older 4.xx CFW without any flashcard (ds or gateway) and if so how? Thanks!
     


  2. KazoWAR

    KazoWAR GBAtemp Advanced Maniac

    Member
    1,795
    676
    Aug 12, 2008
    United States
    Winter Haven
  3. Myth
    OP

    Myth Advanced Member

    Newcomer
    86
    14
    Jun 3, 2015
    United States
  4. Jaitsu

    Jaitsu Yet Another GBATemp Furry

    Member
    152
    51
    Jun 2, 2015
    United States
    There's a pretty easy process to follow, now.

    1. Grab the Spider ROP-Loader exploit from here: http://s000.tinyupload.com/index.php?file_id=47753777289998764895 (link courtesy of peekatyou)

    2. Place the code.bin file from that on the root of your SD card.

    3. Use a Spider code exploit that loads code.bin. http://dukesrg.no-ip.org/3ds/rop/?LoadCode4.dat&code.bin should work. Wait for the browser to crash. (If you get the black screen instead of the dialog, or it otherwise doesn't work, try clearing your browser's history and cookies and trying again.) You now have a Gateway-exploited Nintendo DS Profile.

    4. BACK. UP. YOUR. NAND. (You'll hopefully never need it, but in case you do, you're up a creek without it.) Use the Launcher.dat from Gateway's latest pack here: http://www.gateway-3ds.com/downloads/ It's in the "GW_Ultra_3.2.2(Public Beta)" folder. It needs to go on the root of your SD card.

    [Optional] For the next few steps, anywhere they tell you to install BigBlueBox/DevMenu, I recommend FBI instead; it can do all the same things, plus shows more info and can install CIAs over a network, which you can't otherwise do from the Pasta CFW. Without the ability to net-install, your SD card needs to have double the free space for every CIA you want to install! Link to FBI: https://github.com/Steveice10/FBI/releases/

    5a. If you want to use Pasta CFW (starts nearly 100% of the time with no hassle, can install unsigned CIAs) then follow this guide: https://gbatemp.net/threads/release-pasta-cfw-without-cubic-ninja-mset-4-x-old3ds.389498/ (NOTE: When you get to the "copy the Palantine files" step, delete the Launcher.dat and rename Launcher_GW.dat to Launcher.dat. If you don't do this, it won't work. I didn't know this and it would've saved me hours of fiddling and re-doing.)

    5b. If you want to use emuNAND (again, not really necessary, but safer, however it eats a GB) then follow the second half of https://gbatemp.net/threads/tutorial-4-5-sysnand-4-5-cfw-9-4-emunand-without-gateway.378721/ (you don't have to do the first half if you don't need a 9.x emuNAND; you're only gonna need a 9.x emuNAND if you have legit cartridges that you want to play that need newer FW)

    6. If you want to run .3dsx files (Ninjhax homebrew) you're going to need Cubic Ninja, no way around that for now. However, a CIA-installed copy of it will work. Ninjhax guide: http://smealum.net/ninjhax/

    And that's just about all you need to know! And about all you can do without a flash-cart.

    EDIT: Oh, important thing to know. That ROP loader exploit installs the Gateway version of the DS Profile exploit, which means your Launcher.dat's need to be encrypted. That means any time you have a Launcher.dat and a Launcher_GW.dat, you need to be using the Launcher_GW.dat (renamed to just Launcher.dat).
     
    Last edited by Jaitsu, Jun 3, 2015
    Margen67 likes this.
  5. Myth
    OP

    Myth Advanced Member

    Newcomer
    86
    14
    Jun 3, 2015
    United States

    As I already have emunand etc setup it shound't take long to install cfw, ill try the new link. Thank you very much for the very large amount of usefull info, more then I was ever expecting. Ill post back shortly with my results, thanks again!
     
  6. tonybologna

    tonybologna GO VOLS!

    Member
    258
    1
    Dec 8, 2008
    United States
    USA- East Tennessee
    Can I follow your same set of instructions if I'm on FW 3.0.0-6.0U? I'm just not wanting to buy 2 separate cards right now to update to 4.x FW & install Pasta. Right now on the older FW I need to buy a retail cartridge on 4.x to update & also buy Cubic Ninja to install Pasta CFW.

    I really don't wanna do all of that right now especially since Cubic Ninja has skyrocketed in price. I'd be better of just buying a Gateway instead of paying for 2 cartridges to do all of this that way. I'd just like to get to Pasta or some other CFW from the older FW that I'm on at this time. Haven't updated the FW since late 2011. This is for the O3DS. Thanks!
     
  7. Myth
    OP

    Myth Advanced Member

    Newcomer
    86
    14
    Jun 3, 2015
    United States
    You need to be on 4.xx at least from what I'm aware of. You can follow this guide etc without cubic ninja if you stay on the 4.xx firmwares, you can run PBT CFW without buying anything other than the 4.xx upgrade, however the boot rate isn't great on PBT...
     
  8. VerseHell

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    No first you need to be on 4.X. Second,your last digit must be at least 7 to use the spider rop as far as i know.
     
  9. Jaitsu

    Jaitsu Yet Another GBATemp Furry

    Member
    152
    51
    Jun 2, 2015
    United States
    To be perfectly honest, I don't know. I'm not 100% certain, but I think the answer is no, there. I'm fairly new to all of this, myself; I just thought I could post up a guide for people like me that lucked out and got a system that came with 4.X. From some quick searching around, if you do decide to buy a card to update, any of the following games should come with 4.5.0U (found by searching http://3ds.essh.co/ ):

    Fast & Furious - Showdown Activision
    LEGO Legends of Chima: Lavals Journey
    Crash City Mayhem
    Animal Crossing - New Leaf
    Turbo - Super Stunt Squad
    Shin Megami Tensei IV
    Luigis Mansion - Dark Moon
    LEGO City Undercover - The Chase Begins
    Pokemon Mystery Dungeon - Gates to Infinity
    Donkey Kong Country Returns 3D
     
  10. tonybologna

    tonybologna GO VOLS!

    Member
    258
    1
    Dec 8, 2008
    United States
    USA- East Tennessee
    The OP isn't on 4.x & ask how to do this. Is it that he's downgrading from a newer FW while I'm on an older FW as to why his situation would work & not mine?

    So, I must get to 4.x FW before I could do any of the Spider tutorial posted above? If so, then I would rather just buy a Gateway flashcart. I would be paying the price of a Gateway or close to it if I have to buy the 2 cartridges needed to update & install CFW from where I'm at right now. Thanks guys!
     
  11. Myth
    OP

    Myth Advanced Member

    Newcomer
    86
    14
    Jun 3, 2015
    United States

    You only need to by a 4.xx upgrade cart, not cubic ninja as well.
     
  12. tonybologna

    tonybologna GO VOLS!

    Member
    258
    1
    Dec 8, 2008
    United States
    USA- East Tennessee
    Yeah! I had already bookmarked that site for future reference in getting a 4.x cartridge. Like I said though, I might as well go ahead & buy a Gateway since I need to buy/do so much just to update FW & install any CFW. :unsure:
     
  13. Jaitsu

    Jaitsu Yet Another GBATemp Furry

    Member
    152
    51
    Jun 2, 2015
    United States
    From what I'm reading, he's not downgrading at all. It's worded a bit oddly, but I think he's calling the CFW itself "older." (by the way, the CFW isn't actually a firmware, it's more like a hacky reboot that patches some checks in the normal firmware, it doesn't stick on reboot)
     
  14. tonybologna

    tonybologna GO VOLS!

    Member
    258
    1
    Dec 8, 2008
    United States
    USA- East Tennessee
    I thought that I had to get Cubic Ninja as well just to install the Pasta CFW hack? No?
     
  15. Myth
    OP

    Myth Advanced Member

    Newcomer
    86
    14
    Jun 3, 2015
    United States
    I know this, I was saying "older" in reference to a non pasta cfw. On a side note, how did you find your 3ds's IP adress in the pasta without cubic ninja expolite? I keep getting 10.0.0.172 on wireless network watcher :blink:

    — Posts automatically merged - Please don't double post! —

    "5a. If you want to use Pasta CFW (starts nearly 100% of the time with no hassle, can install unsigned CIAs) then follow this guide: https://gbatemp.net/threads/release-pasta-cfw-without-cubic-ninja-mset-4-x-old3ds.389498/ (NOTE: When you get to the "copy the Palantine files" step, delete the Launcher.dat and rename Launcher_GW.dat to Launcher.dat. If you don't do this, it won't work. I didn't know this and it would've saved me hours of fiddling and re-doing.)"
     
  16. Jaitsu

    Jaitsu Yet Another GBATemp Furry

    Member
    152
    51
    Jun 2, 2015
    United States
    Personally, I went into my router's settings and assigned a static IP for my 3DS so it always uses the same known IP. If you don't feel like doing that, though, the network watcher SHOULD work. 10.0.0.xxx is a valid internal IP, I believe; try that. By the way, Pasta CFW can't download CIAs over the network; only Palantine and PBT can - or you can run FBI. The fact that Pasta can't grab CIAs over the network is the reason the guide tells you to use PBT first. (palantine would install to emuNAND which doesn't do you any good, pasta can't) By the way, if you go back to PBT, when you boot it make sure you're holding L, that's what enables the network CIA installation. Once you have FBI installed, you don't need PBT at all anymore.

    Edit - oh, and there's two "versions" of the Pasta CFW, sorry, I should have said. That link is the somewhat stripped down (but still totally working) version that you can use with no need for Cubic Ninja.
     
  17. Myth
    OP

    Myth Advanced Member

    Newcomer
    86
    14
    Jun 3, 2015
    United States

    Iv been using PBT, however I can't seem to get FBI installed. However if you think 10.xxx etc is a valid ip for this then ill recopy the files etc and hopefully have better luck...
     
  18. tonybologna

    tonybologna GO VOLS!

    Member
    258
    1
    Dec 8, 2008
    United States
    USA- East Tennessee
    Yeah, I had bookmarked that thread too. :wink: It was my understanding though after reading the Pasta CFW tutorial that I first had to get my FW updated to 4.x & then use Cubic Ninja just to install the Pasta hack itself. I guess I need to go back & read it again. There's been so much happened in the scene the past 1-2 years.

    I've been out of the loop with illness for a good while so please forgive me with so many questions. I've been trying to read up on a lot of stuff but it's a lot to take in to be honest. Nothing like the simplicity in running things on the standard DS. Thanks!

    Edit
    : Nevermind, I did see the Pasta CFW stripped down one that you provided too. I totally forgot about that one. I would rather use that one than have to buy 2 cartridges for all I need to do. I still may just get me a Gateway though. Do I still need to update to 4.x to use a Gateway flashcart? Thanks again!
     
    Last edited by tonybologna, Jun 4, 2015
  19. Myth
    OP

    Myth Advanced Member

    Newcomer
    86
    14
    Jun 3, 2015
    United States
    If you do the expolite, be ready for a weak boot rate from PBT, if it does not boot you could still have done everything correctly.
     
  20. tonybologna

    tonybologna GO VOLS!

    Member
    258
    1
    Dec 8, 2008
    United States
    USA- East Tennessee
    I edited my previous post. Could you answer my added question about updating & using a Gateway flashcart? BTW, I'm getting off-topic here now. Just don't want to open a new thread or post elsewhere either. I just thought I could use the Spider tut posted in this thread so that's why I posted in this thread initially anyhow. Thanks!