4.1 update and what I should know

Discussion in 'Wii - Hacking' started by MaGnUmKiLLa, Jul 16, 2009.

  1. MaGnUmKiLLa
    OP

    MaGnUmKiLLa GBAtemp Regular

    Member
    157
    2
    Feb 20, 2009
    United States
    United States
    So, 4.1 came out. I've seen a lot of people asking honest questions about it and, I've seen a lot of a-holes on here giving them the run around. I want to play Wii Sports Resort so, yes, this update is important to me. The question is, is it safe to update to 4.1? Can I update through Nintendo or is there some other way that could potentially be safer? I've checked the other threads so please, don't give me that crap. The only thing I've seen that remotely resembles an answer is people worried about pre-loader or cioscorp. That's fantastic if you use those, I don't. I'm on cios10 with, as far as I know, all the ios files. I have no idea if they're trucha bugged and, I honestly don't know if that's important. Could you please help me? I don't want to sound too hateful here but, you guys are really bad for answering the questions that pertain to certain situation then, assuming that everyone can just figure it out from there.
     
  2. rustybanana

    rustybanana GBAtemp Fan

    Member
    316
    0
    Jun 11, 2009
    UK
    Install 4.1 from nintendo then load tbr from the homebrew channel and re-trucha you ios [​IMG]
     
  3. Wiinie

    Wiinie Advanced Member

    Newcomer
    50
    0
    Nov 15, 2008
    United States
    United States
    There is nothing special to the 4. update, just a fix to a bug in wii sports resort. Yes you cna upgrade through nintendo. No it will not affect your back-up channels or cios installed. If you dont know if you have trucha then you probably dont. If your not worried about cioscorp or preloader, than feel free to update from nintendo.
     
  4. MaGnUmKiLLa
    OP

    MaGnUmKiLLa GBAtemp Regular

    Member
    157
    2
    Feb 20, 2009
    United States
    United States
    Is the trucha bug restorer like super important? What would it mess with if I didn't restore them?
     
  5. sl33p

    sl33p GBAtemp Regular

    Member
    191
    7
    Dec 7, 2008
    United States
    I haven't given it a shot yet but can't you load this from a launcher (like neogamma) or USBLoader and avoid the need to update to 4.1 at all?
     
  6. nabster92

    nabster92 GBAtemp Advanced Maniac

    Member
    1,631
    0
    Apr 16, 2009
    United States
    The bug fix is that when you first load Wii Sports Resort it automatically plays the motionplus video (which requires you to do some alternate dol loading the first time you load it unless you load it through the disc channel) and then after you watch it you shouldn't have to anymore after that and no longer have to use the alternate dol loading as a result. If you play a game from the sd card menu after that however the bug makes you have to watch that video again for some reason and therefore have to do the alternate dol loading again. 4.1 is supposed to fix that error so you really only have to watch that video once.

    If you already have cIOS on your Wii the Trucha Bug Restorer is not really needed for you. The Trucha Bug Restorer is used to get the Trucha Bug back on IOS36 so you can use it to install anything else such as your cIOS to IOS249. Since you already have a cIOS you have the Trucha Bug in that IOS249 already.

    So as far as I know updating will only get rid of CIOSCORP and preloader and there are no hacks.ini for 4.1 at the moment so while preloader can be reinstalled it won't have any viable hacks yet.

    If you don't use those then you SHOULD be fine updating, but you might as well wait unless you use the sd card menu a lot and are playing the japanese version of WSR. If you don't do both of those then updating won't really do anything for you at the moment and by the time it does there may be some other method to update via homebrew or something in case there IS something else that the update does.
     
  7. shaka!!

    shaka!! Member

    Newcomer
    48
    0
    Apr 5, 2009
    New Zealand
    New Zealand
    Yesterday I updated to 4.1 thinking I was updating to 4.0 on a fresh, virgin Wii.

    I hacked it from the start with the 4.1 system and had no problems what so ever.

    Some people have said it might effect the Trucha Bug but I had no problems with it using the TBR and everything is working fine.

    Later noticed it said 4.1e in my Wii settings and I had a pretty good chuckle about it lol.
     
  8. jservs7

    jservs7 GBAtemp Advanced Fan

    Member
    891
    6
    May 14, 2008
    So I'm assuming that once Preloader hacks are defined for 4.1, then updating will be 100% ok? [​IMG]
     
  9. TheShadowRunner

    TheShadowRunner I'm like you, I have no name.

    Member
    666
    197
    Mar 14, 2009
    United States
    Hey all, i'm currently on 4.0u, I patched IOS60 in order to be able to load games from SD card.
    If I update to 4.1u the nintendo way, will i have to patch IOS60 again?
    In other words, does 4.1 overwrite the old/patched IOS60 from 4.0?
     
  10. MaGnUmKiLLa
    OP

    MaGnUmKiLLa GBAtemp Regular

    Member
    157
    2
    Feb 20, 2009
    United States
    United States
    that is a good question ShadowRunner and, I have to say, I appreciate everyone's help. I'm sure I sounded like a prick in my initial post but, you guys have been great.
     
  11. WiiBlaster

    WiiBlaster GBAtemp Maniac

    Member
    1,189
    0
    Nov 23, 2008
    United States
    it didn't when i updated to 4.1
     
  12. TheShadowRunner

    TheShadowRunner I'm like you, I have no name.

    Member
    666
    197
    Mar 14, 2009
    United States
    WiiBlaster, thx for your answer.
    So you can confirm loading games from SD still works fine after 4.1, without doing anything special?
     
  13. WiiBlaster

    WiiBlaster GBAtemp Maniac

    Member
    1,189
    0
    Nov 23, 2008
    United States
    yep it works fine
     
  14. 9th_Sage

    9th_Sage GBAtemp Maniac

    Member
    1,481
    1
    Apr 30, 2008
    United States
    The version number of the IOS should be the same still, so I'm going to guess this is why it didn't overwrite it.
     
  15. pm_41

    pm_41 GBAtemp Regular

    Member
    204
    0
    Jul 1, 2009
    United States
    Lurking in my Wii's NAND
    Will the Nintendo update overwrite preloader? (I've heard that if Preloader is overwritten, the Wii bricks.)
     
  16. nabster92

    nabster92 GBAtemp Advanced Maniac

    Member
    1,631
    0
    Apr 16, 2009
    United States
    It will get rid of preloader as any update would, but it shouldn't brick you. Also it seems Waninkoko already released a 4.1 updater app:
    http://gbatemp.net/index.php?showtopic=168153

    After you update you would just have to reinstall preloader, but there are no hacks.ini for 4.1 so you wouldn't be able to enable anything of that sort.
     
  17. ThatDudeWithTheFood

    ThatDudeWithTheFood TRIANGLEZ

    Member
    2,198
    291
    Mar 9, 2009
    United States
    Illuminati
    If preloader is overwriten than its overwriten by the original system menu so its kinda like System Menu is overwritten by Preloader therefore preloader loads because its in the place of the SM then preloader gets overwritten and deleted the system menu loads the way it should
     
  18. nabster92

    nabster92 GBAtemp Advanced Maniac

    Member
    1,631
    0
    Apr 16, 2009
    United States
    http://www.acc.umu.se/~zqad/cats/index.htm...2102-stoned.jpg
     
  19. zektor

    zektor GBAtemp Maniac

    Member
    1,325
    22
    Nov 29, 2005
    United States

    Exactly. What the fuck?

    Preloader shares itself with the system menu. So, if you update, a new system menu is installed...overwriting that "shared" system menu. It basically brings you back to square one...no preloader installed. So, when you update, you have to do it again (that is, install preloader again).

    That is the way it *should* be explained!