3gs unlock being a pain in the a**

Discussion in 'iPhone, iPod & iPad' started by kiel379, Dec 28, 2011.

Dec 28, 2011
  1. kiel379
    OP

    Member kiel379 GBAtemp Regular

    Joined:
    Aug 18, 2011
    Messages:
    129
    Location:
    england
    Country:
    United Kingdom
    hey, i have a 3gs new bootrom, baseband 6.15.00, the production date is before the hardware change. i have been useing redsnow 0.9.9b9d to jailbreak on 5.0.1 and ultrasnow 1.2.5 to try and unlock. here is what i do. download 5.0.1 ipsw, use custom firmware button in redsnow to cook a coustom ipsw file, put iphone in pwned dfu and shift click restore in itunes to restore to the ipsw i just made. all goes well but after it has completed itunes says it cannot connect to the itunes store but the phone works fine so i jailbreak it with redsnow which hacktivates it and preserves the baseband, then i install ultrasnow from a repo that has it, for some reason the official ultrasnow repo is empty so i get it from another one, i install it and it says "unable to activate mobile data network" (i dont know what this means). i then insert sim and it searches and then says noservice. the carrier and network settings on the iphone show the correct carrier whatever sim i put in and all the other stuff seems fine, when i turn airplane mode on and off it still says no service, i have done it with 3g on and off and mobile data and data roaming on and off. i have tried doing all this again, re flashing baseband and re installing cydia and ultrasnow, but it doesnt want to play, i am obviously doing something wrong, anyone out their know what it is??? i would owe you one big time if you could help.
     
  2. Originality

    Member Originality Chibi-neko

    Joined:
    Apr 21, 2008
    Messages:
    5,154
    Location:
    London, UK
    Country:
    United Kingdom
    I was curious, and that site would charge $231 for an iPhone 4 locked to T-Mobile in the UK. So much for affordable...
     
  3. yusuo

    Member yusuo GBAtemp Addict

    Joined:
    Oct 19, 2006
    Messages:
    2,196
    Country:
    United Kingdom
    If you haven't accidently overwritten the baseband then there is a solution.
    update to 5.1.1 re-jailbreak but make sure you keep baseband intact (if you forget dont worry you can re-install baseband when your in the process of re-jailbreaking)
    Install ultrasnow as usual and then add "http://repo.iparelhos.com" into cydia and install "Ultrasn0w Fixer for 5.1.1" and it'll work like a charm.

    Had me stumped for ages and this solved the issue straight away, oh just make sure you reboot after you install the fixer.

    Let me know how you get on

    And there is an untethered jailbreak available for 5.1.1
     

Share This Page