.3DS ROMs not working on R4i gold pro 2014

Discussion in 'R4 DS' started by Nellodee, Apr 9, 2014.

  1. Nellodee
    OP

    Nellodee Newbie

    Newcomer
    3
    1
    Apr 9, 2014
    Italy
    Rome
    Hey guys, sorry for being a total noob at this, but I've searched all around and I am at a loss. I need some help.

    I've just purchased an R4i gold pro 2014:

    [​IMG]
    [​IMG]

    The kernel that seems to work with it is the R4i-V3.3b, but while it can play all .NDS games (and also the GBA and SNES emulators), no .3DS ROM I have seems to work.

    Here's a screenshot of what's inside the kernel download.

    [​IMG]

    Also, on the website listed on the card sticker there's no firmware update download available, just the kernel in various languages ( http://www.r4isdhc.com/2014-r4isdhc-gold-pro/) .
    I've tried the kernel at http://www.r4i-gold.me/ : the r4isdhc-yellow1.72 with the _rpg folder and _DS_MENU.dat, but it won't work.
    Every time I've setup/tried a new kernel I formatted the SD card with the Panasonic SDFormatter before doing anything else (as recommended on various websites).
    Am I doing something wrong? Am I supposed to convert the .3DS files somehow? Have I been sold a spoof card?

    Thank you!
     
    Akawashi likes this.
  2. Pong20302000

    Pong20302000 making notes on everything

    Member
    8,076
    1,933
    Sep 8, 2009
    One's inner self
    thats because its a DS games Flashcard
    not a 3DS games flashcard

    there are 2 types of flashcard that work on a 3DS

    DS Flashcards, for playing DS games
    3DS Flashcards, for playing 3DS Games
     
  3. Nellodee
    OP

    Nellodee Newbie

    Newcomer
    3
    1
    Apr 9, 2014
    Italy
    Rome
    What? Really? I am such an idiot! :( It said 3DS on the package and I assumed it would work with 3DS ROMs.

    Where can I but a 3DS flashcard?
     
  4. Joe88

    Joe88 [λ]

    Member
    11,677
    2,960
    Jan 6, 2008
    United States
    NYC
    before any of that you must have a 3DS or 3DSXL on firmware 4.1-4.5 to use any of the current 3DS flashcards
     
  5. Pong20302000

    Pong20302000 making notes on everything

    Member
    8,076
    1,933
    Sep 8, 2009
    One's inner self
    they say 3DS to show they WORK on a 3DS, as the 3DS blocks flashcards

    the only 3DS Games Flashcards are Gateway3DS, MT-Card, R4i Gold 3DS Deluxe, 3DSLink, Orange3DS (listed in order of best compatibility)

    and yes as above says
    your 3DS must be on 4.1>4.5 Firmware
    and no you cannot downgrade if you are on higher
     
  6. Nellodee
    OP

    Nellodee Newbie

    Newcomer
    3
    1
    Apr 9, 2014
    Italy
    Rome
    Oh, well... I AM on a higher firmware, as a matter of fact (I think it was already higher when I bought it). I guess this card is better than a 3DS card that wouldn't have worked anyway. At least I can play SNES and GBA games now. :)

    Thank you so much guys, and sorry for being so naive and ignorant.

    Last question... any other emulator/homebrew that's worth checking out for my card?
     
  7. Akawashi

    Akawashi Member

    Newcomer
    39
    5
    Feb 25, 2014
    i have this cart... i cant get games to load at all... can you shed some light on how you set this up and do the pokemon games work?
    also. where can i get a gba emu for it?

    Any help would be great.
     
  8. Krakatau

    Krakatau Nintendo 3DS XL

    Member
    399
    119
    Nov 10, 2012
    Belgium
    You should buy a Gateway3DS, it has multi-rom support so you can basically also play every released 3DS ROMs. I don't think there is cheat support yet, and also some games have WFC problems, but I think that's basically the least of your worries. :)

    http://www.gateway-3ds.com/
     
  9. migles

    migles Mei the sexiest bae

    Member
    GBAtemp Patron
    migles is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    7,073
    4,755
    Sep 19, 2013
    Saint Kitts and Nevis
    my dad works for nintendo.

    are you trying to sell gateways? 2 threads telling about gateways, without telling the dude it requires a firmware range....
     
  10. Krakatau

    Krakatau Nintendo 3DS XL

    Member
    399
    119
    Nov 10, 2012
    Belgium
    No, but basically I think it's a great card for every 3DS user? Except for it's price, which can be called: 'expensive'.
     
  11. migles

    migles Mei the sexiest bae

    Member
    GBAtemp Patron
    migles is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    7,073
    4,755
    Sep 19, 2013
    Saint Kitts and Nevis
    my dad works for nintendo.
    if the user does have an higher firmware than 4.5 it is great for that user?

    please, if you gonna advertise at least don't do it without "hide" information, that person maybe have a 7.x firmware and you telling him to buy the card without let him know if it works on his console... a lot of people already buy theese cards whithout paying attention to firmware requirements...
     
  12. DiggingWolf

    DiggingWolf Newbie

    Newcomer
    1
    0
    Jul 13, 2014
    Netherlands
    Hey guys, so yeah, i bought a 2ds with version 6.0.0 without knowing all of this.... does this mean i can't use something like the gateway3ds?