3DS not loading luma anymore, soundhax/no apps running

Discussion in '3DS - Flashcards & Custom Firmwares' started by juins, Apr 25, 2017.

  1. juins
    OP

    juins GBAtemp Fan

    Member
    496
    68
    Sep 13, 2003
    hey guys i have a friends' old 3ds here on 11.3
    I got everything up and running after installing A9LH+Luma and installed all my stuff. Eventually i was curious and did the stuff mentioned here:
    https://gbatemp.net/threads/tutorial-using-luma3ds-with-gateway-on-v2-a9lh.431691/
    because i was curious if this method worked on 11.3. I DO know it worked on 11.2 and lower. Launcher loaded, but before entering sysmenu i got a black screen.

    Now, every game/app says this software could not be loaded.
    Luma3DS 'Select' menu wont run, neither will any payload.
    Entering HBL via soundhax returns immediatly to the main menu after it says 'The robpin is ready'.
    Basically any and all entrypoints into doing anything are not working. Its as if the 3DS returned to vanilla state.

    Can anyone help me out here? Really bizarre, have never seen this before.
    This is my first time working on 11.3 btw
     
  2. Decooter

    Decooter Advanced Member

    Newcomer
    55
    4
    Jun 16, 2011
    United States
    I'm by no means an expert so I could easily be wrong about this, but I thought I read somewhere that gateway only works properly on 11.2 or lower and that if you launch it on 11.3 or 11.4 it will screw with your a9lh and you'll lose everything.

    You might be fucked bro

    EDIT: By lose everything I meant it uninstalls a9lh and you lose cfw.
     
    Last edited by Decooter, Apr 25, 2017
  3. RedBlueGreen

    RedBlueGreen GBAtemp Advanced Fan

    Member
    993
    284
    Aug 10, 2015
    Canada
    by everything are you including the system apps or just the CFW installed titles? Try updating boot.3dsx and the otherapp payload, and then see if you can reinstall a9lh (I would highly recommend doing this after making a NAND back up if you don't have one).
     
  4. GothicIII

    GothicIII GBAtemp Fan

    Member
    499
    137
    Jan 4, 2015
    Gambia, The
    You screwed up. Using gateway on sysnand above 11.2 will remove a9lh because gateway didn't implement firm protection. GW is still not compatible with these firmwares. We have at least five threads already here on gbatemp discussing this issue.

    You are lucky to have an o3ds. You would have bricked if you used a n3ds.

    So read 3ds.guide and start from beginning again
     
    Last edited by GothicIII, Apr 25, 2017
  5. RedBlueGreen

    RedBlueGreen GBAtemp Advanced Fan

    Member
    993
    284
    Aug 10, 2015
    Canada
    Why would N3DS brick? What would the difference be that causes that?
     
  6. GothicIII

    GothicIII GBAtemp Fan

    Member
    499
    137
    Jan 4, 2015
    Gambia, The
    I am not reverse engineering this so I don't know for sure but I think it's because a9lh is differently implemented for o3ds. -> e.g. O3ds doesn't originally had a secret_sector.bin so in that case it just boots normally when the firmware messes with firm partitions for whatever reasons. For n3ds it's a brick because firm0 is broken (invalid hash) completely after this and it falls back to firm1 partition which is then also broken and because there is no fall back after that the system stuck on a black screen. N3ds has just an added layer of protection.

    Don't quote me on this though. Just speculating.

    Edit: or did I mixed something up and it really just removes a9lh? I am now not sure anymore.
     
    Last edited by GothicIII, Apr 25, 2017
    Quantumcat likes this.
  7. juins
    OP

    juins GBAtemp Fan

    Member
    496
    68
    Sep 13, 2003
    well, this is obviously a very unique case because since im on A9LH with a nand backup obviously i know that in any scenario i could just use my nand backup to restore.
    Is this confirmed that i lost a9lh? I've never read anything of the like. (EDIT: nvm, just read it.) Also, i couldnt be able to restart the whole thing because HBL isnt loading, it just returns me to main menu when trying to run it thru soundhax

    @RedBlueGreen only cfw stuff. normal system stuff runs fine.

    EDIT:
    on that note. is there a way to downgrade 11.3 to 11.2?

    EDIT2: nvm, got HBL to run thru soundhax again, gonna do the whole a9lh process again.
    Still wanna know if possible to downgrade 11.3 to 11.2 tho
     
    Last edited by juins, Apr 25, 2017
  8. Quantumcat

    Quantumcat Dead and alive

    Member
    11,109
    5,951
    Nov 23, 2014
    Australia
    Canberra, Australia
    Yes, once you get a9lh again, do a 9.2 CTR transfer then update with a Yoshi's Wooly World rom using Gateway mode. Or, you can find the 11.2 cias on that iso site and downgrade using sysupdater. Make sure you use emuNAND in future, Gateway is dangerous on sysNAND.
     
    OrGoN3 likes this.
  9. Hayleia

    Hayleia GBAtemp Maniac

    Member
    1,485
    1,136
    Feb 26, 2015
    France
    It is written 5 times in bold in big font at the beginning of the guide you linked and said you followed...
     
    Quantumcat likes this.
  10. Quantumcat

    Quantumcat Dead and alive

    Member
    11,109
    5,951
    Nov 23, 2014
    Australia
    Canberra, Australia
    LOL you are right. How could OP miss this? Literally the first words of the post, in extra large font and bolded.
     
    Hayleia likes this.
  11. juins
    OP

    juins GBAtemp Fan

    Member
    496
    68
    Sep 13, 2003
    @Quantumcat yea i was using that same page but i had it saved locally from months ago, so that bold text didnt appear on my local save. Checked after reading the comments in the thread and saw it. I edited my comment btw.
     
    Quantumcat likes this.
  12. juins
    OP

    juins GBAtemp Fan

    Member
    496
    68
    Sep 13, 2003
    @Quantumcat I know which iso site youre talking about and used to use it for 9.2 files, but i literally cannot find any 11.2 files on it

    Also, update using Wooly World in GW mode? How do u do that? i once was able to do it back in the day but I dont get update prompts anymore upon loading games.
     
  13. Quantumcat

    Quantumcat Dead and alive

    Member
    11,109
    5,951
    Nov 23, 2014
    Australia
    Canberra, Australia
    Sorry you're right the highest the files go on the iso site it 10.3. To disable update blocking, open the Gateway menu and hold Up when choosing to boot Gateway mode (I think - if it doesn't work and you can't find it how let me know and I'll do a search for you).
     
  14. juins
    OP

    juins GBAtemp Fan

    Member
    496
    68
    Sep 13, 2003
    @Quantumcat so i tried holding up upon loading GW mode, and that isnt the right button

    think u can figure out how to disable update blocking? I did some reading and it seems the up on dpad thing only works for emunand

    i gotta either
    -get a working 11.2 pack for sysdowngrader
    -some other kind of alternative to get on 11.2 (dont have access to cartridges atm)

    EDIT
    nvm, ur right, other games are offering updates, but my version of yoshis wooly world isnt...
    gonna find another version of the game and ill post back
     
    Last edited by juins, Apr 25, 2017
  15. Quantumcat

    Quantumcat Dead and alive

    Member
    11,109
    5,951
    Nov 23, 2014
    Australia
    Canberra, Australia
    Yep it is Up: https://gbatemp.net/threads/tutorial-update-emunand-via-rom-current-max-9-4-5.388692/

    If you have an emuNAND on your SD card you also have to hold a combination of buttons to boot sysNAND from the Gateway menu. It may be easier to get another SD card and just have the necessary files on it. That way there will not be an emuNAND present and you won't have to hold the combination.
     
  16. juins
    OP

    juins GBAtemp Fan

    Member
    496
    68
    Sep 13, 2003
    got it to work. Got ahold of another version of Wooly World and it updated to 11.2 just now. Thanks man
     
    Quantumcat likes this.