3.60 + Enzo + Adrenaline + Won't turn on after dead battery with sleep mode

Discussion in 'PS Vita - Hacking & Homebrew' started by retro_consoles, Sep 14, 2019.

  1. retro_consoles
    OP

    retro_consoles Newbie

    Newcomer
    1
    Sep 14, 2019
    United States
    Hi all,

    My PS vita won't turn on and I hope there's a fix.

    The Vita had f/w 3.60 with Enzo installed. I was running Adrenaline and playing the PSP game GTA Liberty City Stories. I put the Vita in sleep mode and left it on a shelf and forgot about it for several months while the battery died. I picked it back up and it will no longer turn on.

    The battery will charge to full, with the home button orange while charging. I installed a new battery thinking that was the problem. The new battery charged to full but still won't turn on.

    The only signs of life I can get from it is plugging it into a laptop where it will recognize the PS Vita, flash the home button blue once, and then disconnect from the USB. I can't get the Sony 'content manager' app to connect to it.

    I have tried the usual fixes such as: holding the power button 30+ seconds and holding the power button + home + Right shoulder for 30+ seconds. Do you know of anything I can do to bring this Vita back to life? Is it a glitch with the CFW and sleep mode while the battery died?

    Thanks for any help!

    UPDATE:
    I found the problem. Turns out the power button had stopped working... go figure. I found it by testing for continuity on the PCB while pressing the power button.
    I've replaced the power button and it boots right up now.
     
    Last edited by retro_consoles, Sep 18, 2019
Quick Reply
Draft saved Draft deleted
Loading...