3.2 To 4.1 Upgrade, Bootmii, Preloader, System Files Corrupt (IOS60)

Discussion in 'Wii - Hacking' started by xbman, Aug 3, 2009.

  1. xbman
    OP

    Member xbman GBAtemp Regular

    Joined:
    Feb 8, 2006
    Messages:
    130
    Country:
    So last Monday I finally decided to upgrade my 3.2U (which was downgraded from either 3.3U or 3.4U quite sometime ago). I did run into an initial problem during the 4.1 upgrade (following the guide here and using wanin's 4.1 upgrader) with a -1036 error which after searching, I found out was caused because I did not have an ISO60 installed. I believe this is part of the 4.0 system menu update, but really not an issue here.

    Anyway, late last week I ran into a problem after existing Wii Fit (channel/not the disc) back to the Wii System Menu with the "System Files Corrupt..." message. I power cycled a few times and it started working fine again. But it happened again this weekend and now it pretty much happens all of the time (only seems to be after exiting the Wii Fit channel).

    So a little more about my system. HBC 1.03 installed, Bootmii (boot2) installed, preloader 0.29 installed. Other various apps, etc. but nothing that should come into play at this point.

    The only hacks I have enabled in preloader are the disable update disc check and remove no copy flag. Otherwise everything else is disabled. My SD that I have been using does not work with Bootmii, so I changed the preloader setting to boot to the system menu. Again, otherwise everything is at it's default.

    After being stuck in this state for a while I decided to change preloader to use IOS249 for the system menu (running r14) and it seems to be working fine now. At least all the tests, apps, etc. work as expected and I have not seen the "SystemFiles Corrupt..." message with IOS249 (although it didn't happen until a few days after my initial upgrade to 4.1 and I do use the Wii Fit channel every day).

    I did try re-running dop-ios to reinstall ISO60 with the sig hash check and reinstalling preloader again, but the problem still persists (when using IOS60 for the system menu).

    So a couple of questions:

    1) Has anyone run into this before and know why IOS60 is causing this problem?
    2) Is it ok to use IOS249 (through preloader for the system menu)?
    3) Is there anything else I can check or any tools to verify the IOS is fine?

    To me, it would appear something is wrong with IOS60, but I have to admit I am no expert, just coming to that conclusion since that seems to be the only way I run into this problem.

    If anyone has any advice or suggestions, as well as being able to answer my questions, it would be much appreciated!
     
  2. Unfortune

    Member Unfortune GBAtemp Fan

    Joined:
    May 10, 2009
    Messages:
    342
    Location:
    Alberta, Canada
    Country:
    Pakistan
    run ios downgrader and wait till its done, then change preloader back to ios60 and see if its fine.
    (you need wifi for ios downgrader.)
     
  3. spacedkadet

    Newcomer spacedkadet Advanced Member

    Joined:
    Jul 26, 2009
    Messages:
    57
    Country:
    United Kingdom
    IOS 60 IS the system menu in 4.0+ it is needed for your wii to run at this level.

    IOS 249 is the ios that is installed by wanin's cIOSr14, it is a custom IOS based off IOS38 and is totaly safe. Most recent loaders use it so you will have no problems.

    Run wanin;s 4.1 upgrader and if needed rin wiipower's Trucha bug restorer.

    This should be all you need to get 4.1 fully softmodded.
     
  4. xbman
    OP

    Member xbman GBAtemp Regular

    Joined:
    Feb 8, 2006
    Messages:
    130
    Country:
    Thanks for the responses. So would the following be good steps to follow?

    1) Re-run the 4.1 upgrader
    2) Re-run dop-IOS
    3) Reinstall Preloader?

    Should I try downgrading first, and if so, what System Menu should I downgrade to?

    I still haven't noticed any problems with 249, but would like to get 60 working in case something hidden is lurking in there.

    I don't actually softmod (i.e. loaders, etc. - aside from the USB loader). I do have a d2ckey/wiiclip installed, but otherwise just HBC & the GX USB loader (with HD forwarder). Everything else are just apps launched from HBC.

    Thanks.
     
  5. xbman
    OP

    Member xbman GBAtemp Regular

    Joined:
    Feb 8, 2006
    Messages:
    130
    Country:
    I believe I may have resolved my issue (at least haven't been able to reproduce it yet) - but will keep monitoring and update again if it happens (or not).

    But what I first tried was re-running the 4.1 updater which just went to to a "press any key to restart" which I assume is because it checks to see if 4.1 is already installed (which it wast).

    So what I did was the following:

    1) removed the hacks.ini file (the one that was included in the upgrade guide). Got just the two hacks I wanted from wiibrew and created a new hacks.ini (and copied it to the sd card).

    2) launched HBC through bootmii and re-ran dup-ios to reinstall the latest version of ios60 with the sig hash check

    3) power cycled - which resulted in a system file corrup message (which was expected since I had preloader previously installed)

    4) launched HBC again through bootmii and reinstalled preloader

    5) launched preloader, enabled the two hacks, changed it to boot to system menu and changed it back to ios60 (it actually may have defaulted back to that with the reboot).

    So far I have not seen the problem, but again it didn't happen until a few days after I first upgraded. But as the problem related ti ios60, I guess something got corrupted along the way, so hopefully this has fixed it.
     

Share This Page