Homebrew 2GB SD Card problems

Jalkhov

Member
OP
Newcomer
Joined
Feb 11, 2020
Messages
19
Trophies
0
Age
26
XP
108
Country
Venezuela
Laptop: Lenovo Y560p Windows 10 x64 Bits

Devices
  • Micro SD Adapter: Kingston technology .
  • Micro SD: SanDisk 2 GB (1,83).
FAT32 Format GUI
  • With Allocation unit size from 32768
    • ERROR
      FSCTL_ALLOW_EXTENDED_DASD_IO OK
      ClusterCount=60334
      FAT32 must have at least 65536 clusters, try to specify a smaller cluster size or use the default
      Somewhere I read that the cards had to be formatted in this way, and when I did it with a 4GB card it ran successfully. I don't know if that number changes for smaller capacity cards.
  • With Allocation unit size from 4096
    • PASSED
      FSCTL_ALLOW_EXTENDED_DASD_IO OK
      GuiFormat version 1.02 x86 Windows version 0602 64 bit
      Size : 1GB 3862393 sectors
      512 Bytes Per Sector, Cluster size 4096 bytes
      Volume ID is f14:3737
      32 Reserved Sectors, 3765 Sectors per FAT, 2 fats
      481853 Total clusters
      481852 Free Clusters
      Formatting drive D:\:...
      Clearing out 7570 sectors for Reserved sectors, fats and root cluster...
      Wrote 3875840 bytes in 0.39 seconds, 9.48 Megabytes/sec
      Initialising reserved sectors and FATs...
      Done
      If you find this code useful please consider donating at
      http://www.ridgecrop.demon.co.uk/guiformat.htm
      When I install TWiLightMenu formatted in this way two things happen:
      • UnLaunch opens normally but when I assign BOOT.NDS as NO BUTTON I can't locate the file.
      • The UnLaunch gives me an MBR Empty error.
HDD Low Level Format Tool 4.40: All good, formated in Quick and Slow.
H2testw: Finished without errors.
HP USB Disk Storage Format Tool: Don't read the device.
SD Card Formatter: Correctly formated, but in FAT.
Diskpart: Correctly formated in FAT32.

Otras anotaciones:
  • I noticed that the adapter does not have the Block Switch activated.
  • All programs using have been run with Administrator permissions.

Before I used a 4GB SD Card and everything worked perfectly, at the moment of configuring the unlaunch I got the respective BOOT.NDS file. Of course, I was following the recommendation to fill part of the card with X files so that it would have 2GB available.

I could not continue using that card and I was left with the "2GB" and I thought that everything would be better because it is the one recommended, but nothing.

I wanted to be as specific as possible to avoid the "Try this...I already tried this" dialog. This way we can go straight to solutions that I haven't specified here.

I have visited posts where they raise similar problems but in the end they don't come up with anything specific.

Thank you very much in advance.
 

Jalkhov

Member
OP
Newcomer
Joined
Feb 11, 2020
Messages
19
Trophies
0
Age
26
XP
108
Country
Venezuela
Is this particularly problematic? As far as I know, FAT(16) 32KB clusters should be fine
When I installed TWiLightMenu, the BOOT.NDS file to configure it in UnLaunch did not appear.

Screenshot_1.png

This is the content of the sd card.
 
Last edited by Jalkhov,

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
  • No one is chatting at the moment.
    HUNTERFOX @ HUNTERFOX: Gn fr