2GB Mini-SD only shows as 1GB?

Discussion in 'General Off-Topic Chat' started by Darkforce, Dec 26, 2006.

Dec 26, 2006
  1. Darkforce
    OP

    Former Staff Darkforce DERP!

    Joined:
    Nov 5, 2002
    Messages:
    2,911
    Location:
    UK
    Country:
    United Kingdom
    As the title says I picked up a 2GB Mini-SD card from mymemory.com and when I stick it in my PC, even though the formatted size came to 1.89GB I could only put 960MB or so worth of data on it - i.e. 1GB capacity. I've tried a couple of SD formatting programs and when it's erasing the memory or whatever it shows as a 2GB card but the formatted size is now always 1GB.

    Mymemory are a big company and have been trading for a long time so I doubt they would have shipped a fake 2GB card. I know this is a fairly common problem; getting a PC to recognise a 2GB card to as a 2GB card!- I think... So I was just wondering if anyone knew of any good programs to format my SD card correctly!

    Thanks in advance. =)
     
  2. Qpido

    Member Qpido Call me Q.

    Joined:
    Jul 12, 2006
    Messages:
    634
    Country:
    Netherlands
    I had the exact same problem at first, but somehow it read 2gb after a while.
    I have NO idea how I fixed that.

    But just fill it up, see if it actually goes full.
    I'm sure you'll be rid of this problem in no time.

    Good luck.

    Q~
     
  3. cory1492

    Member cory1492 GBAtemp Maniac

    Joined:
    Jun 23, 2005
    Messages:
    1,488
    Location:
    Home, WhereElse?
    Country:
    Canada
    Darkforce: when it comes up as formatted 2 gig's, does it say ~960M is in bad blocks?

    I had this problem before, and using a different SD reader (one that came with my DSLink) plugged directly into the USB port of the PC (using an extension made the thing freeze up alot) was the only way I was able to format it as 2G and have the close to 2G actually free on the card. I came to the conclusion that either whatever drivers are working with the other readers, or the other readers themselves, were just not up to the task.
     
  4. Darkforce
    OP

    Former Staff Darkforce DERP!

    Joined:
    Nov 5, 2002
    Messages:
    2,911
    Location:
    UK
    Country:
    United Kingdom
    Sorted the problem!
    Like you said cory1492 it was my internal card reader that was the problem. I tried a cheap USB card reader and it worked perfectly. I don't understand why... after all they're using the same generic XP drivers right? Must be a hardware thing then? Guess it's time to buy a new card reader now. >_>
     

Share This Page