2ds xl. themes won't stay after i reboot my 2ds

Discussion in '3DS - Flashcards & Custom Firmwares' started by headcrash11, Sep 9, 2018.

  1. headcrash11
    OP

    headcrash11 Member

    Newcomer
    1
    Sep 9, 2018
    Mexico
    Hey guys I've been looking all over the internet in search for a possible solution for my problem what basically is that i purchased a theme.. applied the theme but when i reboot my system it will show me the default theme aka white theme. i have tried to do this with several themes but they wont stay after i restart. i have formated my sd to 32 try to applied and no luck. formated again to 64 cluster and didn't work. I've deleted the files from the 8f folder in exdata in nintendo 3ds folder to reset the menu settings and it didn't work. I have tried to install a theme with anome3ds and no luck, i really need help I'm new in this 2ds hacks i berally got mine like a week ago.

    NOTE: when i apply any color theme and restart.. it will show, but it won't work for the one i purchased

    PS: i have installed CFW Luma, the most recent one.

    please help!

    my sd card is a 32 gigs ADATA
     
    Last edited by headcrash11, Sep 9, 2018
  2. TurdPooCharger

    TurdPooCharger Meh

    Member
    10
    Jan 1, 2018
    United States
    Fix 3DS Theme Shuffle
    1. Copy everything off your SD card onto your computer.
    2. Download MiniTool Partition Wizard Free Edition.
    3. Because you used 64 KB cluster size on a SD card smaller than 128 GB, which is a big no-no for the 3DS, reformat the card with the following settings with that program:
      • Delete Partition
      • Initialize to MBR Disk -or- Convert GPT to MBR Disk (if it's in GPT Disk)
      • Rebuild MBR
      • Create a New Partition [ Create as: Primary | File System: FAT32 | Cluster Size: 32 KB ]
    4. Reformat the card again with SD Memory Card Formatter with the Quick format setting.
    5. Nuke it once more as FAT32 + 32 KB cluster size using guiformat.
      • We're going for overkill because you've dun goof using 64 KB cluster on a 32 GB card.
    Now that we're absolutely, positively sure your SD card does not have an improper partition table.

    6. While it's empty, use H2testw to Full Write + Verify Test that it's not a fake or bad card.
    7. If it passes, delete all the test files and copy everything back onto the card.
    8. Follow the instructions found here in the post about Fixing the Shuffle Install for Anemone3DS (v2.0.0 and newer).
     
    Last edited by TurdPooCharger, Sep 9, 2018
    NFates and zacchi4k like this.
  3. headcrash11
    OP

    headcrash11 Member

    Newcomer
    1
    Sep 9, 2018
    Mexico
    thank you for replying, I'll do this right away! and reply as quickly as i finish

    — Posts automatically merged - Please don't double post! —

    it does not give me the option for
    • Initialize to MBR Disk -or- Convert GPT to MBR Disk (if it's in GPT Disk)
    • Rebuild MBR
    do i skip these?
     
  4. TurdPooCharger

    TurdPooCharger Meh

    Member
    10
    Jan 1, 2018
    United States
    It means your card is already in MBR disk.
     
  5. headcrash11
    OP

    headcrash11 Member

    Newcomer
    1
    Sep 9, 2018
    Mexico
    Ohh ok so i will skip those steps!
     
  6. headcrash11
    OP

    headcrash11 Member

    Newcomer
    1
    Sep 9, 2018
    Mexico
    damn the sd is defective from one small portion the rest of the 28 gigs are fine
     
  7. TurdPooCharger

    TurdPooCharger Meh

    Member
    10
    Jan 1, 2018
    United States
    That tiny unaccounted for piece is fine. That means there's a small partition allocated for security stuff (it's not really needed).

    As long as the result states Test finished without errors, your card's fine.

    [​IMG]
     
  8. headcrash11
    OP

    headcrash11 Member

    Newcomer
    1
    Sep 9, 2018
    Mexico
    The media is likely to be defective.
    28.8 GByte OK (60595448 sectors)
    388 KByte DATA LOST (776 sectors)
    Details:0 KByte overwritten (0 sectors)
    0 KByte slightly changed (< 8 bit/sector, 0 sectors)
    388 KByte corrupted (776 sectors)
    0 KByte aliased memory (0 sectors)
    First error at offset: 0x0000000528d72800
    Expected: 0x0000000528d72800
    Found: 0x0008000520d42000
    H2testw version 1.3
    Reading speed: 17.5 MByte/s
    H2testw v1.4


    i got this :/ i think i need a new sd card
     
  9. TurdPooCharger

    TurdPooCharger Meh

    Member
    10
    Jan 1, 2018
    United States
    Oh wow, you're like one of the very rare few whose SD card is real but failed the test with dead NAND cell(s).

    Yah man, you gotta replace it.

    Go buy lottery ticket. :)
     
    zacchi4k likes this.
  10. zacchi4k

    zacchi4k GBAtemp Maniac

    Member
    7
    Feb 6, 2015
    Italy
    Somewhere eating pizza
    You've got a defective SD card :(
    You need to buy another one. Fortunately 32GB microSD cards are extremely cheap on Amazon, at least where I live
     
  11. headcrash11
    OP

    headcrash11 Member

    Newcomer
    1
    Sep 9, 2018
    Mexico
    good thing i have an extra sd card same capacity. I'll format it with mini tool to 32 kb cluster and also test it with h2 so i can know for sure I'm using a good sd card. I'll keep you guys updated, thank so much for your help!
     
    TurdPooCharger and zacchi4k like this.
  12. headcrash11
    OP

    headcrash11 Member

    Newcomer
    1
    Sep 9, 2018
    Mexico
    I coulnd't find my 32 gig, but i found a 16 gb. already formated to fat32 32k and now I'll just proceed to turbo poo's tutorial

    — Posts automatically merged - Please don't double post! —

    Test finished without errors.
    You can now delete the test files *.h2w or verify them again.
    Writing speed: 6.94 MByte/s
    Reading speed: 18.0 MByte/s
    H2testw v1.4
    16 gig results
     
  13. zacchi4k

    zacchi4k GBAtemp Maniac

    Member
    7
    Feb 6, 2015
    Italy
    Somewhere eating pizza
    The SD card is fine then
     
    headcrash11 likes this.
  14. headcrash11
    OP

    headcrash11 Member

    Newcomer
    1
    Sep 9, 2018
    Mexico
    when i inserted the 16 gig sd to the system, it said that it couldn't detect the sd card.. but when i pop it back to my pc it seems ok, format seems ok FAT32 32 K cluster, am i doing something wrong?
     
  15. headcrash11
    OP

    headcrash11 Member

    Newcomer
    1
    Sep 9, 2018
    Mexico
    nvm i formated it wrong, didn't convert it to MBR
     
  16. headcrash11
    OP

    headcrash11 Member

    Newcomer
    1
    Sep 9, 2018
    Mexico
    It works for multi themes, but it doesn't let me a main theme (just 1) it has to be multiple in order for them to stay :/

    — Posts automatically merged - Please don't double post! —

    just to say I'm running the 2ds with the 16 gig, and same thing happens. If i try to put just 1 theme... after reseting the system it will go away
     
  17. TurdPooCharger

    TurdPooCharger Meh

    Member
    10
    Jan 1, 2018
    United States
    If you followed the Fixing the Shuffle Install for Anemone3DS (v2.0.0 and newer) guide, can you verify whether your issue happens when you do a single theme install with Anemone3DS v2.1.0 Beta?

    You can find homebrew themes at themeplaza. Put a theme in the Themes folder placed in the SD root. Test out installing themes with Anemone to see if the problem is unique to your officially purchased theme.
     
  18. headcrash11
    OP

    headcrash11 Member

    Newcomer
    1
    Sep 9, 2018
    Mexico
    Yes it happens with a single theme install with Anenome3ds 2.0.1 as well. I downloaded 10 and tested like 6 and none of them were applied after i rebooted the console

    — Posts automatically merged - Please don't double post! —

    maybe i have something disabled from luma or something like that?
     
  19. TurdPooCharger

    TurdPooCharger Meh

    Member
    10
    Jan 1, 2018
    United States
    I experienced something kinda like this, and it wasn't pretty trying to fix it. I had theme installation bug messing with an old build of Anemone3DS along with changing my cluster size.

    That tutorial guide you used was based on an older, more detailed version: How to Properly Setup Anemone3DS when Changing Allocation Size
    Found in the posts here.

    You can try that one as there are extra steps versus the simplified one you tried earlier... I'm not sure if it'll work for you.


    Are you using the latest Luma3DS v9.1, boot9strap v1.3, and GodMode v1.7.1?

    In case you're using Luma v7.0.5 or older, you'll have to update from arm9loaderhax (a9lh) to boot9strap (b9s).
     
  20. headcrash11
    OP

    headcrash11 Member

    Newcomer
    1
    Sep 9, 2018
    Mexico
    I'll try to use this method

    Yes i have everything updated including boot9strap and godmode

    — Posts automatically merged - Please don't double post! —

    I noticed in my Luma configuration it has Enable game patching activated and Disable ARM11 exception handlers also activated

    — Posts automatically merged - Please don't double post! —

    also my autoboot doesn't start with emunand or so i think.

    — Posts automatically merged - Please don't double post! —

    Or is there a way to install the same theme in shuffle mode.. so that way it can have a semi-fix?
    i mean like get two same themes but 1 name it diffrent and then just apply it to shuffle theme so that way you'll have that theme everytime

    — Posts automatically merged - Please don't double post! —

    i kinda fixed it. I did what i mentioned to have 2 exact same themes. both installed in shuffle mode with Anemone xD but man how i wish no one suffers like i did. and yet... this is not a legit solution for the problem. Thank you.. guys for your time!!
     
    Last edited by headcrash11, Sep 9, 2018
Loading...