2DS ( A9LH, Luma ) can't play SSB, MH Gen, please help

Discussion in '3DS - Flashcards & Custom Firmwares' started by gcorners, Sep 27, 2016.

  1. gcorners
    OP

    gcorners Member

    Newcomer
    12
    0
    Sep 14, 2009
    Thailand
    Dear all,

    I followed Plailect guide to do A9LH with Luma
    on my 2DS and it's done perfectly.
    But I found that A9LH on O3DS/2DS can't play
    Super Smash and Monster Hunter with the RAM problem.
    I tried to search for the the guide to solve this problem on this page:

    https://github.com/AuroraWright/Lum...ng-luma3ds-work-with-an-external-boot-manager

    GBA/DS games/DSiWare/Smash Bros/Monster Hunter 4 fail to start
    You haven't configured Luma3DS to work with your boot manager, please refer to this for instructions.

    it's link to this :
    (Optional) Making Luma3DS work with an external boot manager
    If you're using a boot manager (BootCtr9, CtrBootManager9, ARM9Select, etc.) to load Luma3DS, you won't be able to play GBA/DSiWare games, or certain games that need more RAM on the device (such as Super Smash Bros).
    • You can disable your boot loader OR
    • Change Luma3DS's path (refer to the Options and usage page).
    then link to this:
    Use custom path: If the option is on, you can change the default location of the Luma3DS payload (which is arm9loaderhax.bin on the root of the SD) by typing it in a path.txt file in luma, it must start with a / and not exceed 55 characters. This path is also picked up if not booting via A9LH.

    But I don't understand how to do it,
    please someone kindly explain simple step for me T_T
    thanks a lot
     
  2. justln

    justln GBAtemp Advanced Fan

    Member
    709
    276
    Aug 16, 2013
    There is no solution, you can't play MHGen and Smash with 2DS or the Original 3DS because it doesn't have enough memory. End of Story.

    Edit: derped out, ignore my message.
     
    Last edited by justln, Sep 27, 2016
    retrofan_k likes this.
  3. aos10

    aos10 how i fotochop?

    Member
    3,112
    760
    Apr 10, 2012
    Saudi Arabia
    Huh? Because sysnand a9lh on old 3ds so he can't play those games?
     
  4. DBlaze

    DBlaze I don't know what i'm doing.

    Member
    208
    72
    Nov 15, 2006
    Netherlands
    That's funny, cause my 2DS runs both of them just fine.
    The only game from the top of my head only working on N3DS is xenoblade.

    Either way, I don't use a bootloader, so that might be the difference there.
     
    Last edited by DBlaze, Sep 27, 2016
  5. gcorners
    OP

    gcorners Member

    Newcomer
    12
    0
    Sep 14, 2009
    Thailand
    After I did A9LH by Plailect guide, is it has a bootloader ?
    I don't understand that which one is a bootloader
    because it's turn on and go to 2DS menu directly.
     
  6. DBlaze

    DBlaze I don't know what i'm doing.

    Member
    208
    72
    Nov 15, 2006
    Netherlands
    If you literally only did plailect's guide, you *should* be fine, as it doesn't user any external bootloaders.
    Did you install anything else besides what was said in the guide?
     
  7. Ghassen-ga

    Ghassen-ga GBAtemp Advanced Fan

    Member
    570
    358
    Jul 21, 2016
    They work just fine on my 2ds as well ..
     
  8. lyk93

    lyk93 Member

    Newcomer
    38
    4
    Dec 24, 2007
    Senegal
    Updated your firmware to the latest? Mh gen and ssb cannot boot on 9.2

    Sent from my Redmi Note 3 using Tapatalk
     
  9. gcorners
    OP

    gcorners Member

    Newcomer
    12
    0
    Sep 14, 2009
    Thailand
    I installed NTR and FreeShop, should not effect, right ?

    In the past, it's working on Emunand. But when I change to A9LH, it's not working T_T

    I use A9LH with Luma 6.3.1 on Sys 11.1 now.
     
  10. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ Spooky cute.

    Member
    20,079
    21,206
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    As detailed as this is, I really suggest keeping with the official thread, instead of making a new one
    Still, if you changed the payloads and it's not working, have you tried downloading the changed payload from this site?
    http://luma3ds.ericchu.net/
     
  11. DBlaze

    DBlaze I don't know what i'm doing.

    Member
    208
    72
    Nov 15, 2006
    Netherlands
    Gonna guess NTR is your issue then for games (Smash / MHG) that need all the RAM they can use on O3DS / 2DS systems
     
  12. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ Spooky cute.

    Member
    20,079
    21,206
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    NTR will not work with high memory games on the old3DS. Try running them without NTR running
     
  13. gcorners
    OP

    gcorners Member

    Newcomer
    12
    0
    Sep 14, 2009
    Thailand
    Thanks a lot, I will try. If I still have a problem, I will post on the main topic of Luma ^^

    I installed NTR, but I never run it before playing a game T_T
     
  14. Sketchy1

    Sketchy1 gbatemp's shadiest warez dealer

    Member
    1,514
    397
    Aug 9, 2016
    United States
    If you still have the problem, switch to luma 5.5 cause that helped me when I had this problem
     
  15. Sumea

    Sumea Disco Ninja Frog

    Member
    1,508
    278
    Aug 16, 2008
    Finland
    Turku
    All I can say is that the explanation is that the reboot patches Luma3DS has are not working correctly for whatever reason. 3DS does a hotboot into completely different home menu etc. modes to free up memory, disabling background processes like web browser, MiiVerse etc. To free up memory for the game software in 3DS. Smash Brothers, Monster Hunter 4 and Gen, and few other games do this (I think Hyrule Warriors 3DS too)

    So, Luma3DS has support for these games (which was not the case always BTW, RXtools had problems with this too and I think people figuring out reboot patching was THE thing)

    It would be weird though if only YOU have a problem with this. This does not seem to be any wider problem given lack of reports but to specify that the reboot patches are not working right for one reason or another.
    As I understand, one thing can be if you are ex gateway user, gateway system files or something like that can fuck up resources that CFW's want to patch or whatever when needed. May be a completely clean reinstall may be. I am just speculating, I hope aurora can specify and help with this.