2 3DS's on same firmware, flashcard only works on one.

Discussion in '3DS - Flashcards & Custom Firmwares' started by Austin1227, Aug 2, 2017.

  1. Austin1227
    OP

    Austin1227 Member

    Newcomer
    17
    0
    Jun 27, 2011
    United States
    Hello, a while back i completed a 3DS hacking guide to get FBI on my 3DS along with my brother's. They are both on the same 3ds firmware (11.2U, both the original 3DS). I have an R4 SDHC Dual Core card from 2015, from http://r4isdhc.com/, but it only works on his 3DS but not mine. I get a black screen saying an error occurred. The only things i can think that are different is that for his 3DS, is that he has to take out the SD card or his 3DS wont start, not sure why, and the other is that I have an external battery. Other than that they are exactly the same.

    Any thoughts why his would work and not mine?
     
  2. Lacius

    Lacius GBAtemp Guru

    Member
    5,634
    2,122
    May 11, 2008
    United States
    It's hard to know what the problem could be exactly. As a matter of troubleshooting, here's my recommendation:
    • On both 3DS systems, update to B9S and the latest version of Luma3DS following this guide if you haven't already done so: https://3ds.guide/a9lh-to-b9s
      • Following this guide should also fix the 3DS that has the SD booting issue.
    • If you're sure you're on the latest version of Luma3DS, update to 11.5 in the system settings.
    • If you continue to have problems with the flashcart, see this guide and follow the steps under DSi / DS functionality is broken after completing the guide: https://3ds.guide/troubleshooting
     
    Quantumcat likes this.
  3. TheZoc

    TheZoc GBAtemp Regular

    Member
    226
    21
    Apr 6, 2009
    Brazil
    Rio de Janeiro
    If his 3DS won't start without his SD card, he probably have A9LH installed and probably some sort of hack to remove the restriction on some Nintendo DS flashcards.

    There's a utility, also, that allowed me to run my old CycloDS on it, but I can't recall its name.

    Edit: On the link posted by Lacius, there is a file called "Nintendo DS Cart Whitelist - v11264.cia". That's probably the reason he can run that card and you can't.
     
    Last edited by TheZoc, Aug 2, 2017
  4. Austin1227
    OP

    Austin1227 Member

    Newcomer
    17
    0
    Jun 27, 2011
    United States
    Yep, it was the DS Cart Whitelist. I installed all the files in that section and it worked. Didn't do the B9S thing. I might do it later, but I don't really understand the purpose of Luma and a9lh and all that. Care to explain?
     
  5. Lacius

    Lacius GBAtemp Guru

    Member
    5,634
    2,122
    May 11, 2008
    United States
    If you want to use newer versions of Luma3DS and other applications, updating to B9S is required. Support for older entrypoints like A9LH has ended. The 3DS that won't boot without removing the SD card probably has a corrupt payload on the SD card and can only boot with the payload on the CTRNAND. Updating that 3DS to B9S using the guide I posted should fix that problem.