18 Month Old Official R4 Is Dropping .Sav files!

Discussion in 'R4 DS' started by donniedroc, Oct 22, 2008.

  1. donniedroc
    OP

    Newcomer donniedroc Newbie

    Joined:
    Apr 19, 2007
    Messages:
    5
    Country:
    United States
    Hello everyone. Longtime lurker, first time posting. [​IMG]

    Before going into my issue, let me get out in front of a few of the typical questions.

    No, I do not have an R4 clone. I have had the official R4 for around 18 months.
    Yes, I have formatted the microSD (a 1.0 gb SanDisk) and installed the official 1.18 kernel from r4ds.cn.
    I even removed all of my themes, and am now just using the default theme.

    Around 2 weeks ago, I loaded NDS 2596 onto the microSD, after not touching the DS for about a month (new baby came!). I was really excited for this game. I spun up the R4, and started the game. Played for 15-20 minutes, made sure it saved, then turned it off. When I came back a couple of hours later, the R4 said there wasn't a .sav and wanted to create it again. Knowing that I lost my work from the first 20 minutes, I rolled my eyes and tried again. This time, though, I didn't play the game. Started it up, then just turned it off. Immediately, I turned it back on, and no 2596.sav! So, instead I started up another file which already had a .sav. The game wouldn't boot, and the R4 locked. Reboot...and every .nds and .sav in that directory was GONE, about 400mb worth! (selecting the directory wouldn't even open an empty screen, just wouldn't drill to the next level) When I opened it on the PC with the card reader, the directory appeared to be empty, but the used space on the microSD was 960mb, as if the lost files were still on the microSD.

    So, that is when I started everything. Formatted the microSD (is FAT32 okay?), added the 1.18 kernel (a copy of what was already on there, as well as a new download). Quit dropping on my themes. At first, it still wasn't retaining the .sav files, but after 1 reboot, it started working! Unfortunately, this was temporary, and eventually an .nds in the directory locked again, and dropped everything in the directory!

    I am at a loss, as I couldn't find anything on the forums here (or on Google) that matched my experiences. I would appreciate any suggestions as to what is going on? Has my R4 finally died after 18 months of solid service? Is my microSD somehow broken or corrupted? Is the the error between keyboard and chair (me)?

    Thanks in advance.
     
  2. HBK

    Member HBK Clover - Fearless to Speak Now. ;)

    Joined:
    Mar 30, 2007
    Messages:
    1,813
    Location:
    Portugal
    Country:
    Portugal
    This could be a dodgy memory card or maybe the R4 bit the dust. Impossible to say, unless you have another microSD you could test it with and then isolate the problem. If it still continues to drop .savs when you use a different and proven good mSD card, then I'm afraid the R4 has finally died. [​IMG]
     
  3. Another World

    Former Staff Another World Emulate the Planet!

    Joined:
    Jan 3, 2008
    Messages:
    10,476
    Location:
    From Where???
    Country:
    Colombia
    first you must understand that the r4 is a dead kit, it is no longer made and no longer updated. the 1.18 firmware isn't fixing any new problems and that is the way it is going to be. problems with games can be soft reset issues, saving issues, header problems, etc. sometimes the firmwares are updated to fix these issues so when the rom is DMA patched before hitting the loader it will run and perform correctly. sometimes these issues aren't fixed, mostly on games which aren't very popular. you are playing a new rom dumped in the last few months. r4 has been out of business since the summer (jun/july) so your game missed the chance to get patched or fixed. i honestly do not think your problem has anything to do with your r4 but instead with the rom itself. you could try first to arm7 patch it. usually when a game needs to be arm7 patched its because it can't access the msd to write a save file. but i have read about rare cases where arm7 patching fixed corrupt save issues as well. in the case of bleach2 unpacking the rom and replacing the header file with the japanese version fixes not only the corrupt save issue but the broken wifi issue. so perhaps you want to try replacing the header. finally, go out and buy another micro sd card. you can get a 2gb japanese kingston off dealextreme for $7 or off meritline.com for $8.99-9.99 with a reader.

    here is the thing, if other roms/homebrew save fine and have no issues the problem is with that 1 rom. if everything else is having issue the problem is with the msd. letting your r4 sit around for a month will not do anything to it. i've left some of my old GBA kits sit for more than 3 years, only to get back into recently and all work perfect. while the kits aren't the same the circumstances are.

    do a gbatemp search for amr7fixa, its a little app cracker made that works with drag/drop. i've been told that 0864 - SimCity DS (J) & 2696 - Kirby Super Star Ultra (U) work well as donor files so try both.

    for unpacking the rom do a search for dslazy. there is a nice wiki site that has more info. once you unpack the roms to swap the header you will instantly understand what to do, all files are neatly placed in directories. repacking is just as easy with that app.

    goodluck,
    -another world
     
  4. Law

    Member Law rip ninjacat that zarcon made me

    Joined:
    Aug 14, 2007
    Messages:
    4,132
    Location:
    ‭jerkland
    Country:
    United Kingdom
     
  5. Another World

    Former Staff Another World Emulate the Planet!

    Joined:
    Jan 3, 2008
    Messages:
    10,476
    Location:
    From Where???
    Country:
    Colombia
    clearly after he corrupted the msd which negates all testing at that point to false results. please do not call my comments useless, just because you do not find use does not make them so. also cutting part of what i said out of the whole changes the meaning. i was making a point that if things work its that rom, if things don't work its probably the msd.

    -another world
     
  6. Law

    Member Law rip ninjacat that zarcon made me

    Joined:
    Aug 14, 2007
    Messages:
    4,132
    Location:
    ‭jerkland
    Country:
    United Kingdom
    Useless, unrelated, same thing. No point talking about how the R4 is a dead cart (Because it so isn't obvious) when it has nothing to do with the problem at hand. He'd already stated there was more than just the problem with the save file. To me the majority of your post read "I didn't read the OP fully". Oh, also. Top paragraph says "lolr4isdead", everything I snipped out underneath says "arm7patchit". No meaning had changed.

    Also, just checked. I think 2596 is "N+". I don't recall having any save issues with that ROM.

    OP, have you tried a different MicroSD?
     
  7. donniedroc
    OP

    Newcomer donniedroc Newbie

    Joined:
    Apr 19, 2007
    Messages:
    5
    Country:
    United States
    I greatly appreciate HBK and Another World's rapid suggestions and feedback here. While I might have tried to be more tactful, I was definitely with LAW regarding how the arm7 header on the n+ ROM would impact 12 month old ROM and their save. Again, thank you Another World for explaining that the msd could be compromised by this unpatched ROM.

    I want to answer questions, and ask some more of my own:

    1) When Another World says "MSD" does he mean the microSD?
    2) LAW (and HBK), no only have the 1 microSD right now. I ran to Target and Office Depot to pick one up, but I didn't want to spend the money on a larger (2gb+) microSD just for this test. I will probably run to Best Buy or WalMart to try to get my hands on a cheap 1gb.
    3) So, to clarify, Another World, your theory is that a recent, unpatched ROM has the ability to corrupt my entire microSD. Is this correct? Even if I do patch a new ROM, there is no guarantee that it will work, is there?

    Thanks again!
     
  8. Another World

    Former Staff Another World Emulate the Planet!

    Joined:
    Jan 3, 2008
    Messages:
    10,476
    Location:
    From Where???
    Country:
    Colombia
    @law: stating that the r4 is dead is the build up to describing why the firmware won't be updated. does he know these things? i can assume but i don't know i'm not inside his head. also for others who come to read this post adding as much information in relation to both his problem and the age of the kit seemed very relevant. my posts do not contain meaning or get to the point they contain information designed to help the person attempt to 1) fix their problem and 2) think for themselves. apparently you are judging me based on how my post reads to you, but you are not the majority. commenting on what annoys you about someone else’s post builds a conversation thread full of useless rebuttal where everyone wants to defend their thought process, useless banter.

    i made clear distinctions between the age of the kit verses the probability of having the firmware updated
    the possible arm7 and header fixes to attempt as they might fix the issue
    debugging by replacing the msd for a brand new one

    back on topic:
    'msd' yes does indeed mean microSD when i type it. my comments are in regards to the fact that some roms require a bit of patching (hacking) to get them working correctly on flash equipment. in regards to bleach2ds swapping the header fixes the save issue. i have had it corrupt the entire msd on more than one of my flash kits before doing this. on my r4 it only corrupted the save file and nothing more. that doesn't mean the entire msd corruption couldn't happen, that is why i suggested giving it a try. i'm mostly speculating based on what i have experienced and read about as to your problem. i know that arm7 and header swapping have fixed other roms - so could it work in this case? yes -- but is this the answer - not necessarily.

    at this point, after formatting and putting the firmware back on, other roms work but not this one? is that correct? if YES then i still feel its not the kit but that rom.

    try a few experiments. do an arm7 patch, try a header swap (if you can) and see if they make a difference. you can get the 1gb kingstons off maritline.com for around $5 with free shipping. they do coast to coast in 5 days, might be worth doing that if your are in the U.S.

    http://www.meritline.com/kingston-1gb-microsd-card2.html
    https://www.dealextreme.com/details.dx/sku.1458

    keep us informed i'm curious what will fix your problem.

    -another world
     
  9. donniedroc
    OP

    Newcomer donniedroc Newbie

    Joined:
    Apr 19, 2007
    Messages:
    5
    Country:
    United States
    I will definately keep you posted. Thanks for the help.

    I did have one more comment/question. Sure, I had put together that there were no new updates coming (since I hadn't seen one in a while, seen comments here, etc)...however, the r4ds website doesn't say it is a dead product...how do we know this? I seem to remember there was 4 months between the releases of 1.11 (7/30/07) and 1.12(11/21/07). Again, I am not trying to be confrontational, I am just trying to understand whether or not we are in another dry spell.

    Lastly, I see that n5 is just an r4 clone, and it got a recent update...will that update work on the r4?
     
  10. donniedroc
    OP

    Newcomer donniedroc Newbie

    Joined:
    Apr 19, 2007
    Messages:
    5
    Country:
    United States
    So, I decided that removing the n+ rom from the equation would at least give us some good troubleshooting information. Here were the steps I took:

    1) Formatted msd.
    2) Installed 1.18 firmware.
    3) Put 3 games on:
    a) Viewtiful Joe
    b) Mario vs Donkey Kong 2
    c) Crossword DS

    I was able to start each of the 3 games, play, shut down. As I rebooted, I could see that the .sav was retained. When I decided to start Crossword DS again, the "loading" screen came up, but the bar didn't move. Waited, nothing. Rebooted, now I cannot open the directory I put the games in.

    I am replicating the behavior, but N+ never saw the msd since it was formatted.

    I am having difficulties thinking that an msd can go bad...sounds like I need suggestions as to a new flash cart.
     
  11. Another World

    Former Staff Another World Emulate the Planet!

    Joined:
    Jan 3, 2008
    Messages:
    10,476
    Location:
    From Where???
    Country:
    Colombia
    the official r4 site no longer exists, what is up now is a archived version at a different host. the r4 is in a law suit with nintendo, you can read about it on this forum (use search) or by checking google. team r4 closed their doors at the end of the summer due to the cost of the kit, the dated feature list and the problems with nintendo japan. no official announcement was made, but those in the flash kit retailer end let some know, others heard it first hand from contacts, and the rest speculated.

    a msd is only good for about 10,000 read/writes and/or 4-7 years. some last longer, some die faster, shite happens. i really think you should try a new msd for $5-9 before you buy a new flash kit. if your msd is dead you will need a new msd for the new flash kit as well, and that’s double the money. if it isn't then you gain another msd. use the new one for movies or just emulation =)

    the only thing i know for sure about the n5 is that on the msd power cycle at boot up it has a design flaw that drains to much power. it can (and has) brick the ds by blowing a fuse. the fuse is actually pretty easy to replace if you can solder. as for the menu it might just be a decrypted version of the r4 menu. i'm sure if you did some searches on this forum you could get more information.

    cheers,
    -another world
     
  12. aerowalk

    Member aerowalk GBAtemp Regular

    Joined:
    May 22, 2006
    Messages:
    124
    Country:
    Australia
    i got quite same problem b4
    only with my m3dss, instead of r4
    turns out that my microsd is corrupted

    try get a new sd, see if the problem continues / not
     
  13. Shelleeson

    Member Shelleeson GBAtemp Advanced Fan

    Joined:
    Jan 30, 2007
    Messages:
    928
    Location:
    i'm here....silly.
    Country:
    United Kingdom
    yes they can and do
    i have 2 r4's and a m3dss and 4 memory cards, one memory card without warning just stopped working out of the blue last week and i tested it in the computer a phone and the other carts but it's gone and cannot be recovered
    if you can't get the computer to see it no matter what you do it's gone and ain't coming back
    i formatted the spare memory card and put it into the r4 that lost the memory card and it continues to play on fine
    original kingstons are covered by a lifetime warranty (not sure about other makes) [​IMG]
     
  14. donniedroc
    OP

    Newcomer donniedroc Newbie

    Joined:
    Apr 19, 2007
    Messages:
    5
    Country:
    United States
    So, it appears the msd was the culprit. Ran to Circuit City yesterday and picked up a 2gb Sandisk. I noticed as soon as I plugged the USB adaptor into the laptop that the file transfer was MUCH quicker than with the old 1gb Sandisk.

    First test was crossword ds, mario vs Dk 2, and New Super Mario. Worked like a champ. Then, added a few more roms, including the offending N+ (and a recently arm7 patched Sonic Chronicles). All of them are working great. I have rebooted, reset, tried everything I can think of to 'break' it, but it is behaving as normal.

    Unless I post again in the next couple of days, we can consider this solved! Thanks again for everyone's help.
     
  15. Another World

    Former Staff Another World Emulate the Planet!

    Joined:
    Jan 3, 2008
    Messages:
    10,476
    Location:
    From Where???
    Country:
    Colombia
    cheers mate, glad to hear it.

    -another world
     

Share This Page