100% g6 lite chinese ==> english

Discussion in 'Other Flashing Hardware & Software' started by tao168, Jul 18, 2006.

Jul 18, 2006
  1. tao168
    OP

    Newcomer tao168 Member

    Joined:
    Jul 1, 2006
    Messages:
    16
    Featured Posts:
    0
    Country:
    Australia


  2. Hypnotoad

    Member Hypnotoad GBAtemp Fan

    Joined:
    Jul 6, 2006
    Messages:
    312
    Featured Posts:
    0
    Location:
    Space.
    Country:
    United States
    Wow, with this new breaking I forsee every store being sold out of the Chinese cart in no time!
     
  3. MaDDaWg836

    Member MaDDaWg836 GBAtemp Regular

    Joined:
    Jun 21, 2006
    Messages:
    104
    Featured Posts:
    0
    Country:
    United States
    How will they handle new firmware updates? what version is this one?

    ps - this is amazing, but i can load english on mine [​IMG] this is still big for everyone
     
  4. Golds

    Member Golds Old Member

    Joined:
    Dec 2, 2004
    Messages:
    373
    Featured Posts:
    0
    Country:
    United States
    i just wonder if this 1.0beta firmware will support later updates, (5.0 and so on)?
     
  5. tao168
    OP

    Newcomer tao168 Member

    Joined:
    Jul 1, 2006
    Messages:
    16
    Featured Posts:
    0
    Country:
    Australia

    i really think the g6 team will just make their own english one off this one, and in no time we'll see an offical g6 english firmware, hehehe =)

    ps. i thought the g6's were sold out all over despite in being in chiense, i don't know, but when my 1 was shipped out, every1 was complaining that they want one even though it was in chinese
     
  6. tao168
    OP

    Newcomer tao168 Member

    Joined:
    Jul 1, 2006
    Messages:
    16
    Featured Posts:
    0
    Country:
    Australia
    if they don't release an offical english one, then you can always flash it back to official g6 chiense loaders
     
  7. zim_

    Newcomer zim_ Member

    Joined:
    Jun 28, 2006
    Messages:
    23
    Featured Posts:
    0
    Country:
    United States
    is there any other way to flash other then using gba mode

    when i try no matter how, it always locks up when i try to update
     
  8. klonoakun

    Newcomer klonoakun Member

    Joined:
    Jun 30, 2006
    Messages:
    32
    Featured Posts:
    0
    Country:
    WHATTHEPWNED!!!!11!!!1
     
  9. outphase

    Member outphase Custom title

    Joined:
    Nov 21, 2005
    Messages:
    1,218
    Featured Posts:
    0
    Country:
    United States
    the info tab says it's just v4.0 beta
     
  10. leonardo71286

    Newcomer leonardo71286 Advanced Member

    Joined:
    May 27, 2006
    Messages:
    57
    Featured Posts:
    0
    Country:
    United States
    Yeah it is. This had been posted before on these forums (don't remeber exactly which thread) and it's just an older
    firmware which happens to have both english and chinese languages. However if you try to update to english 4.0c
    after installing this, my guess is that it won't work. I'm still looking forward to a hack. Something tells me that the
    Chinese firmware has built in english support but that it was disabled in the source code.
     
  11. tao168
    OP

    Newcomer tao168 Member

    Joined:
    Jul 1, 2006
    Messages:
    16
    Featured Posts:
    0
    Country:
    Australia

    but i couldn't flash my g6 lite with the old 4.0c beta english, is weird, with this it works fine..........maybe i got a bad file or maybe someone just made it flashable, i don't know
     
  12. outphase

    Member outphase Custom title

    Joined:
    Nov 21, 2005
    Messages:
    1,218
    Featured Posts:
    0
    Country:
    United States
    I just tested it. v4.0 beta -> v4.0c english doesn't work on chinese version... which is always the case
     
  13. leonardo71286

    Newcomer leonardo71286 Advanced Member

    Joined:
    May 27, 2006
    Messages:
    57
    Featured Posts:
    0
    Country:
    United States
    I don't think there is/was a v4.0c beta.
    As far as I know these are the firmware versions that have come out for G6Lite:

    v4.0beta:
    Major update, oldest and the only one with dual language

    v4.0a:
    Minor update, the version included in most final G6 package CDs

    v4.0b:
    Minor update

    v4.0c:
    Minor update

    v4.1:
    Minor update, still only in Chinese
     
  14. fatfree

    Newcomer fatfree Advanced Member

    Joined:
    Jul 13, 2006
    Messages:
    80
    Featured Posts:
    0
    Country:
    I'm not understanding this thread correctly...

    What I think is going on is downgrading firmware??

    The G6 lites come with 4.X firmware, and this thread is telling people to flash it with 1.0 beta firmware.

    Is this right?
     
  15. exile

    exile Newbie

    Sorry for the slightly offtopic question, and I understand that I missed some discussion on this, but is there really any reason to care if I get a chinese version or not?

    I mean for the most part everything is straight forward and easy to use and understand correct? I could care less about the pda function but it would be nice if the rest of the info (game names, etc...) were at least in english so I could enjoy it a little bit more.

    Thanks for the info.

    EDIT - Nevermind, found the other thread talking about this.
     
  16. GameGeezer

    Member GameGeezer GBAtemp Regular

    Joined:
    Jun 29, 2006
    Messages:
    222
    Featured Posts:
    0
    Country:
    United States
    I just received my g6 lite today and was loading the various builds of the loader. My lite is the Chinese version. It came with the 4.0a software loaded. I tried to load the 4.0c English version and it loaded but gave me the English language error others have been talking about. Then, I loaded the 4.0 beta loader described in this thread and it worked fine and 100 % in english. I had no problems with any of the 14 or 15 games that were loaded on it. I did have a problem with pocketnes and ebooks opening on the gba side but other emulators did work so I'm assuming there is a compatibility issue beyond my scope.

    Also, I tried Mario Kart DS and got the same data related error many people had and confirmed that it was a problem with the rom. It seems the (U) version did not work but the (E) version did work. The game ran, WIFI worked, etc.

    Other things. My G6 lite seems to have come with the "old" style casing instead of the one with holes in recent threads. Also, I put some .txt ebook files on the u drive and tried to read them in the gba media center area and was actually able to read one from the text file but others did not want to be read. Does anyone have any information on this reader in english? If I find more about this I'll let you know. A built in reader is a nice feature.

    I really have no complaints at this point. I messed with the Chinese loader for a while before updating and it really didn't make much of a difference. You still have the icons of most games and it is possible to show the names of the roms in english. The important things you need to assign to the roms are in the pc software for the most part and that is completely in english.
     
  17. MaDDaWg836

    Member MaDDaWg836 GBAtemp Regular

    Joined:
    Jun 21, 2006
    Messages:
    104
    Featured Posts:
    0
    Country:
    United States
    well my g6 lite with 4.0c english runs mario kart (U) with wifi perfectly =\
     
  18. GameGeezer

    Member GameGeezer GBAtemp Regular

    Joined:
    Jun 29, 2006
    Messages:
    222
    Featured Posts:
    0
    Country:
    United States
    May just be a bad version of it then. thanks
     
  19. dem1980

    Newcomer dem1980 Member

    Joined:
    Mar 2, 2006
    Messages:
    32
    Featured Posts:
    0
    Country:
    France
    this **great** tip doesn't solved our problem, does it ?
    we can't install lastest english loader into our chinese g6 lite...
    am i right ?
     
  20. MaDDaWg836

    Member MaDDaWg836 GBAtemp Regular

    Joined:
    Jun 21, 2006
    Messages:
    104
    Featured Posts:
    0
    Country:
    United States
    yes sir you are correct
     

Share This Page

Loading...