1.0 user here and I don't know what to do

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by PalomPorom, Oct 8, 2018.

  1. PalomPorom
    OP

    PalomPorom Advanced Member

    Newcomer
    2
    Jul 11, 2018
    United States
    I have a switch on 1.0 and i want to stay. I've been playing catch up with the switch scene so I'm a bit lost and have some questions.

    As long as I follow the tutorial for ChoiDujourNX I can upgrade but can still downgrade back to 1.0 if I want? As long as I install briccmii or autorcm and always boot from the Hekate payload that supports kip1patch so the game cart reader doesn't update? Also I'm assuming installing autorcm would be the first step in that?

    So as long as I have that right I'm not sure what to do here.
    I could do that, buy another exploitable switch to have on newer firmware, or cave in and pay for sx os for emunand. Unless Hekate, Raj, or Rai CFWs will be adding emunand as a feature in the near future. And I don't think atmosphere will be finished for a while.

    I'm really itching to play the new Xenoblade that just came out and pokemon is a month away but I don't want to miss out on any 1.0 coldboot goodness. I don't really want to support TX but 30 bucks is cheaper than a new switch so I can't make up my mind. Anyone care to drop some wisdom on me?

    Sent from my toaster running rebug
     
  2. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    There have been plenty of people who held onto a 1.0 console then updated their firmware with ChoiDujourNX to their firmware of choice. The whole point of using it is that it doesn't burn your fuses unlike the official system firmware updates installed by Nintendo. This is because those remove AutoRCM and reboot the console into the built-in bootloader while ChoiDujourNX installs AutoRCM by default to prevent the console from rebooting into the built-in bootloader. The gamecart slot is prevented by having the fs_nogc.kip patch applied either as an fs.kip file, launch configuration in Hekate/RajNX, or having an empty file named nogc with ReiNX.
     
  3. annson24

    annson24 The Patient One

    Member
    6
    May 5, 2016
    Philippines
    Wait. I didn't have that fs_nogc.kip, I just used kip1patch=nogc. Is my gc slot screwed?

    Sent from my SM-G950F using Tapatalk
     
  4. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    Yeah that's fine, I indicated you can use that as a launch configuration if you don't have the file since Hekate now supports that (initially it did not hence why rajkosto made a temporary fork that automatically patched it).
     
    annson24 likes this.
  5. Only1chance

    Only1chance Member

    Newcomer
    1
    Aug 7, 2018
    Costa Rica
    Im also a 1.0 proud owner, Im just waiting for official emunand which will take a few weeks, (not the fake TX's horrible "emunand" that gets you banned) My plan is to have sysnand on 1.0 (for future proof and cool stuff in future), one SD card w/ latest for online games and eshop purchase, and a second SD card (Always offline) w/ hacks/nsp/emulators/etc. I will be here soon.
     
  6. Milenko

    Milenko GBAtemp Advanced Maniac

    Member
    9
    Oct 16, 2017
    Australia
    Who says emunand is coming that soon?

    And yeah it's so easy to use ChoiDujour
     
  7. fisher6

    fisher6 Member

    Newcomer
    3
    Jul 14, 2017
    United States
    I had the same issue with my 2.3.0. Last week, I decided to try ChoiDujourNX and it worked fine. Using ReiNX 6.0.0 now with nogc file. I initially had lots of issues with cfw not booting (in order to upgrade using ChoiDujourNX). Turns out the issue was my SD being formatted to exfat which is an issue on lower firmwares, an update needs to be downloaded.

    I first used my exfat formatted SD to make a nand backup of everything there is to back up in hekate. Moved all the files to an external hdd and my desktop. Formatted card as fat then booted RajNX, updated with ChoiDujourNX to 6.00 (with exfat support) and then booted ReiNX 6.0.0. No issues so far!
     
  8. BL4Z3D247

    BL4Z3D247 GBAtemp Stoner

    Member
    7
    Oct 22, 2008
    United States
    I'm so high, I don't even know!
    I suggest you upload the files to the cloud as well. Never know if a file or drive may corrupt, this way you can easily download them if anything ever happens.
     
  9. PalomPorom
    OP

    PalomPorom Advanced Member

    Newcomer
    2
    Jul 11, 2018
    United States
    So where does one go to get firmware packs? Or is that not allowed here? I can't dump any newer firmware games to extract the update because I'm on 1.0. Tried a couple scene releases and they must be eshop rips because I kept getting an error about the xci file trying to extract it.

    Or can you update via cart? I know you can't update through settings or it will wipe autorcm.

    Sent from my toaster running Rebug
     
    Last edited by PalomPorom, Oct 8, 2018
  10. shremi

    shremi Member

    Newcomer
    2
    Mar 29, 2016
    Mexico
    I also have a 1.0 console that i purchased a while back for hombrew .... i was away for a while but now i want to get back into it..... so it seems we should wait for proper emunand ???

    Edit: I have bought the xecuter pro OS and it is also sitting here wondering what are the best practices to at least get some fun in the meantime...
     
    Last edited by shremi, Oct 9, 2018