Search results

  1. katrinasofia

    Can't install NSP after updating both AMS & switch firmware

    Hi! I'm running version 13.0.0 and AMS 1.2.4|S. I just updated everything so I could play Skyward Sword and Metroid Dread but I can't even install older games, like Mario's Odissey. A bunch of errors when I do it through Goldleaf 0.9 (2145-0001 (0x291) being the most common. With newer games...
General chit-chat
Help Users
  • No one is chatting at the moment.
    Dark_Phoras @ Dark_Phoras: Have you tried Dragon Ball Fighters? It's surprisingly fun