Skylanders Imaginators Save 11-12-18

SkylandersSave

  1. sbaq
    sbaq
    5/5,
    Version: 2018-06-21
    Not all Skylanders are playable?
  2. hrtbrkd
    hrtbrkd
    5/5,
    Version: 2018-06-21
    This save works for 1.1.1 and will be corrupt if you load it to a lower version of the game.
    1. DarkCrudus
      Author's Response
      Oh right! Totally forgot about that. Will update the notes about the requirement
  3. Zumoly
    Zumoly
    5/5,
    Version: 2018-06-21
    Does what it says!