Resource icon

EZ5i firmware update and unbricker 108a

This download is only applicable to EZ5i users, it is not to be confused with the bootstrap updates of the earlier EZ5 models.

Please note at present this has nothing to do with game compatibility, game compatibility is determined by the loader updates which all models of the EZ5 can use.

Explanation/guide.
The EZ5i, unlike most other previous carts, is able to update the core/internal loader (ostensibly as a means to counteract any DSi updates) which controls how the EZ5i interacts with the DS and memory card as well as the internal hardware.
To use simply extract the .nds file to the root of the card (the first directory as in e:\ or wherever your card reader puts the memory card) run it and follow the on screen instructions. Users are strongly advised to have a fully charged DS before undertaking this.
If your cart says no need to update then check this thread and look for some answers first: sometimes the EZTeam release updates for specific hardware revisions that do not have updates for other revisions in.

Here is a video showcasing the fix for 1.4 but it also shows the update procedure:
http://www.youtube.com/watch?v=JpYABH7z4lM&fmt=18
General chit-chat
Help Users
  • No one is chatting at the moment.
    NoobletCheese @ NoobletCheese: Hi Ramesh, please join our weird puddle.