coolgamer

3DSTT patch for 3DS2.0&DSI1.43 3.0

  1. coolgamer
    This is the patch for 3DSTT , after update with the patch successfully , your 3DSTT flashcard can support 3DS2.0 & DSi 1.43

    http://www.aceshop.jp/3dstt-p-248.html