WiiFlow - an open source GUI USB-Loader

Discussion in 'Wii - Backup Loaders' started by zorglub07, Jan 17, 2010.

  1. modbrain

    modbrain Advanced Member

    Newcomer
    55
    9
    Apr 30, 2017
    Jamaica
    I have done the all neek2o stuff. (Even changed the pln2o path's inside the wiiflow.ini file

    Maybe i try to load up Majoras Mask (VC) and see if this gives me the same error - hope the error (if there is one) is at the start of the game ;)
     
  2. modbrain

    modbrain Advanced Member

    Newcomer
    55
    9
    Apr 30, 2017
    Jamaica
    Ok. I tweaked the "per-game-settings" to Force "PAL 60" - now it works. But when i try to end it (home button) it should go back to Wiiflow (i have this in the main settings configured like this) BUT it freezes to black screen.

    There's always something i guess.. Well now i go to sleep. Tomorrow is an other day. Goodnight

    :sleep::sleep::sleep:


    .
     
  3. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,165
    802
    Mar 2, 2015
    United States
    Wiiflow has a hidden channel you need to install to get the returnto feature to work. If you use the forwarder installer app it should take care of both.
     
  4. modbrain

    modbrain Advanced Member

    Newcomer
    55
    9
    Apr 30, 2017
    Jamaica
    Hmm.. i remember when i was using "showmiiwads" that there was something on the "emulated neek2o nand" called "Hidden Channel". Does that mean i have to go to HBC on my real nand and install this "wad" with a wadmanager programm - ? - plus i already have a forwarder for wiiflow installed on my real nand.

    Or do i have to install these wads in emunand. (?)

    Because
    there seems to be a problem with something - all my Wii, VC & Wiiware (expect the neek2o ones) retrun flawless back to wiiflow. BUT when i use any emulator, instead of returning to the loader, they all return to system menu. (?)




    UPDATE:


    Inside the "WiiFlow_v4.2.3_Nintendont_MasterMod_Pack_Full_2016" package i have found a folder with wads - are those the wads you refering to?

    wad (folder)

    Back 2 Nand for Uneek2o - NK2O v4.2 vWii.wad
    Back 2 Nand for Uneek2o - NK2O v4.2 Wii.wad
    Back 2 Real-Nand for Sneek2o- NK2O v1.0.wad
    Neek2o Uneek - NK2O v4.2 vWii.wad
    Neek2o Uneek - NK2O v4.2 Wii.wad
    WiiFlow Channel - Clouds v14b - DWFA.wad
    WiiFlow Channel - Clouds v15 for vWii - DWFA.wad
    WiiFlowLoaderChannel v2 - WIIH.wad

    If that's so, which should i install (i guess the vWii are for WiiU so i don't need them). And a Wiiflow channel forwarder i already have, or should i delete that forwarder wad and install the above?


    .
     
    Last edited by modbrain, Jun 2, 2017
  5. fledge68

    fledge68 GBAtemp Advanced Fan

    Member
    968
    529
    Jan 30, 2012
    United States
    yes for emulator/plugins you need the hidden channel to return to wiiflow. wii and wiiware/vc use cios d2x to return to wiiflow.

    install the WIIH.wad unless you are on vWii. if on vWii then you will need to use the wiiflow channel installer in the apps folder of the mastermod pack.
     
    modbrain likes this.
  6. modbrain

    modbrain Advanced Member

    Newcomer
    55
    9
    Apr 30, 2017
    Jamaica
    Thank you guys - everything works now as it should. Thank you. :toot: :yay: :toot: :yay:

    .
     
  7. modbrain

    modbrain Advanced Member

    Newcomer
    55
    9
    Apr 30, 2017
    Jamaica
    Just when i thought i have it.

    I deleted two WW wads through "showmiiwads" and loaded up 3 new WW wads. The new wads show up in emunand just fine (show me nand). But they don't show up in Wiiflow.

    Do i need to change something in wiiflow.ini ?

    I tried to delete them 3 wads and loaded em back up - nothing. All my other wads on emunand are displayed and work fine.


    .
     
  8. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,165
    802
    Mar 2, 2015
    United States
    You have to reload the cache when you change your games.
     
    modbrain likes this.
  9. modbrain

    modbrain Advanced Member

    Newcomer
    55
    9
    Apr 30, 2017
    Jamaica
    Is this normal?

    I play a Wiiware game in Wiiflow with "neek2o-mode" activated and return (with home button) back to loader. But now i can't play NO WW game at all. It's just the Wiiflow logo for a moment, then it returns back to game selection screen.

    I observed that, before i start a game in neek2o-mode, the settings in global menu are "USB1" - after i launch a game through neek it changes to "nand". Plus when i exit the loader, it brings me to the "system menu" of the emunand.

    So i thought maybe the other wads inside the "WiiFlow_v4.2.3_Nintendont_MasterMod_Pack_Full_2016" package" would fix this problem... so i installed these two wads that i haven't previously installed:

    Back 2 Nand for Uneek2o - NK2O v4.2 Wii.wad
    Neek2o Uneek - NK2O v4.2 Wii.wad

    But that didn't help. So i deinstalled them again - one of them only partially deinstalled:

    Uninstalling 1/2: Back 2 Nand for Uneek2o ..... OK!
    Uninstalling 2/2: Neek2o Uneek - NK2O ..... - Title (-106)


    Hope i didn't mess anything up.. I just wish there were some better tutorials on this, so i don't have to bother you guys...




    .
     
  10. fledge68

    fledge68 GBAtemp Advanced Fan

    Member
    968
    529
    Jan 30, 2012
    United States
    when you launched the game using neek2o and then exited the game you are now in neek2o mode. so yes your system menu is now your emunand. running wiiflow now is supposwed to work but i think some changes in neek2o broke that.

    anyway the back 2 nand wad is supposed to be installed on your emunand so when in neek2o mode you can select it to return to real nand system menu.
    neek2o uneek is supposed to go on real nand. i believe they are both nswitch (the same channel) so when you uninstalled the 1st one the second gave an error because it's already uninstalled.
     
  11. modbrain

    modbrain Advanced Member

    Newcomer
    55
    9
    Apr 30, 2017
    Jamaica
    Maybe because i used the neek2o mode before installing all the necessary wads to real-nand. Plus i had a little confusion before knowing how to updating the cache in Wiiflow. This may caused some disturbances.

    Do you think it will help if i give it an other shot?

    I delete everything:

    - delete Wiiflow from my SD card
    - delete all wads related to it: Back 2 Real-Nand for Sneek2o + WiiFlowLoaderChannel v2 - WIIH
    - delete everything on my USB stick (where EmuNand is located)

    And install it fresh?



    .
     
  12. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,165
    802
    Mar 2, 2015
    United States
    For returning from neek2o you need the NK2O channel installed on your NAND dump, not on your real NAND. The loader also has to be able set the "return-to" title when starting the neek2o environment to launch the game. I'm not sure if WiiFlow or CFG support that.
     
  13. modbrain

    modbrain Advanced Member

    Newcomer
    55
    9
    Apr 30, 2017
    Jamaica
    @GreyWolf

    I got the pre-made emunand (E) from the official and latest "Mastermod.." package.

    These are the wads that are (pre-) installed in this emunand:

    - Back to Nand (Title ID: NK2O / IOS Flag: IOS38)
    - postLoader(Title ID: POST / IOS Flag: IOS58)
    - Wiiflow Channel (Title ID: DWFA / IOS Flag: IOS58)
    - 2x Hidden Channel (1x Europe (IOS56), 1x Japan IOS58)

    If i understand it correctly, according to @fledge68 Wiiflow should be able to launch games again, when returning from a game that was started in "neek2o-mode".

    btw.
    Here is the problem better explained from someone who had the same problem:

    https://www.reddit.com/r/WiiHacks/comments/318vg0/wiiflowemunandneek2o_issue/?sort=old


    I wait on fledge68, if he thinks i can try to re-do it without troubles, then i'm gladly try it again :)



    .
     
  14. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,165
    802
    Mar 2, 2015
    United States
    The only way to exit NEEK is to reboot the console or turn it off so there is no way to return directly to the loader after booting a title via NEEK.

    neek2o has a way to specify what channel you want to return to when a title exits but since the environment is isolated it must be a title on your NEEK NAND dump. NK2O reboots the console if it's already running in NEEK so that is the best way to get back to real NAND on a regular Wii. vWii has a built-in channel that essentially does the same thing.

    If WiiFlow launches neek titles with setting the returnto to NK2O or the vWii one then it will reboot to real NAND. Otherwise it will still be running in virtual mode.

    That reddit post is from 2 years ago. :/
     
  15. fledge68

    fledge68 GBAtemp Advanced Fan

    Member
    968
    529
    Jan 30, 2012
    United States
    Are you on wii or vwii?
     
  16. modbrain

    modbrain Advanced Member

    Newcomer
    55
    9
    Apr 30, 2017
    Jamaica
    Wii (the one with GameCube controller ports)
     
    Last edited by modbrain, Jun 6, 2017
  17. fledge68

    fledge68 GBAtemp Advanced Fan

    Member
    968
    529
    Jan 30, 2012
    United States
    here is how wiiflow and wiiflow mastermod launch a game using neek2o:
    wiiflow launches neek2o with 3 arguments -

    1. the game title ID - so when neek2o boots it will auto start that game.
    2. the emunand path - so neek2o knows which emunand to use and where to find the game.
    3. the return to title ID - the ID of a channel on the emunand to launch when you exit your game.
    number 3 is the same as the return to channel you have set on pg4 of main settings for cios d2x to return to. most people set this to the wiiflow forwarder channel they have installed on real nand. but in order for that to work when using neek2o you have to have the wiiflow forwarder channel also installed on your neek2o emunand. and if you do, that means wiiflow is launching/running in neek2o mode after you exit your game. while in neek2o mode wiiflow acts as if your emunand is the real nand. and now if you go to home menu then exit to menu you can now select exit to real nand to exit wiiflow and neek2o and get back to the real system menu. but once back at the system menu wiiflow will not launch unless ... you have priiloader installed and use the wiflow priiloader dol to launch wiiflow or you have bootmii installed and use the wiiflow bootmii forwarder to launch wiiflow. but if you use either of those then wiiflow will autoboot every time you start your wii.

    wiiflow lite works the same except with wiiflow lite i have the return to for neek2o set to always be the back2nand channel to boot you back to the real system menu but requires that the back2nand channel be installed on your emunand.

    any more questions?
     
    Last edited by fledge68, Jun 7, 2017
  18. modbrain

    modbrain Advanced Member

    Newcomer
    55
    9
    Apr 30, 2017
    Jamaica
    Man i just re-installed everything and it's the same in green. Once i start a game in neek2o and retrurn to Wiiflow (now in neek2o mode) no other game can be played, not even the same game i just returned from. But it "should" work like:


    1. Start Wiiflow from real nand > Start any Wiiware in normal mode > Exit game > back to Wiiflow on real nand
    2. Start Wiiflow from real nand > Start any Wiiware in neek2o mode > Exit game > back to Wiiflow on neek2o nand
    3. Start Wiiflow from Neek2o nand > Start any Wiiware in any mode > Exit game > back to Wiiflow on neek2o nand


    A few things i observed this time:


    • When Wiiflow is in "default Theme" - and i try to play a game in neek2o mode - it doesen't play.
    • When Wiiflow is in "Carbon Abz Theme" - and i try to play a game in neek2o mode - it plays
    • When i go from System Menu in "Real-Nand" to System Menu in "Emu-Nand" and i try to play Castlevenia Rebirth, it freezes after logo (just like when i play it in Wiiflow (Real Nand) without "sneek2o-mode" ON.


    But hey.. im cool with it. I accept it how it is.

    Ima just install the few games that act up, on real nand with MMM. And done it is.

    Thank for all your help guys :yaywii:



    .
     
    Last edited by modbrain, Jun 8, 2017
  19. modbrain

    modbrain Advanced Member

    Newcomer
    55
    9
    Apr 30, 2017
    Jamaica
    Kinda as a last shot.

    Here is how i did it - step by step

    I take everything from "WiiFlow_v4.2.3_MasterMod Pack Full"


    USB1
    • I extract the "Premade Emunand" and copy the two folders inside "USB_Files" to my "USB1" (FAT32 / 32k)
    • nands
    • SNEEK

    SD
    • I copy the WiiExplorer folder from "Mastermod/apps" to "SD/apps"
    • I copy the Wiiflow folder from "Mastermod/apps" to "SD/apps"
    • I copy the Wiiflow folder from "Mastermod/root" to "SD/root"
    • I copy these wads from "Mastermod/wad" to "SD/WAD"
    • Back 2 Real-Nand for Sneek2o
    • WiiFlowLoaderChannel v2 - WIIH
    • WiiFlow Channel - Clouds v14b - DWFA

    I insert SD and USB1 to Wii
    • I go to "Homebrew Channel" and launch "WiiExplorer"
    • i follow the steps from tutorial
    • I go to "Homebrew Channel" and launch "WiiFlow"
    • I go to "Homebrew Channel" and launch "MultyModManager" and install the 3 new wads

    I eject SD and USB1 from Wii and connect them to PC

    • I go to "SD/Apps/WiiFlow" and edit the "Wiiflow.ini" like in tutorial
    • I run "showmiiwads" and copy the game wads like in tutorial to "USB1" path

    I insert SD and USB1 back to Wii
    • I launch "WiiFlow" with Forwarder Channel
    • I go to global "settings" and change two things:
    • I select the "Carbonicz Abz" Theme
    • I set the "return to" Option to "Wiiflow"


    *** Install Prozess finished ***


    I reboot the Console, go to Wiiflow, the games show up and play well.
    When i return from game i'm direct inside Wiiflow again (Real Nand). I can play the next game. I choose a game with issus like "Castlevania Rebirth" and change the "per game option" to launch game with neek2o : YES. I launch the game, but it freezes after Konami logo. I have to hard reboot the console.

    I repeat the steps but this time i additionaly change in "per game option" Videomode from "game" to "progressive". I launch the game, it works fine (saveing inside game works) i exit game to WiiFlow. I try to launch an other game, but the screen goes to black and returns to WiiFlow. I have to Return to Real-Nand and from there back to WiiFlow. Then it works again.
     
  20. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,165
    802
    Mar 2, 2015
    United States
    The original Wiiflow (and mastermod) doesn't support returning from n2o as far as I know. Fledge68's fork does.