Where can i download the 4.50 (or a higher, hackable) firmware?

Discussion in 'PS3 - Hacking & Homebrew' started by WiiFoundLove, Jun 10, 2017.

  1. WiiFoundLove
    OP

    WiiFoundLove GBAtemp Regular

    Member
    197
    62
    Jan 18, 2015
    Afghanistan
    Hi!

    Today i got a used PS3. It seems that a firmware update has failed before, it asks me for an USB-Stick with firmware 4.50 or higher. So now i want to try to reupdate/unbrick it, and since i would like hack it, i am looking for a source where i can download the 4.50FW (or a higher, hackable firmware).

    So does anyoune know where i can get it?

    Thanx :)
     
    Jayammi likes this.
  2. Gary Hamilton

    Gary Hamilton Advanced Member

    Newcomer
    76
    13
    Feb 25, 2016
    You cant Hack a PS3 on a firmware above 3.55 unless you got a Flasher but even that only works on some models.
     
  3. WiiFoundLove
    OP

    WiiFoundLove GBAtemp Regular

    Member
    197
    62
    Jan 18, 2015
    Afghanistan
    Oh, ok. But i still need the Firmware to reupdate/unbrick it.
     
  4. Gary Hamilton

    Gary Hamilton Advanced Member

    Newcomer
    76
    13
    Feb 25, 2016
    Sorry bro I am not 100% where to download it man. I am sure some 1 in the forum can point you in the right direction.
     
  5. WiiFoundLove
    OP

    WiiFoundLove GBAtemp Regular

    Member
    197
    62
    Jan 18, 2015
    Afghanistan
    Hm. I found a site that backuped some updates:

    http://www.psdevwiki.com/ps3/Main_Page

    But now i'm not sure which version i should choose. My PS3 is a EU. On the site there are Retail/CEX, Shop/SEX, Debug/DEX, Tool/DECR. Which one should i choose? What's the difference between x.xx and x.xx-patch? While the lastest firmwares are available for different regions, the older (4.50) are only available as one file without any information about the region they are for. Does ist matter which one i choose?
     
  6. Gary Hamilton

    Gary Hamilton Advanced Member

    Newcomer
    76
    13
    Feb 25, 2016
    Sorry man I hit a brick wall with my ps3. I bought another 1 after my original YLOD and that ended up not being able to hack/CFW on it as it was a newer ps3.
     
  7. tedmg091309131

    tedmg091309131 GBAtemp Regular

    Member
    116
    18
    Feb 17, 2016
    United States
    If your PS3 is still on ofw then choose retail (ofw). However you might try installing rebug cfw first.
     
  8. WiiFoundLove
    OP

    WiiFoundLove GBAtemp Regular

    Member
    197
    62
    Jan 18, 2015
    Afghanistan
    It's on OFW. Btw.: Is someone still working exploits for higher firmwares? Or is the PS3 development dead?
     
  9. Daggot

    Daggot GBAtemp Fan

    Member
    479
    297
    Aug 3, 2015
    United States
    Homebrew is still being made and all but there has never been an exploit past 3.55 that allows full CFW.
     
  10. Byokugen

    Byokugen Unit_01

    Member
    1,151
    659
    May 16, 2016
    Serbia, Republic of
    Just a bit to the right, or was left...
    Development is not, nor will die soon, but only 3.55 is exploitable, and only on phats and early slims, no superslims. Maybe some day, but who knows
    OP, still have problems? Was that ps3 on cfw or not?