We're almost there!

Discussion in 'Switch - Hacking & Homebrew' started by DarkOrb, Nov 11, 2017.

  1. UnsureSherlock

    UnsureSherlock Member

    Newcomer
    42
    69
    Aug 20, 2015
    United States
    Mine currently crashes out after dbg_printf() calls. Fairly sure it's my clang installation since I installed the stable from apt instead of 5.0.
     
  2. cloudfe

    cloudfe GBAtemp Regular

    Member
    243
    27
    Feb 24, 2013
    Belgium
    A few questions about Emunand (or its potential equivalent for Switch):
    1. Would it represent the only way to play (legit) games that require >3.0.0 firmware?
    2. Is a kernel exploit necessary to achieve it?
    3. Would we also need to decrypt the games in order to play with our (legit) cartridges?
    Needless to say, we're talking about an hypothetical (and probably very distant) future. But I'm curious (i.e. anxious :rolleyes:).
     
  3. Digital_0xFF

    Digital_0xFF Advanced Member

    Newcomer
    57
    28
    Oct 7, 2017
    Austria
    Repost .... :glare:
     
    Last edited by Digital_0xFF, Nov 14, 2017 at 10:02 AM
  4. cloudfe

    cloudfe GBAtemp Regular

    Member
    243
    27
    Feb 24, 2013
    Belgium
    I confess :shy:
    In my defense, no one replied...
     
    Last edited by cloudfe, Nov 14, 2017 at 10:04 AM
  5. Sephirosu

    Sephirosu GBAtemp Regular

    Member
    147
    56
    Jan 28, 2015
    Boca Raton, Florida
    in my limited understanding, emunand would work if they somehow find a way to bypass the first check the switch does which verifies the console's version. If they crack the bootrom open I think it would hold the key to doing so. Again, this is what I managed to understand. Not 100% sure.
     
  6. adrifcastr

    adrifcastr GBAtemp Advanced Maniac

    Member
    1,791
    818
    Sep 12, 2016
    Germany
    Because everyone can find out the answer by simply reading into how the OS and HW works.
     
  7. Digital_0xFF

    Digital_0xFF Advanced Member

    Newcomer
    57
    28
    Oct 7, 2017
    Austria
    1: emunand would be useless unless we find a way to accept only the needed content from an update (keys etc).

    2: yes would need kernel

    3: this would be the alternative to getting the new keys into old fw but how should the decryption be possible without obtaining the keys first?

    Tldr:no homebrew/piracy on switch will not be as easy as it was in 3ds days
     
    Last edited by Digital_0xFF, Nov 14, 2017 at 10:19 AM
  8. Jackson98

    Jackson98 Member

    Newcomer
    45
    14
    Aug 8, 2017
    Australia
    I doubt anyone will pay that much for a device that still cant do anything yet ;), yes it has potential but still nothing has been made we have no homebrew launcher or emulator ports. A year or 2 down the track if nothing else firmware wise pops up who knows :P. Maybe.
     
    nmkd and Bladexdsl like this.
  9. Bladexdsl

    Bladexdsl ZOMG my posts...it's over 9000!!!

    Member
    16,380
    3,971
    Nov 17, 2008
    Australia
    Queensland
    [​IMG]

    oh your serious? :blink:
     
    Last edited by Bladexdsl, Nov 14, 2017 at 10:40 AM
  10. xianbaby

    xianbaby Newbie

    Newcomer
    5
    2
    Oct 23, 2017
    United States
    Screenshot_2017-11-14_04-06-36.png

    neat!!!!! Right is output from Mephisto and left is output from a real Switch (from PegaSwitch)
    seems to crash to the "An error has occured" screen a lot on a real switch, and getting it to even run took like 5 attempts but I'm happy - I've been excited all day about coming home and getting userland code setup and working! look for "yeah ProcessNo: X"
     
    Last edited by xianbaby, Nov 14, 2017 at 11:27 AM
    DarthDub and MrGarapablo like this.
  11. Dodain47

    Dodain47 GBAtemp Advanced Fan

    Member
    802
    223
    Jan 1, 2017
    Austria
    You should censor your Switch´s serialnumber from those pictures. Big N is watching.
     
    Bladexdsl likes this.
  12. MrGarapablo

    MrGarapablo Newbie

    Newcomer
    2
    2
    Monday
    Spain
    Just a quick question: Brand new Switches come with a firmware lower than 3.0.0 or have already newer patches?

    I'm asking it because I'm going to buy one this week and I don't know if I should choose the console or the bundle with Odyssey.
     
  13. Dodain47

    Dodain47 GBAtemp Advanced Fan

    Member
    802
    223
    Jan 1, 2017
    Austria
    The Mario Odyssey bundle should be 3.0.1. Not sure about the console alone.
     
    MrGarapablo and xianbaby like this.
  14. xianbaby

    xianbaby Newbie

    Newcomer
    5
    2
    Oct 23, 2017
    United States
    Ah, thanks, I hadn't even considered that.
     
  15. Lacius

    Lacius GBAtemp Guru

    Member
    6,271
    2,558
    May 11, 2008
    United States
    The Mario Odyssey bundles seem to be 3.0.0, but the console will require an update to play Odyssey.
     
    CandraSoftware and MrGarapablo like this.
  16. Dodain47

    Dodain47 GBAtemp Advanced Fan

    Member
    802
    223
    Jan 1, 2017
    Austria
    Nice! Didn´t know that.
     
    MrGarapablo likes this.
  17. Bladexdsl

    Bladexdsl ZOMG my posts...it's over 9000!!!

    Member
    16,380
    3,971
    Nov 17, 2008
    Australia
    Queensland
    too late the black vans are on the way :creep:
     
    xianbaby likes this.
  18. ehnoah

    ehnoah GBAtemp Fan

    Member
    395
    74
    Oct 9, 2012
    Netherlands
    You have a Small Tutorial? Switch stuff is Setup on my Linux System. Just no clue how the command is to execute or if more is needed. I cloned The PegaSwitch Stuff.
     
  19. seanp2500

    seanp2500 Advanced Member

    Newcomer
    87
    28
    Jun 2, 2010
    United States
    i had to enable runnro adrifcaster did make a tutorial in this section which has more info
     
  20. TheGreek Boy

    TheGreek Boy GBAtemp Advanced Fan

    Member
    799
    244
    Jan 9, 2016
    Greece
    Behind you.
    i'm late in the switch scene, so we can run homebrew on 3.0.0???? my switch is on 3.0.0:)