USB Loader GX

Discussion in 'Wii - Backup Loaders' started by cyrex, Apr 19, 2009.

Apr 19, 2009

USB Loader GX by cyrex at 5:00 PM (3,817,986 Views / 7 Likes) 18,293 Comments

    • Member

    d.d.d. New Member

    Member Since:
    Jun 26, 2012
    Message Count:
    430
    Location:
    Tokyo Metropolis
    Country:
    Japan
    (Forgot which Wii I was running when I typed that.)
    My launch J-Wii did let me install the modified boot2 but it kinda 1/2 way died from the GPU pixelation (I wonder if I send it in for repairs if it will still have the vulnerability or not).
    My 2009 US-Wii (to replace the f'd up GPU J-Wii and what I currently use) would only let me install boot2 as IOS. So no matter what, I only get it as the IOS option because of the updated boot1 in manufacturing. No biggie~


    • Newcomer

    doveman New Member

    Member Since:
    Dec 22, 2011
    Message Count:
    62
    Country:
    United Kingdom
    Thanks Cyan. I thought I'd uninstalled the Full Channel which is why I was confused why it still seemed to be loading the old version rather than the one on the HDD/SD but I'll go through those steps again and hopefully clear it up.

    I've got the Wii booting directly into USB Loader GX so I'm not sure where it looks for the files if the Full Channel is uninstalled. I'll change it to boot into the normal Wii menu and try launching the Forwarder from there though. It's been a while since I looked at the boot settings (whatever comes up when I hold reset whilst booting, it's been so long I can't even remember what that's called!) so it might become obvious once I have a look at them.
    • Newcomer

    doveman New Member

    Member Since:
    Dec 22, 2011
    Message Count:
    62
    Country:
    United Kingdom
    OK, I've managed to uninstall the Full Channel and install the Forwarder which is great.

    The Boot settings I was talking about let me set it to boot to the System Menu or Installed File and I previously had it set to Installed File and that was USB Loader GX. I've changed it now to boot to the System Menu and load USB Loader GX from there via the Forwarder Channel. However, I also tried updating the Installed File and that gave me a list of what appeared to be the apps that were on my SD card, so I selected USB Loader GX from there to install the new version but now if I try to boot the Installed File it just gives me a white screen.

    A separate issue, if I upgrade from d2x-v8 to v9 or v10-beta53-alt, USB Loader GX 1207mod1 (or the previous version I had installed) can't access my USB HDD. The HDD spins up and down repeatedly until the countdown times out and then USB Loader GX loads and says it can't find the HDD. Switching back to d2x-v8 and it works fine again.
    • Global Moderator

    Cyan GBATemp's lurking knight

    Member Since:
    Oct 27, 2002
    Message Count:
    10,227
    Location:
    Engine room, learning
    Country:
    France
    Do not install the USBLoaderGX's boot.dol into priiloader, instead you need to install the USBLoaderGX Forwarder's boot.dol (that file is located in the "all-in-one package" on the download page of the loader, inside the wad folder)

    For the cIOS d2x, you can use v10, but just do not use the "alt" version if your drive don't like the alternative one.
    • Newcomer

    doveman New Member

    Member Since:
    Dec 22, 2011
    Message Count:
    62
    Country:
    United Kingdom
    Ah,
    Ah, that's where I was going wrong then, installing the wrong USBLoaderGX dol in priiloader :rolleyes:

    I'll try the non alt d2xv10, although I'm not sure it will work as v9 doesn't either. I only wanted to upgrade to the alt-v10 so that I could use both USB ports in WiiXplorer so if I can't use that there's probably not any reason to change from v8 for now.
    • Global Moderator

    Cyan GBATemp's lurking knight

    Member Since:
    Oct 27, 2002
    Message Count:
    10,227
    Location:
    Engine room, learning
    Country:
    France
    Hermes cIOS v4+ allows you to use both ports too. if Wiixplorer let you select the IOS, use one of hermes IOS.

    else, you can always install both d2x v8 and v10 alt in different slots.
    • Newcomer

    doveman New Member

    Member Since:
    Dec 22, 2011
    Message Count:
    62
    Country:
    United Kingdom
    Ah cool, I'll give that a go.

    I installed following this guide http://www.wiihacks.com/recommended-faqs-guides-tutorials-only/96886-guide-softmod-any-wii.html so it looks like Hermes v4 should be IOS223 or should I use IOS224?

    IOS222 (rev 65535): Trucha Bug, ES Identify, NAND Access, USB 2.0 -hermes v4 base-38
    IOS223 (rev 65535): Trucha Bug, ES Identify, NAND Access, USB 2.0 -hermes v4 base -37/38
    IOS224 (rev 65535): Trucha Bug, NAND Access, USB 2.0 -hermes v5.1r base-57

    So if I wanted to install v10-alt in a different slot, leaving v8 in 249/250 how would I do that? I presume the Wii would still boot using 249/250 so USB Loader GX would still find the HDD OK?
    • Newcomer

    crisash New Member

    Member Since:
    Sep 13, 2009
    Message Count:
    6
    Country:
    Chile
    i have problems with this loader, everything loads fine, games, banners, options, but at time to play, the games never loads.
    I think i have the correct configuration of ios (hermes, d2x, etc), because with a older version of cfg loader (and older gx version) I load every existing game.
    with the new version of wiiflow and cfg loader its the same problem. all load, but at time to play, black screen.
    just work the oldest version of each loader.
    can anyone to know what happen?
    thanks.
    • Global Moderator

    Cyan GBATemp's lurking knight

    Member Since:
    Oct 27, 2002
    Message Count:
    10,227
    Location:
    Engine room, learning
    Country:
    France
    The Wii is booting with IOS80 (if you are on system menu 4.3)
    USBLoaders are booting with the IOS slot you decide.

    By using the cIOS d2x installer, you can select any slot from 200 to 255 (254=bootmii, 220-229 usually where Hermes cIOS are installed, other are free)

    @crisash:
    which version of the "old" loader is working, and which version of the new loader is not working?
    • Newcomer

    Shiranui-san New Member

    Member Since:
    Nov 4, 2011
    Message Count:
    85
    Country:
    Spain
    Following with force video mode tests, I found something weird:

    Rune Factory Frontier PAL:

    Force Video Mode:

    Disc Default --> 480i
    System --> 480i (My Wii is configured as HDTV 480p)
    PAL50 --> 480i (Should be 576i)
    PAL60 --> 480i
    NTSC --> 480p (Should be 480i)
    PAL480p --> 480i (Should be 480p)
    NTSC480p --> 480p

    Then I tried forcing Mario Party 8, DBZ Tenkaichi 3 and Shinchan (which I had previously tested forcing them to PAL480p and were displayed in 480i) to NTSC480p but I got black screen.
    • Member

    d.d.d. New Member

    Member Since:
    Jun 26, 2012
    Message Count:
    430
    Location:
    Tokyo Metropolis
    Country:
    Japan
    What version are you using?
    • Newcomer

    Shiranui-san New Member

    Member Since:
    Nov 4, 2011
    Message Count:
    85
    Country:
    Spain
    Both r1207 mod1 and the .dol included in "USBLoader GX V3.0 AllinOnePackage IOS249".
    • Global Moderator

    Cyan GBATemp's lurking knight

    Member Since:
    Oct 27, 2002
    Message Count:
    10,227
    Location:
    Engine room, learning
    Country:
    France
    My games are correctly displayed in 480p when I select Disc default (and Wii set to 480p).
    Maybe the game doesn't support some video mode, so it's using default mode for incompatible mode. (games like No More Heroes USA, and One Piece unlimited Adventure don't have PAL mode at all, I don't know how these games react when forcing to an unavailable mode (I matched my boot.dol to add them))

    Could you test with v2.3 too?
    I changed the video mode past 3.0, so I thought maybe I broke it, but if even 3.0 is not working then there's something wrong from an old revision.
    • Newcomer

    Shiranui-san New Member

    Member Since:
    Nov 4, 2011
    Message Count:
    85
    Country:
    Spain
    Mine too, most of them, but it seems these older games and ported games do not.

    That's what I thought, but it seemed strange to me that Rune Factory Frontier is displayed in 480i if forced to PAL480p and displayed in 480p when forced to NTSC and NTSC480p.

    I will, and will report later.
    • Newcomer

    crisash New Member

    Member Since:
    Sep 13, 2009
    Message Count:
    6
    Country:
    Chile
    configurable usb loader v70 runing on ios 222
    with newest version of this loader (cfg70MODr50) and gx (v3.0), the games doesn't load.
    thanks (and sorry by my english)
    • Newcomer

    Shiranui-san New Member

    Member Since:
    Nov 4, 2011
    Message Count:
    85
    Country:
    Spain
    I tried GX v2.3, same results.
    Mario Party 8, Tenkaichi 3 and Shinchan are always displayed in 576i, but if they are forced to NTSC or NTSC480p, I get a black screen.
    Rune Factory Frontier is always displayed in 480i, except when it is forced to NTSC or NTSC480p, then it is displayed in 480p.
    • Global Moderator

    Cyan GBATemp's lurking knight

    Member Since:
    Oct 27, 2002
    Message Count:
    10,227
    Location:
    Engine room, learning
    Country:
    France
    Thanks,
    I'll have to see how the patches are working.
    • Newcomer

    Shiranui-san New Member

    Member Since:
    Nov 4, 2011
    Message Count:
    85
    Country:
    Spain
    Thanks to you for working on this loader.
    Last edited by Shiranui-san, Jan 8, 2013
    • Newcomer

    doveman New Member

    Member Since:
    Dec 22, 2011
    Message Count:
    62
    Country:
    United Kingdom
    Ah, thanks.

    Apparently Hermes cIOS does allow use of both ports but not at the same time, which is what I'm trying to do. I'll try d2x-v10-beta53-alt and see if that lets USB Loader GX see my HDD.

    So with the cIOS d2x installer, I can select any slot, like 210 and 211, to install to, even though the d2x-v10 wads are named like this?
    cIOS249[56]-d2x-v10-beta53-alt.wad
    cIOS250[57]-d2x-v10-beta53-alt.wad
    • Member

    Maxternal Peanut Gallery Spokesman

    Member Since:
    Nov 15, 2011
    Message Count:
    5,173
    Location:
    Deep in GBAtemp addiction
    Country:
    Costa Rica
    Some loaders (and a lot of people you as for troubleshooting help from) will just assume that you've installed base 56 in 249, base 57 in 250 and base 58 in 251 which is kinda the unwritten convention most people use.

    EDIT : Besides, I think the first time you load GX it will try to load whatever's in 249 or 250 even though you can change that setting later.
    Last edited by Maxternal, Jan 9, 2013

SPONSORED LINKS
 

Share This Page