USB Loader Cover Help Needed Please

Discussion in 'Wii - Backup Loaders' started by pangasinan, Jun 9, 2012.

Jun 9, 2012
    • Newcomer

    pangasinan New Member

    Member Since:
    Apr 7, 2009
    Message Count:
    87
    Country:
    United States
    Hi i have 2 problems.
    1. In Configurable USB Loader v7 I want to just download the flat cover,but I can see only 2 options, "Download missing covers"and "Download all covers", both options are downloading all the covers which takes too long.
    Does anyone know a way of configuring the loader to just download download only one cover ?

    2. In USB Loader GX when I go to download the covers I get an error message : Cant create directory usb8;/config/images/2d/ " .How can I solve this error ?.

    thanks


    • Global Moderator

    Cyan GBATemp's lurking knight

    Member Since:
    Oct 27, 2002
    Message Count:
    10,397
    Location:
    Engine room, learning
    Country:
    France
    I can only help with GX:

    If it says "USB8", then it's a problem in the config file.
    For a reasons, it couldn't find any partitions the first time you launched the loader, so it tested one partition after another and ended at partition 8. It may have initiated partition number 8 in the setting file, but I guess you don't have 8 partition on your USB drive.


    You should delete the config file completely and let the loader create a new clean one.
    If you don't want to delete your config file for whatever reason, then follow this:

    If your settings and folders are all on USB first partition, it should point to:
    USB1:/config/images/
    or
    USB1:/apps/usbloader_gx/images/
    Select the path you want to edit:
    [IMG]
    and select the device from the bottom-center of the screen (the one with "USB1" on my screen bellow), then select the path to use.
    [IMG]
    • Newcomer

    pangasinan New Member

    Member Since:
    Apr 7, 2009
    Message Count:
    87
    Country:
    United States
    Thanks for the reply.
    In the config file on the sd card there is only one thing and that is # USB Loader GX R1180 - Main settings file
    language_path = sd:/apps/usbloader_gx/language/english.lang
    , there is no reference to USB8.
    I deleted the GXGlobal.cfg from the sd card and then inserted into the wii and opened up USB Loader GX ,but it never created another config file,im sure I did something wrong.
    But also I am unable to change the path in the usb loader gx ,I can go to custom path,but when I select anything I get an error popup,so there is no way to select the device from the buttons at the bottom of the screen (fig.2),them buttons are not there.

    thanks
    • Global Moderator

    Cyan GBATemp's lurking knight

    Member Since:
    Oct 27, 2002
    Message Count:
    10,397
    Location:
    Engine room, learning
    Country:
    France
    It's strange that you have only 2 lines in the config file.

    Maybe there's a problem in accessing your devices.
    Which cIOS are you using ? (you can see it in the Settings > Credits)

    Paste here the 2 lines from the top-right of the credit page.
    • Newcomer

    pangasinan New Member

    Member Since:
    Apr 7, 2009
    Message Count:
    87
    Country:
    United States
    Hi
    There is only one line and it say v3.0 ios249 (rev21)
    thanks
    • Global Moderator

    Cyan GBATemp's lurking knight

    Member Since:
    Oct 27, 2002
    Message Count:
    10,397
    Location:
    Engine room, learning
    Country:
    France
    You should try updating the cIOS.
    you are not using the latest version available.


    You can install cIOS d2x v8 by using modmii and a wadmanager, or by using the d2x installer.

    You need to install version v8 final, in slot 249, with base 56, and version 21008.

    If you don't understand what to do, or what the tutorial explains, let me know.
    • Newcomer

    pangasinan New Member

    Member Since:
    Apr 7, 2009
    Message Count:
    87
    Country:
    United States
    Hi,I will install using d2x installer,but I have a question.
    Using d2x installer I have chosen version v8 final, in slot 249, with base 56, and version 21008.,then on the next screen (summary) it shows a grid like screen called Slot Map with one number from 200-254 in each box.
    The box 200 is highlighted and the box 249 is flashing red.Do I move the field box from 200 to 249 so that 249 is now highlighted ? and then continue the install,or just install from 200 or doesn't it matter ? thanks
    • Global Moderator

    Cyan GBATemp's lurking knight

    Member Since:
    Oct 27, 2002
    Message Count:
    10,397
    Location:
    Engine room, learning
    Country:
    France
    I think your "highlighted 200" is the cursor.
    You can move that cursor over the table to see informations. But you don't need to place that cursor over the slot 249. This is only the "info cursor", not the "install place".

    Move it to your current red 249 slot, and it will show you information about your currently installed IOS in this slot. (rev21, base xx)



    The blinking slot show which slot will be installed/overwritten. (you can have multiple blinking slots to install multiple IOS at once).
    Just press A to confirm installation of the blinking slots.

    It will then install and replace your slot 249 from cIOSrev21[base ??] to cIOS d2x v8[base56]
    After successful install, press B to exit the installer, and try again the loader to see if it fixed your device detection problem.
    • Newcomer

    pangasinan New Member

    Member Since:
    Apr 7, 2009
    Message Count:
    87
    Country:
    United States
    Hi
    Well the problem is still there after upgrading the cIOS.
    I am using a 750gb portable hard drive for these games and I am getting this problem,but when I use a 32gb flash drive with some games installed i am able to download the covers no problem.
    So it seems it might be a hd problem,any suggestions on how to fix this please... thanks
    • Global Moderator

    Cyan GBATemp's lurking knight

    Member Since:
    Oct 27, 2002
    Message Count:
    10,397
    Location:
    Engine room, learning
    Country:
    France
    which partition format are you using?
    Could you have a hidden partition on your HDD? (some Western Digital drives tend to have CD-emulated partition which you can't remove under Windows)
    I remember that such partition created problem in the past.

    If you are using FAT32 or NTFS, I find it strange that it can detect your games correctly, but can't detect the partitions correctly to save the config and data.


    Using SD card is out of question?
    • Newcomer

    pangasinan New Member

    Member Since:
    Apr 7, 2009
    Message Count:
    87
    Country:
    United States
    My hard drive is wbfs formatted, I didnt do it myself someone else set up my system to play games from a hd.
    Im not sure how to tell if there are hidden partitions :(
    • Global Moderator

    Cyan GBATemp's lurking knight

    Member Since:
    Oct 27, 2002
    Message Count:
    10,397
    Location:
    Engine room, learning
    Country:
    France
    You have ONLY a WBFS partition?

    If you don't have any FAT32 or NTFS or Ext partition, then of course you can't save the covers on your HDD! and that's why it didn't find any partition number to store your data.
    WBFS can store ONLY Wii disc games.
    No covers, no config, etc.
    You need an SD card.
    • Newcomer

    pangasinan New Member

    Member Since:
    Apr 7, 2009
    Message Count:
    87
    Country:
    United States
    Well it might have another partition how can I tell ? I do have an sd card and the covers for usb loadercfg are stored on the sd card.
    I am using WiiBackupManager_Win64 to install games on my hd,can I change the path for downloading covers for usb loader gx from usb to sd card ?
    Sorry if I sound kinda dumb :blink: ,
    • Global Moderator

    Cyan GBATemp's lurking knight

    Member Since:
    Oct 27, 2002
    Message Count:
    10,397
    Location:
    Engine room, learning
    Country:
    France
    You can certainly select a different path to download the covers.
    Then, after transfering a game, don't forget to also manually transfer/copy the cover folder to the SD card.


    But, if you have Wifi on your Wii, I suggest that you use the internal cover download feature of USB Loader GX.
    Press (1) button on the wiimote, and select the cover you want to download from gametdb.com
    It will be downloaded in the "images/covers" "images/2D" etc. paths set in your settings.

    The default setting for the covers are:

    Box covers (3D perspective) : SD:\apps\usbloader_gx\images\cover\
    Box covers (2D Flat) : SD:\apps\usbloader_gx\images\2D\
    Disc labels : SD:\apps\usbloader_gx\images\disc\
    Full covers : SD:\apps\usbloader_gx\images\full\

    the full cover is used to display the box in real 3D when pressing (2) button, you can move/rotate/zoom the cover.


    Edit:
    To see your HDD Structure and check how many partition you have, it depends on your operating system.

    But just use SD card, it's easier.
    Or convert your WBFS partition to FAT32, then you can store data on it.
    • Newcomer

    pangasinan New Member

    Member Since:
    Apr 7, 2009
    Message Count:
    87
    Country:
    United States
    Ok,problem is now solved :) ,it seems I had a bad sd card.I changed sd cards and copied the content from bad sd card to good sd card and now I can download the covers in gx,but am wondering will this affect anything that may have been hidden on bad sd card that was not transferred over , like will bootmii still work ok ?
    Thanks also for you time helping me Cyan,i really appreciate it,you are a good person.
    • Global Moderator

    Cyan GBATemp's lurking knight

    Member Since:
    Oct 27, 2002
    Message Count:
    10,397
    Location:
    Engine room, learning
    Country:
    France
    There is always a chance you transfered corrupted files from the old SD to the new one if the old SD was bad.

    If you want to check your bootmii, just launch it (homebrew channel > home > bootmii).
    You can also launch hackmii installer again, and choose "prepare SD Card" to create new, 100% correct, files.
    • Newcomer

    tjobs New Member

    Member Since:
    Aug 31, 2012
    Message Count:
    2
    Country:
    Estonia
    Help I have the same problem but can't read the solution from this tread easily.
    I have also only WBFS partition. My program also only refers to USB8:....
    I try to change it under Custom Paths but when I press "A" it says "Error!" instead of letting me change the link.
    I also tried to find the config file (on the SD card) but I can't find it.
    I want to use the SD card solution as I bought a big SD card just because of that...
    • Global Moderator

    Cyan GBATemp's lurking knight

    Member Since:
    Oct 27, 2002
    Message Count:
    10,397
    Location:
    Engine room, learning
    Country:
    France
    If you use only a WBFS partition, then it's normal that you can't list/find any USB partition.
    The loader is listing usb1, usb2, usb3 etc. only on partition in FAT32/NTFS/Ext

    But it's not normal that you can't select SD card.
    if you launch the loader from SD:/apps/usbloader_gx/boot.dol
    it should create a file SD:/apps/usbloader_gx/GXGlobal.cfg


    Launch the loader WITHOUT the USB drive connected.
    That way, it will be forced to use the SD card to store the config.

    If it still doesn't work, verify that your SD card is not write protected.
    Or try formating it again (with Panasonic SD Formater 3.x)
    • Newcomer

    tjobs New Member

    Member Since:
    Aug 31, 2012
    Message Count:
    2
    Country:
    Estonia
    Hmm I disconnected the USB and started the USBloader and nothing happens. I have inserted the SD card in my PC and all I can see is this
    (in the folder H:\apps\usbloader_gx) is
    boot.dol
    icon.png
    meta.xml

    I am also showing hidden files and nothing happens...
    Is it wrong to read the SD card just from normal windows or should I use one of the Wii specific programmes to look at the SD card to find some extra files?
    • Global Moderator

    Cyan GBATemp's lurking knight

    Member Since:
    Oct 27, 2002
    Message Count:
    10,397
    Location:
    Engine room, learning
    Country:
    France
    Windows is fine.

    the loader use two different places for storing config files:
    /apps/usbloader_gx/
    and
    /config/

    maybe look if you have this folder, the config files used by the loader are all prefixed with "GX".
    But I think that your SD card have problem being mounted, that's why the loader display "USB8:/", it's the latest possible device tested, and while no device has been found it's stopped there.

    If it couldn't create any config files in that folder maybe your SD card can't be written on the Wii?
    Did you try formating it again?

SPONSORED LINKS
 

Share This Page