[Tutorial] Installing rxTools Custom Firmware - (3DS and 2DS)

Discussion in '3DS - Tutorials' started by samiam144, Jun 15, 2015.

Thread Status:
Not open for further replies.
  1. rody2k6

    rody2k6 GBAtemp Regular

    Member
    224
    2
    Dec 30, 2009
    United States
    Yeah let's see. They have been saying there are 2 type of error codes, I'm seeing the one that they say it's permanent. Let's wait and see I guess.

    Sent from my ASUS_Z00LD using Tapatalk
     
  2. isaias guerrero

    isaias guerrero Member

    Newcomer
    43
    1
    Feb 26, 2013
    United States
    this is maybe a dumb question, but i havent done anything to my o3ds in a long time, so i have been out of this for a while, my o3ds has rxtools 2.5.2 with mset and fbi cia installed, my emunand is on 9.8 or something and sysnand 4.5, my son wants to play pokemon sun and moon and i have seen a spoofed version that supossedly works on old emunand, but there is also the choice for a retail cia to play online, if i update emunand to the latest version will i be able to install and play the retail version online?? also if not, do i need to do anything else to be able to play the spoofed version? i have read about luma3ds but honestly i dont want to go through that for now since rxtools has been good... so if i update my emunand will it be ok? is there anything else i need to do??

    forgot to mention my fbi version is 1.3.8, should i update that too?
     
    Last edited by isaias guerrero, Nov 29, 2016
  3. samiam144
    OP

    samiam144 Régulier

    Member
    2,871
    936
    Aug 19, 2007
    Canada
    The latest emunand should work on rxTools. There are some people that claim that the latest Pokemon does not work on rxTools, and some that claim that it does. If it doesn't work for you then I still recommend Luma.

    I'd also recommend updating FBI, as the newer versions have a lot of helpful features such as auto-update, cia installation through QR codes, deleting titles without going into System Settings, etc.
     
  4. isaias guerrero

    isaias guerrero Member

    Newcomer
    43
    1
    Feb 26, 2013
    United States
    so update emunand first, then update fbi?? how do i update fbi ??
     
  5. samiam144
    OP

    samiam144 Régulier

    Member
    2,871
    936
    Aug 19, 2007
    Canada
  6. isaias guerrero

    isaias guerrero Member

    Newcomer
    43
    1
    Feb 26, 2013
    United States
  7. samiam144
    OP

    samiam144 Régulier

    Member
    2,871
    936
    Aug 19, 2007
    Canada
    Installing the cia will update it, unless you are using an injected FBI, in which case you would have both the newest version and the old version. The newest version has the auto-update feature which you can use from then on.
     
  8. isaias guerrero

    isaias guerrero Member

    Newcomer
    43
    1
    Feb 26, 2013
    United States
    thanks a lot, i updated emunand and fbi and now i got poke moon (spoofed) running... ill stick to rxtools until i can...
     
    samiam144 likes this.
  9. synx13

    synx13 Newbie

    Newcomer
    5
    0
    Oct 25, 2015
    Brazil
    Hi! I did not play my O3DSXL for a while and want to play Mario Maker, can I play it with the latest emunand?

    My Sysnand is 9.2 and my emunand is 6.2, I am launching RxTools at boot with Themehax.

    Is it safe to update my emunand through the System Settings App to the latest version (11.2)?

    Can I launch RxTools at boot with Themehax after updating my emunand to 11.2?

    Thanks in advance!
     
    Last edited by synx13, Dec 4, 2016
  10. Trolling

    Trolling This Username is taken. Problem?

    Member
    282
    365
    Jul 29, 2012
    Netherlands
    Behind you
    Switch to Luma and update your emunand (or use A9LH) and than you can play Super Mario Maker.
     
  11. synx13

    synx13 Newbie

    Newcomer
    5
    0
    Oct 25, 2015
    Brazil
    I thought I could update and play.

    I will stick with my old 10.2 for some time, almost updated my emunand.

    Thanks!
     
  12. Trolling

    Trolling This Username is taken. Problem?

    Member
    282
    365
    Jul 29, 2012
    Netherlands
    Behind you
    samiam144 likes this.
  13. JC4Ever97

    JC4Ever97 Member

    Newcomer
    17
    1
    Aug 24, 2016
    United States
    Please help me, after I attempted this my health and safety app is gone on my sysNAND. Now I'm currently transitioning to Luma3DS by using Plailect's guide, got it down to installing A9LH and updating the system. Now I want to inject FBI into the h&s app, but I can't locate the h&s app even after a successful inject. How can I solve this? I didn't move the contents of my previous emunand setup to the new sysnand setup and I used a brand new SD card for Plailect's guide.

    EDIT: Uhh nevermind it moved to the end of my 3DS Home Menu.
     
    Last edited by JC4Ever97, Jan 1, 2017
  14. MrErdo

    MrErdo Member

    Newcomer
    33
    5
    Mar 8, 2017
    Netherlands
    I have currently installed this:
    https://3ds.guide/

    This hack is called arm9loaderhax right?

    And now I read this:

    The tutorial says it is better if I upgrade to luma3ds but I already have luma3ds by having followed this tutorial: https://3ds.guide/

    So this guide (https://3ds.guide/) already let's you install luma3ds? Because I already have luma3ds when I look on my Nintendo.
     
  15. Sliter

    Sliter GBAtemp Psycho!

    Member
    3,060
    805
    Dec 7, 2013
    Brazil
    ᕕ( ᐛ )ᕗ
    it install but in a oter way ... I don't know how do epxlain because I'm still takig courage to perform this tuto xD
     
  16. Joom

    Joom  ❤❤❤

    Member
    4,209
    2,885
    Jan 8, 2016
    United States
    Yes, you have Luma installed if you followed that guide. You should be good to go if you followed it to the end.
     
    samiam144 likes this.
  17. MrErdo

    MrErdo Member

    Newcomer
    33
    5
    Mar 8, 2017
    Netherlands

    But I don't understand this part of the tutorial:

    It makes it looks like what is written above this text is outdated and I should click on that hyperlink to follow another tutorial. So I don't have to click on that hyper link that says luma3ds? If I understand it correctly I have luma3ds now and I only have to update it by clicking that update button in the menu of my Nintendo, right?

    You have to be careful. Nothing wrong happened but I'm still confused what I installed and how I should use it. Is there a guide that explains every feature of luma3ds? The only thing that I figured out is how to install cia files so I can play games. That is about it right?
     
    Last edited by MrErdo, Mar 8, 2017
  18. Joom

    Joom  ❤❤❤

    Member
    4,209
    2,885
    Jan 8, 2016
    United States
    Yup. The only guide you should follow is the one at 3ds.guide, and you can totally disregard this one. Also, if you want to see all of Luma's features you can read its Wiki.
     
  19. MrErdo

    MrErdo Member

    Newcomer
    33
    5
    Mar 8, 2017
    Netherlands
    Is it possible to run nds games? If yes how?
     
  20. Joom

    Joom  ❤❤❤

    Member
    4,209
    2,885
    Jan 8, 2016
    United States
    You can run some using nds-bootstrap and TWLoader, but the compatibility is low. Your best bet is to get a flashcart for that, or wait for more development to come along.
     
Thread Status:
Not open for further replies.