"The system files are corrupted" error exiting Wii Fit Plus

Discussion in 'Wii - Hacking' started by sYndrome13, Dec 19, 2009.

Dec 19, 2009
    • Member

    sYndrome13 New Member

    Member Since:
    Nov 28, 2008
    Message Count:
    134
    Country:
    United States
    After updating to Wii System Menu 4.1U using Waninko's Firmware Updater, my Wii gives the error "The system files are corrupted" any time I exit the Wii Fit Plus channel using the Home button and selecting Wii Menu. The Wii gives the same error the next time I boot the system. I then shut down the Wii again and turn it back on, after which, it doesn't give the error.

    I only see the error after using the Wii Fit Plus channel and two reboots clears the problem. What can I do to prevent the same issue in the future? I want to continue using the Wii Fit Plus channel, but not if it means damaging the Wii.


    • Member

    transam81 New Member

    Member Since:
    Oct 4, 2009
    Message Count:
    284
    Location:
    Central California
    Country:
    United States
    Stop using Wanikiko's Shit, it's out of date.
    • Member

    Tanas New Member

    Member Since:
    Aug 19, 2006
    Message Count:
    2,258
    Country:
    United Kingdom
    What he said...

    It also bricked my wii but luckily enough I had Bootmii installed.
    • Member

    sYndrome13 New Member

    Member Since:
    Nov 28, 2008
    Message Count:
    134
    Country:
    United States
    Okay, then what would you recommend for updating from System Menu 3.2U to 4.1U? I have a NAND backup from right before the update from 3.2U and 4.1U, so I could use a different method of updating if I knew what was recommended.
    • Member

    transam81 New Member

    Member Since:
    Oct 4, 2009
    Message Count:
    284
    Location:
    Central California
    Country:
    United States
    This was my step 1.

    I used "Modify any Wii 4.2 & below, aka the simplistic mod". http://gbatemp.net/index.php?showtopic=171901

    Everything i've added to my Wii since then has worked flawlessly. In other words this is the foundation on which i have customized my Wii.

    Step 2
    Configurable Usb Loader (yours can be Neogamma)

    P.S. I took my FW all the way to 4.2u after running 4.1u for about a month. I've got no complaints for either Firmware.
    • Newcomer

    ysuki New Member

    Member Since:
    Sep 13, 2009
    Message Count:
    23
    Country:
    United States
    I have the same problem on 4.2 with the Wii Fit Plus channel. I get the exact same problem when I go to Home then Wii Menu. After removing the Wii Fit Plus channel, the problem went away. I don't think the updater is the problem because I used zektor's guide and I had the problem too. Channel installation from a backup disc doesn't work too well I think. You could try to see if a friend have a legit Wii Fit Plus disc and try installing the channel from that disc. You could try installing a Wii Fit Plus channel wad to see if that fixes the problem (after removing the channel of course).
    • Member

    techboy New Member

    Member Since:
    Mar 15, 2009
    Message Count:
    1,720
    Location:
    Pennsylvania
    Country:
    United States
    The Wii Fit Plus channel has issues.

    Be glad it even works for you at all. My friend installed it on his wii through the OFFICIAL DISC, and it banner bricked! Others have reported this issue as well. Not sure why it happens...

    Best advice is to not use the channel.
    • Member

    sYndrome13 New Member

    Member Since:
    Nov 28, 2008
    Message Count:
    134
    Country:
    United States
    The problem definitely seems to be isolated to Wii Fit Plus.

    I tried removing the Wii Fit Plus channel using WAD Manager, restarting the Wii, then re-adding the channel using WAD Manager again. I had the same issue--plus my Wii Fit Plus save data was deleted. Fortunately, I had a recent save backup on my SD card.

    On a related note: When I tried to load Wii Fit Plus from a USB external hard drive (formatted to WBFS) using WiiFlow, the loader hung at the "Please wait..." screen. I haven't had that problem with any other game.

    Is there a Wii Fit Plus-specific IOS I'm missing somewhere? Maybe installing (or removing) a file would help resolve this issue.

    EDIT: When I load Wii Fit Plus from a backup DVD using NeoGamma R8 RC15, I'm able to get into the game, but have the same problem ("The system files are corrupted" error after exiting the game).

    UPDATE: Re-installing cIOS rev 14 may have fixed the issue. I need to conduct a few more tests to confirm.
    • Member

    techboy New Member

    Member Since:
    Mar 15, 2009
    Message Count:
    1,720
    Location:
    Pennsylvania
    Country:
    United States
    WF+ runs fine off an USB HDD for me. I use USB Loader GX with the #002 fix turned on for WF+. WiiFlow might be your issue.

    Your save data disappeared because it shares the same title ID as the channel. When the channel goes, so does everything else with that ID, including any matching ID save data. The Mario Kart channel does the same thing if removed wad manager. At least you had a backup though.
    • Member

    sYndrome13 New Member

    Member Since:
    Nov 28, 2008
    Message Count:
    134
    Country:
    United States
    Yeh, live and learn. I only lost two Body Test sessions, so I wasn't upset about it.
    • Member

    sYndrome13 New Member

    Member Since:
    Nov 28, 2008
    Message Count:
    134
    Country:
    United States
    Okay, so I'm able to use the Wii Fit Plus channel without issue now, but I still can't seem to load Wii Fit Plus from a USB external drive formatted using WBFS. I've tried WiiFlow, USB Loader GX, and Configurable USB Loader. All try to load the game, but then the loader hangs and the game doesn't load.

    I haven't installed any extra cIOS files for peripherals. Do I need to do that since Wii Fit Plus uses the Balance Board?

    So confused. [IMG]
    • Member

    techboy New Member

    Member Since:
    Mar 15, 2009
    Message Count:
    1,720
    Location:
    Pennsylvania
    Country:
    United States
    A balance board is just a WiiMote w/o buttons, and with an extension controller permanently attached. It doesn't need an extra IOS.
    • Member

    sYndrome13 New Member

    Member Since:
    Nov 28, 2008
    Message Count:
    134
    Country:
    United States
    Okay, so I was able to get Wii Fit Plus to load without any problems after re-extracting the disc image, but not trimming it before loading it on my USB external hard drive using WBFS Manager. (Before, I had trimmed the image before adding it to the drive.)

    But now I'm having the same problem I did before: The Wii boots to a "The system files are corrupted" error every time after I reboot or shutdown after loading Wii Fit Plus or Wii Fit Plus Channel.

    This is a really bothersome problem and one I never had when I loaded the game from DVD.
    • Member

    sYndrome13 New Member

    Member Since:
    Nov 28, 2008
    Message Count:
    134
    Country:
    United States
    UPDATE: I have the same problem (Wii returning "The system files are corrupted" message when rebooting after exiting a Wii Fit Plus session) playing the game from disc using NeoGamma R8 RC15.

    Any ideas?
    • Member

    sYndrome13 New Member

    Member Since:
    Nov 28, 2008
    Message Count:
    134
    Country:
    United States
    I hate to post three times in a row, but I'm really hoping someone can offer some insight on this problem. Wii Fit Plus is the only game that causes the "system files are corrupted error," but I bought the Balance Board for the purpose of using Wii Fit and Wii Fit Plus. I've yet to find a workaround for this issue, even after hours of testing and searching for solutions online.
    • Member

    ringorinfret New Member

    Member Since:
    Mar 10, 2008
    Message Count:
    306
    Country:
    United States
    it is so easy to update to 4.1....just use dop-ios mod...update all ios to latest above 35 make sure you got the right ios60 for system menu 4.1 (cant remember the version number but anyway dop-ios doesnt let you install the stub that came after) and then install system menu 4.1....updated 3 wiis this way with no problem at all

    regards
    • Member

    sYndrome13 New Member

    Member Since:
    Nov 28, 2008
    Message Count:
    134
    Country:
    United States
    My Wii is already running System Menu 4.1. Are you saying you recommend I re-update using the dop-ios mod you mentioned?

    I'm not familiar with dop-ios mod, so any clarification would be helpful.
    • Member

    hellion_52883 New Member

    Member Since:
    Jan 5, 2010
    Message Count:
    138
    Country:
    United States
    I've noticed everytime Dop-ios is suggested that the NUS downloader and Wad manager method will work.......I've heard Dop-ios has bugs and makes me worry.....NUS / WAD Manager Method is simple also.....so because it is supposed to be safer i use that method, I've never touched Dop-ios, so i can't say about that, but (never touching dop-ios) i've done several things that people said i needed Dop-ios for......


    Just letting you know
    • Member

    longtom1 Keep an eye on my posts cause I quick edit frequen

    Member Since:
    Jan 12, 2009
    Message Count:
    2,641
    Location:
    Honey Oils inc.
    Country:
    Antarctica
    have used dop-ios for IOS's and to install system menu's never had a problem
    • Member

    hellion_52883 New Member

    Member Since:
    Jan 5, 2010
    Message Count:
    138
    Country:
    United States
    yeah, i dunno if it is unsafe(Dop-ios).........just heard it might be........i alredy knew how to do the other method (NUS/WAD)......... so i just stuck with it

SPONSORED LINKS
 

Share This Page