Setting up nonpdrm and nps browser...

Discussion in 'PS Vita - Hacking & Homebrew' started by raylgo, Nov 15, 2017 at 7:25 AM.

  1. raylgo
    OP

    raylgo GBAtemp Regular

    Member
    166
    6
    Sep 9, 2007
    Not sure what I'm doing wrong but refreshing the live area doesn't show the games downloaded by nps browser.

    I followed the steps to install nonpdrm and have the file in the Tai folder and have already edited the configuration file to include nonpdrm under ux0.

    I set up nps browser and tried downloading a few games. Got muramasa and child of light. I assumed I just had to copy the app folder to ux0 and refresh the area. It says refreshing 22 titles but nothing new showed up...
     
  2. dizz00

    dizz00 GBAtemp Regular

    Member
    179
    21
    Aug 2, 2016
    Indonesia
    Same thing happened to me, just redownload the game.the refreshed titles probably dlc.
     
  3. Spartk

    Spartk Advanced Member

    Newcomer
    59
    13
    Jul 24, 2017
    Argentina
    forget the ux0:tai/ folder and delete it. nonpdrm.skprx must be copied in ur0:tai/ folder and you must set the config.txt in that folder with the string ur0:tai/nonpdrm.skprx after the first *KERNEL line. do the same in uma0:tai\ folder and with the config.txt in it if you have an original sony memory card installed as uma0: together with a sd2vita mounted as ux0:
     
  4. dizz00

    dizz00 GBAtemp Regular

    Member
    179
    21
    Aug 2, 2016
    Indonesia
    If he got the dlc refreshed then the plug-in already working, and probably unpacking issue with the game.
     
  5. raylgo
    OP

    raylgo GBAtemp Regular

    Member
    166
    6
    Sep 9, 2007
    Alright I'll n try re-downloading the games first. Can't work on it until the weekend... Would I have better luck with pkgi? And just use nps browser for dlc?

    And is it normal for pkgi to have speeds of 70 to 120 kB/s. Our net speed reaches 700kB/s usually...
     
  6. dizz00

    dizz00 GBAtemp Regular

    Member
    179
    21
    Aug 2, 2016
    Indonesia
    In my experience i only have problem with pkgi when installing Valkyrie drive compared to nps with 3 games(shinovi versus, project diva x, noire. All games install normally after 1st redownload for me), but yeah the download speed is slower. Iirc 400kBps for me compared to nps if the speed is fast can reach above 1mBps single download.
     
    Last edited by dizz00, Nov 15, 2017 at 12:48 PM
  7. raylgo
    OP

    raylgo GBAtemp Regular

    Member
    166
    6
    Sep 9, 2007
    Weird... I'll try to re-download smaller game with pkgi and nps browser. See which one of them works.
     
  8. gbands

    gbands GBAtemp Regular

    Member
    130
    1
    Jan 31, 2008
    This is incredibly frustrating. I used to have an 8gb sony memcard and used that when the 3.60 hack first came out. I haven't touched my vita much but want to play some games now. Discovered Enzo and eventually nondprm games. I got that working. I put the nonpdrm.skprx in ux0:tai and had the line ux0:tai/nonpdrm.skprx entered under the first *KERNEL line. I tried one nondprm game after that and it worked.

    Now I found a 32gb sony memcard that my partner originally had and wanted to use that instead. I reformatted it since it used to have an account that he never really bought anything on. Copy pasted stuff from the 8gb card (I can see all the folders) via usb using the latest vitashell and my old stuff are still there. Tried grabbing a game using the NPS browser, no errors shown and I dropped that in uxo:app folder. Tried refreshing the livearea but it says 0 apps. I tried the 1st game that worked on the old card and still no success.

    I thought it might be because I just copy pasted stuff on the new card so I did a reformat of the card. still no. Did a system restore and reformat. Reinstalled henkaku, enzo. Redownloaded the nondprm file. Deleted the ux0:tai folder and put the file in ur0:tai and edited the line in the config found there. NADA. I don't know what I'm doing wrong anymore.

    While writing this, I tried downloading a very small game in the pkgi app and it works. So I guess I'm just having problems when transferring files from the pc. I tried downloading the same game I got on the NPS browser but pkgi gave me an error (it's 3gb), should the screen be kept open when dl larger games?

    Edit: wrote this at 3am. So sorry to hijack the thread. It's just we have the same problem and have been working on it the whole night.
     
    Last edited by gbands, Nov 18, 2017 at 11:54 PM