[Release] tcpGecko dotNet for 3ds

Discussion in '3DS - ROM Hacking, Translations and Utilities' started by Mega-Mew, Mar 10, 2017.

  1. lone_wolf323

    lone_wolf323 GBAtemp Advanced Fan

    Member
    563
    165
    May 27, 2011
    Canada
    Thankies aswell for this information. Finally got mine up and running aswell
     


  2. vitorTC

    vitorTC Member

    Newcomer
    21
    12
    Oct 17, 2009
    Brazil
    I've already tried everithing, still nothing...

    No Plugin folder
    Port fowarded
    Firewall disabled
    ntr.bin overwrited on root

    Any thing missing?
     
  3. Nanquitas

    Nanquitas GBAtemp Addict

    Member
    2,070
    1,696
    Sep 29, 2015
    France
    South of France :)
    Press DPAD-Left when launching the game ?
     
  4. yNEX

    yNEX Member

    Newcomer
    47
    5
    Oct 5, 2016
    Gambia, The
    Happy to see that I could help some of you :)
    You don't need to forward any port (Well I didn't have to..)
    If need I will perhaps write a step-by-step tutorial.
     
  5. NANASHI89

    NANASHI89 GBAtemp Maniac

    Member
    1,096
    121
    May 3, 2012
    United States
  6. Soulsilve2010

    Soulsilve2010 GBAtemp Regular

    Member
    278
    59
    Sep 3, 2016
    United States
    United States,Indiana
    On the github click release.zip not source code

    Now I got a question:How do I change what port it tries to connect to?

    — Posts automatically merged - Please don't double post! —

    Also can't connect to the right port with this one...
     
    Last edited by Soulsilve2010, May 30, 2017
  7. Nanquitas

    Nanquitas GBAtemp Addict

    Member
    2,070
    1,696
    Sep 29, 2015
    France
    South of France :)
    You don't change the port, the ports are scanned until it find the good one since it's 5000 + PID.

    Be sure to not have any plugin, that your 3DS is connected and that you hold DPAD-Left when you launch the game.
    Connect when you're stuck on the loading screen then the game will continue.
     
    Soulsilve2010 likes this.
  8. Soulsilve2010

    Soulsilve2010 GBAtemp Regular

    Member
    278
    59
    Sep 3, 2016
    United States
    United States,Indiana
    Okay,now
    its connected and when i choose to say hello screen flashes green but is still stuck on the 3ds logo,I'm not really good at these things
     
  9. yNEX

    yNEX Member

    Newcomer
    47
    5
    Oct 5, 2016
    Gambia, The
    Uhm how can you click on Say Hello? In Gecko dNET is no button for it
     
  10. Soulsilve2010

    Soulsilve2010 GBAtemp Regular

    Member
    278
    59
    Sep 3, 2016
    United States
    United States,Indiana
    I was using NTR Debugger,can't seem to connect with the other 2 things here

    Sorry for the confusion
     
  11. yNEX

    yNEX Member

    Newcomer
    47
    5
    Oct 5, 2016
    Gambia, The
    Ugh... But you know, that it is useless bit NTRDebugger? oO
     
    Soulsilve2010 likes this.
  12. Nanquitas

    Nanquitas GBAtemp Addict

    Member
    2,070
    1,696
    Sep 29, 2015
    France
    South of France :)
    Hmm, the Gecko Mod is not supposed to be used with NTR Debugger.

    You need the modded ntr.bin then TCP Gecko Dot NET.

    The original ntr.bin won't work with this app and the modded ntr.bin won't work with the original debugger.

    If you're looking support for the original debugger create another thread since it's not related to this one.
     
    Last edited by Nanquitas, May 30, 2017
    yNEX and Soulsilve2010 like this.
  13. vitorTC

    vitorTC Member

    Newcomer
    21
    12
    Oct 17, 2009
    Brazil
    Yes.

    I know how to do, the problem is it don't stay connected.

    It's connect, resumes the game, and then try to connect again.
     
  14. lone_wolf323

    lone_wolf323 GBAtemp Advanced Fan

    Member
    563
    165
    May 27, 2011
    Canada
    curious about something with this. I have two n3ds systems that I have system transfered to and from before while getting b9s set up for them. My red 3ds system, it was able to connect with the items I got on SD card on it. yet the new black 3ds i got. It attempts to connect. then goes back to trying on the different ports again and doesnt. Is this something that perhaps my 3ds is at fault for. Or should I just look at uninstalling everything and trying fresh with the NTRBooter and this ntr bin file?
     
  15. DarkFlare69

    DarkFlare69 GBAtemp Psycho!

    Member
    4,691
    2,516
    Dec 8, 2014
    United States
    Ohio
    did you make sure to change the IP for the black one? system transfer shouldn't make a difference
     
  16. lone_wolf323

    lone_wolf323 GBAtemp Advanced Fan

    Member
    563
    165
    May 27, 2011
    Canada
    Yes, used the HBL to get IP for what the 3ds is.
     
  17. gengardenne

    gengardenne GBAtemp Regular

    Member
    268
    5
    Nov 14, 2016
    Italy
    Gecktod.net don't work for me...
    Placed the ntr.bin mod on the sd root and boot via all the ntr hombrews(with different location for the ntr)and after boot PK moon it makes two blue screen and then a green one freezing on the logo.Until now all good but not only hasn't Geckto string on the ntr menu,but more the program don't connect to my 3ds(I know the ip).
    Have also delete any plugin games folder leaving only this one blank.
    What I'm doing wrong?
    Same with the Geckomodcheat by Nanquitas that is much similar
    Help please :)
     
  18. gengardenne

    gengardenne GBAtemp Regular

    Member
    268
    5
    Nov 14, 2016
    Italy
    Me too have the same exact problem.
    How can I fix it?
     

    Attached Files:

  19. noctis90210

    noctis90210 GBAtemp Advanced Fan

    Member
    731
    106
    Dec 24, 2013
    good day, just want to ask how to use this?

    i followed the instructions.
    i put the ntr.bin on the root of sd
    i removed all the plugins (plg files)
    i boot pokemon x while holding left on dpad (blue screen flash 2x then a green flash once, but stuck on 3ds logo...)
     
  20. Aigle67

    Aigle67 GBAtemp Regular

    Member
    256
    43
    Mar 31, 2015
    Belgium
    [​IMG]

    Can someone tell me how to fix that ? I'm using ntr 3.2 on 11.2 sysnand and i can't fix this error :/