Official [release] Homebrew App Store (for WiiU)

Discussion in 'Wii U - Homebrew' started by vgmoose, Jul 5, 2016.

Jul 5, 2016
  1. vgmoose
    OP

    Member vgmoose GBAtemp Regular

    Joined:
    Jan 31, 2016
    Messages:
    201
    Country:
    United States
    The notice put out was to notify that there appears to be issues with the larger number of apps, and that temporarily the 1.0 version of the app has been "crippled" to a smaller selection of apps to prevent loading issues.

    I've written a write-up of what the major bug seems to be here: https://github.com/vgmoose/hbas/issues/20

    And am actively seeking help to solving this problem! :unsure: If anyone takes a look, make sure to change the repoUrl at the top of src/menu/HomebrewWindow.cpp, and to host your own local store by running the gen.py script in the web folder, and then hosting that folder.
     
    rw-r-r_0644 likes this.


  2. ShadowOne333

    Member ShadowOne333 GBAtemp Guru

    Joined:
    Jan 17, 2013
    Messages:
    6,100
    Country:
    Mexico
    Guys, a title deleter from inside the Homebrew Launcher?
    AFAIK there is no such thing yet.

    Even if there were, the app would require IOSU access, which in this case would need:

    1) A fw.img
    2) Rebooting the console into IOSUhax.
    3) Seeing the red screen of hope.
    4) Once it has been rebooted, then it would start deleting stuff.

    Everyone naive enough to believe him just needs a lesson or two on at least how things work around the Wii U Homebrew community.
     
    ItsKipz likes this.
  3. QuarkTheAwesome

    Member QuarkTheAwesome Working for Hugs

    Joined:
    Apr 19, 2015
    Messages:
    663
    Location:
    Stuck in the PowerPC
    Country:
    Australia
    I; uh, talked to @vgmoose. There's more to this story that meets the eye - let's not start degrading people over it.
     
    ShadowOne333 likes this.
  4. ItsKipz

    Member ItsKipz l33t hax0r

    Joined:
    Sep 9, 2016
    Messages:
    1,572
    Location:
    The C: drive
    Country:
    United States
    oshitwhat
     
  5. rw-r-r_0644

    Member rw-r-r_0644 GBAtemp Fan

    Joined:
    Jan 13, 2016
    Messages:
    307
    Country:
    Italy
    It wouldn't have bricked Wii Us though...
    But yeah, @Filo97 is not lying
     
  6. BIFFTAZ

    Member BIFFTAZ GBAtemp Advanced Fan

    Joined:
    Jul 26, 2010
    Messages:
    552
    Country:
    United Kingdom
    Ohh wow. People were ripping him a new one yesterday for this too >.<
     
  7. vgmoose
    OP

    Member vgmoose GBAtemp Regular

    Joined:
    Jan 31, 2016
    Messages:
    201
    Country:
    United States
    Greetings!

    I have finally updated HBAS to address the constant crashing, and also added categories.
    Github post: https://github.com/vgmoose/hbas/releases/tag/1.5
    Wiiubru: http://wiiubru.com/appstore/#/app/appstore
    or you can update through the v1.0 of hbas

    I'm hoping for a true Stability™ release here! Let me know if there are any outstanding issues.

    Also, the first load may take a while, especially if you're far from the server in the UK. Subsequent launches are faster though, after the info has been cached.
     
    Nikolay, Omegadrien, Brawl345 and 4 others like this.
  8. Marko76

    Member Marko76 GBAtemp Addict

    Joined:
    Aug 19, 2015
    Messages:
    2,850
    Location:
    Clydebank
    Country:
    United Kingdom
    Yes the new version works very well and I like the new design and thank God the awful music from the last version is gone.
     
    vgmoose likes this.
  9. xtheman

    Member xtheman Custom Titles are trash.

    Joined:
    Jan 28, 2016
    Messages:
    5,823
    Country:
    Antarctica
    I liked it :(
     
    vgmoose likes this.
  10. peteruk

    Member peteruk GBAtemp Maniac

    Joined:
    Jun 26, 2015
    Messages:
    1,327
    Country:
    United Kingdom

    Working really well thank you, I like the new chip music on this release a little more than the previous one as well

    1 minor question, I have the latest 1.3 wup installer already but when browsing the app store it tells me there is a newer version available and I am on 1.0... Is this a known bug or something wrong with my setup ?
     
    vgmoose likes this.
  11. pwsincd

    Member pwsincd Garage Flower

    Joined:
    Dec 4, 2011
    Messages:
    3,243
    Location:
    Manchester UK
    Country:
    United Kingdom
    you have 1.3 but the appstore tells you your on 1.0 ?? this isnt possible..

    the app info is the stores version... not what you currently have.
     
  12. peteruk

    Member peteruk GBAtemp Maniac

    Joined:
    Jun 26, 2015
    Messages:
    1,327
    Country:
    United Kingdom
    @pwsincd

    Sorry for the poor quality pics, first one shows my wup installer and the second shows me in the latest app store showing 1.0

    [​IMG]

    [​IMG]
     
  13. vgmoose
    OP

    Member vgmoose GBAtemp Regular

    Joined:
    Jan 31, 2016
    Messages:
    201
    Country:
    United States
    @peteruk Hm, that's interesting. If I had to guess I'd say your (local) wupymod is installed to a folder named wupinstaller, which is why it incorrectly thinks 1.0 is an update. This is because it tries to guess which you have installed based on the folder name, and on wiiubru.com "wupinstaller" still refers to the non-ymod. Since version numbers can be strings, any difference in versions is registered as an "update". The icon displayed is still your local icon though.

    Other people will probably have this issue too. As for fixing it, you could do 1 of 2 things:
    1. install wiiubru's wupymod from hbas (probably further down in that screenshot) and remove yours
    2. rename your wupinstaller folder in sd:/wiiu/apps to wupymod

    As for that "update", if you were to run it, it'd likely just replace your wupinstaller y-mod with the normal wupinstaller without y-mod. (and change the icon too). Since people can get apps from different places, it might be hard to fix this all idiosyncrasies like this.

    at least you're honest :P I prefer the older one, but I changed it as I associated the old song too much with crashing!
     
    Last edited by vgmoose, Nov 21, 2016
    peteruk likes this.
  14. pwsincd

    Member pwsincd Garage Flower

    Joined:
    Dec 4, 2011
    Messages:
    3,243
    Location:
    Manchester UK
    Country:
    United Kingdom
    It seems like your wup directories are messed up
    easiest fix
    delete them both in appstore.. then reisntall from there
     
    CreeperMario and peteruk like this.
  15. peteruk

    Member peteruk GBAtemp Maniac

    Joined:
    Jun 26, 2015
    Messages:
    1,327
    Country:
    United Kingdom
    thanks that's a really helpful reply and your quite right of course about the folder name, I shall go ahead and rename mine

    thank you for the support, much appreciated and please keep up the great work on the app store
     
    vgmoose likes this.
  16. pwsincd

    Member pwsincd Garage Flower

    Joined:
    Dec 4, 2011
    Messages:
    3,243
    Location:
    Manchester UK
    Country:
    United Kingdom
    gotta say though ... the appstore looks kinda sexy in that photo :)
     
    CreeperMario and peteruk like this.
  17. peteruk

    Member peteruk GBAtemp Maniac

    Joined:
    Jun 26, 2015
    Messages:
    1,327
    Country:
    United Kingdom
    sure does mate even on my crappy phone :)
     
    CreeperMario and pwsincd like this.
  18. gabe_derp

    Newcomer gabe_derp Member

    Joined:
    Nov 20, 2016
    Messages:
    22
    Location:
    U.S.
    Country:
    United States
    Best way to update apps. Nice job!
     
    CreeperMario and vgmoose like this.
  19. BlakCake

    Newcomer BlakCake Newbie

    Joined:
    Nov 22, 2016
    Messages:
    1
    Country:
    Panama
    Is it still possible to change the background music like last version?
     
    vgmoose likes this.
  20. vgmoose
    OP

    Member vgmoose GBAtemp Regular

    Joined:
    Jan 31, 2016
    Messages:
    201
    Country:
    United States
    Yep, but since I changed the music the name of the file has changed too. Now custom music should go in sd:/wiiu/apps/appstore/resources/slimers.mp3 (previously was screampics.mp3)
     
    CreeperMario, peteruk and BlakCake like this.

Share This Page