Random crashing in Wii games - tried everything!

Discussion in 'Wii - Hacking' started by britain4, Jan 10, 2017.

  1. britain4
    OP

    Newcomer britain4 Member

    Joined:
    Jun 16, 2014
    Messages:
    27
    Location:
    Sheffield
    Country:
    United Kingdom
    Hi all

    Getting random crashes in Wii games I can't get to the bottom of. This is with USB Loader GX.

    I've tried reinstalling all my cIOSs, using D2X beta 52 and alt 53, also tried using Hermes 222, tried running off both a USB hard drive and an SD card with the hard drive unplugged, different games, different dumps, I had a third party Nunchuk causing crashes in HBC and an official one has cured that but not the crashing in games, I've tried the wacky thing about deleting the internet settings I am at a loose end, can anyone think of anything I've missed? All the above give exactly the same results, random crashing after 2-20 minutes with no rhyme or reason

    The one thing I do still have connected to it other than an SD card and official wiimote and nunchuck is a modchip, I can't remember which one but have they been known to affect stability at all?
     
    Last edited by britain4, Jan 10, 2017


  2. Litle_Bird

    Newcomer Litle_Bird Member

    Joined:
    Jan 1, 2017
    Messages:
    20
    Country:
    Sweden
    Greetings!

    First of a Syscheck report would be nice as it shows the info of all your IOS:es and such.

    On idea that struck me is what happens if you run a game that's on a disc, will it crash aswell or will it work as intended? Perhaps even a burnt disc would be quite intresting since the modchip is needed for that and if there is something wrong with it the burnt game would crash aswell? Well that's somethings I think of but I don't really know.
    But if the games run perfectly from discs that would perhaps narrow it down to either being something wrong with the cIOS:es, Usb drive or sd card.
     
  3. britain4
    OP

    Newcomer britain4 Member

    Joined:
    Jun 16, 2014
    Messages:
    27
    Location:
    Sheffield
    Country:
    United Kingdom
    I've attached the syscheck to this post.

    I've run plenty of disc games on it backup and original over the years and it's been fine but not since I hacked it recently. However I was also using a third party Wiimote and nunchuk that whole time which gave no problens until I tried to run homebrew on it and everything started crashing. I could have put money on my third party Nunchuk causing it as I thought i'd ruled everything else out, a genuine one cured the crashing homebrew but not in Wii games :(

    I'm absolutely stuck, the possibilities at this point are that all the cIOSs I've tried have been faulty, that it doesn't like the hard drive or SD card I'm using giving identical crashes with each, that all the games I've downloaded have been bad or that the console itself is faulty...
     

    Attached Files:

  4. Litle_Bird

    Newcomer Litle_Bird Member

    Joined:
    Jan 1, 2017
    Messages:
    20
    Country:
    Sweden
    Would you like to post the syscheck in a spoiler? I'm not trying to be rude it's just that I'm generally sceptical about downloading files from random scources. :)

    So If I get it right you have trouble playing discs now aswell? That's kinda odd... Hopefully the sysCheck can tell us something more :)
     
  5. britain4
    OP

    Newcomer britain4 Member

    Joined:
    Jun 16, 2014
    Messages:
    27
    Location:
    Sheffield
    Country:
    United Kingdom
    Yep no problem one minute...

    No I mean I haven't tried any disc based games since I hacked it but it always worked fine before that, I have been playing backup DVDs on it for years without a hitch

    Thanks for your help btw I am so lost with this now! So frustrating trying something new and it lasting half an hour and I think I've fixed it then it bloody crashes again!

    I'm trying out more different dumps of the same games now just to completely rule it out. I'd love to just take the modchip out as I don't need it any more (well not if I get this working) but can't find my tri wing and the new ones not arrived yet! argh lol

    syscheck
     
    Last edited by britain4, Jan 10, 2017
  6. Litle_Bird

    Newcomer Litle_Bird Member

    Joined:
    Jan 1, 2017
    Messages:
    20
    Country:
    Sweden
    That report looks very wierd to me.. comparable to what I've got
    My SysCheck

    However I find one thing very strange, It seems your system menu is running under IOS 58 which it shouldn't, it should be IOS 80 for System menu 4.3.
    Don't try anything yet though. Important, do you have bootmii as boot2 installed? And could you perhaps run another sysCheck but with this app?
     
  7. britain4
    OP

    Newcomer britain4 Member

    Joined:
    Jun 16, 2014
    Messages:
    27
    Location:
    Sheffield
    Country:
    United Kingdom
    OK thanks I'll have to give that a go tomorrow now with the software you provided.

    I do have bootmii installed as boot2.
     
  8. Litle_Bird

    Newcomer Litle_Bird Member

    Joined:
    Jan 1, 2017
    Messages:
    20
    Country:
    Sweden
    That's very good that you're lucky to have bootmii boot2, as it allows more effective methodes to be used!
    Just to be on the safe side, you also have a nandbackup right?
     
    John_Ice likes this.
  9. britain4
    OP

    Newcomer britain4 Member

    Joined:
    Jun 16, 2014
    Messages:
    27
    Location:
    Sheffield
    Country:
    United Kingdom
    Yep I've had this Wii since just about launch day so definitely boot2 capable!

    Yup I have a NAND backup too.
     
    Litle_Bird likes this.
  10. GreyWolf

    Member GreyWolf GBAtemp Addict

    Joined:
    Mar 2, 2015
    Messages:
    2,686
    Country:
    United States
    The old SysChecks reports are funky. The 2.4+ versions are much better. (link)
     
  11. britain4
    OP

    Newcomer britain4 Member

    Joined:
    Jun 16, 2014
    Messages:
    27
    Location:
    Sheffield
    Country:
    United Kingdom
    Tried some more different dumps, still the same problem.

    Could it be the SD card it doesn't like causing the crashing? I've heard of bad hard drives causing crashes when they're not even being used. The SD card is about the only variable I haven't changed apart from the console itself.

    Only other thing I could do is restore my NAND backup and redo everything again.

    My bad guys I googled it and thought I had the latest version of it. We'll try this again:

    syscheck
     
    Last edited by britain4, Jan 11, 2017
  12. Litle_Bird

    Newcomer Litle_Bird Member

    Joined:
    Jan 1, 2017
    Messages:
    20
    Country:
    Sweden
    I'm quite suprised of your new SysCheck because it looks very much like my own, except for a few cIOS:es but that shouldn't interfere...
    Yesterday the thought stuck me about reinstalling IOS 80 and System Menu 4.3E manually with a wad manager incase anything with them were wrong that could cause your problem, however if that will help I have no clue of, I'm sure some would deem it risky but I can say I wouldn't mind doing it since I have bootmii boot2. That would remove priiloader atleast, altough you could just reinstall it.

    If not I'm still intressed in knowing what happens if you run a game from disc, will it crash aswell? If not it would suggest something is wrong with the usb/cIOS and such.

    What USB loader are you using? Aswell have you set it to use any special IOS? I've got USB loader GX set to use IOS 249.
     
    britain4 likes this.
  13. britain4
    OP

    Newcomer britain4 Member

    Joined:
    Jun 16, 2014
    Messages:
    27
    Location:
    Sheffield
    Country:
    United Kingdom
    Yeah I thought I'd done everything correctly, I only installed 222 and 223 etc because I was trying to solve the crashing problem with a different cIOS

    I'll give that a go, anything at this stage that might help I will give it a try.

    I'll give some discs a go and see what happens with those but I was playing discs on it for hours the other day before I hacked it and it was fine. :(

    I've tried USB loader GX and Configurable USB loader with 249 (beta 52 and 53) and 222 all with the same results,
     
  14. CheatFreak47

    Member CheatFreak47 Complex Donut

    Joined:
    Oct 11, 2011
    Messages:
    1,195
    Location:
    Michigan, USA
    Country:
    United States
    What kind of hard drive are you using?
    Strange as this sounds, many hard drives have a "power saving" feature that cause it to spin down after a period of about 10 or 20 minutes without any active read/writes, which happens a lot for Wii games because of how the Wii works.

    In those instances, nothing in any cIOS is designed to tell the HDD to spin back up, and thus many games will immediately crash when they try to load anything.
     
  15. britain4
    OP

    Newcomer britain4 Member

    Joined:
    Jun 16, 2014
    Messages:
    27
    Location:
    Sheffield
    Country:
    United Kingdom
    The only hard drive I've tried on it is a spare 180gb Intel SSD in a USB enclosure but I have tried running from the SD card without the hard drive plugged in with identical results.

    The crashing also happens randomly anywhere from 2 minutes to half an hour into playing.
     
  16. CheatFreak47

    Member CheatFreak47 Complex Donut

    Joined:
    Oct 11, 2011
    Messages:
    1,195
    Location:
    Michigan, USA
    Country:
    United States
    Are you using any advanced functions like EmuNAND or anything?
     
  17. britain4
    OP

    Newcomer britain4 Member

    Joined:
    Jun 16, 2014
    Messages:
    27
    Location:
    Sheffield
    Country:
    United Kingdom
    Well, I setup EmuNAND with USB Loader GX and I have a load of games on that but I don't have it setup at all with CFG USB loader nor do I have an EmuNAND on my SD card. Still crashes when using CFG USB and an SD card.

    Could that have messed something up?
     
  18. smf

    Member smf GBAtemp Advanced Fan

    Joined:
    Feb 23, 2009
    Messages:
    844
    Country:
    United Kingdom
  19. britain4
    OP

    Newcomer britain4 Member

    Joined:
    Jun 16, 2014
    Messages:
    27
    Location:
    Sheffield
    Country:
    United Kingdom
  20. britain4
    OP

    Newcomer britain4 Member

    Joined:
    Jun 16, 2014
    Messages:
    27
    Location:
    Sheffield
    Country:
    United Kingdom
    Okay I've tried following the above guide we'll see how it goes. Thanks!
     

Share This Page