[QUESTION] Are the new 2DS XL systems placed on shops the latest firmware version?

Discussion in '3DS - Console, Accessories and Hardware' started by ROMANREIGNS599, Sep 8, 2017.

  1. ROMANREIGNS599
    OP

    ROMANREIGNS599 GBAtemp Regular

    Member
    112
    1
    May 6, 2017
    United States
    So I can install freeshop after installing fbi without a help of carts or any other gadget and just installing what I want by just downloading requirements from the guide?
     


  2. Dionicio3

    Dionicio3 Some Cool Skiddo

    Member
    3,090
    4,396
    Feb 26, 2017
    United States
    Hollister, CA
    No, you still need either a card, a 2nd hacked 3ds, or get a hardmod
     
  3. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ I drool on my knife

    Member
    19,755
    20,499
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    My bad, half a sentence got cut off and I wasn't paying attention, that "either" was suppose to be elsewhere. You need to buy a cart in order to use NTRBoot, the cart is a requirement for the exploit to work.
    Your other three methods are:
    Buy a second system with an exploitable OFW and prefer a dsiwarehax via system transfer
    Hardmod it yourself or send it out.
    Wait until a new kernel exploit is released.
     
  4. wormdood

    wormdood pirate booty inspector

    Member
    3,371
    1,414
    Jan 3, 2014
    United States
    behind a parental advisory sticker
    the goal of the guide is to install b9s/luma (fbi is a standard part of the process) once you have cfw you will only need your systems sd card to download/install games . . . but if your 3ds is on 11.4 you will not be able to install cfw without either a ds flashcard or a hacked 3ds or a hardmod
     
  5. ROMANREIGNS599
    OP

    ROMANREIGNS599 GBAtemp Regular

    Member
    112
    1
    May 6, 2017
    United States
    Ok, so now it is impossible to install Fbi above 11.3 so if I order from eBay getting selled from the user "Nintendo"(I'm not sure if it is the real Nintendo), will it have firmware below 11.4? You might think this is a stupid question but please resist. So if not below 11.4, is there any website or any way that I can get one below firmware 11.4?
     
  6. Hayato213

    Hayato213 GBAtemp Regular

    Member
    118
    17
    Dec 26, 2015
    United States
    Still work on 11.5, LUMA CFW work on 11.5
     
  7. Dionicio3

    Dionicio3 Some Cool Skiddo

    Member
    3,090
    4,396
    Feb 26, 2017
    United States
    Hollister, CA
    Read later posts, we answered this
     
  8. Jayro

    Jayro MediCat DVD and Mini Windows 10 Developer

    Member
    GBAtemp Patron
    Jayro is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,860
    2,589
    Jul 23, 2012
    United States
    Octo Canyon
    I don't get why Nintendo can't use firmware updates to stub-out the "secret sector" that hackers can install B9S to, when they have FULL SYSTEM ACCESS to every and anything. I know Luma keeps it read-only, but they should be able to over-ride that setting upon reboot, or doing a recovery-mode update.
     
  9. Dionicio3

    Dionicio3 Some Cool Skiddo

    Member
    3,090
    4,396
    Feb 26, 2017
    United States
    Hollister, CA
    They actually can't iirc
     
  10. Jayro

    Jayro MediCat DVD and Mini Windows 10 Developer

    Member
    GBAtemp Patron
    Jayro is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,860
    2,589
    Jul 23, 2012
    United States
    Octo Canyon
    I know, but nobody can ever seem to explain to me WHY they can't. they just reply with "They just cant.", and I'm sick of that BS answer.
     
    Dionicio3 and wormdood like this.
  11. Dionicio3

    Dionicio3 Some Cool Skiddo

    Member
    3,090
    4,396
    Feb 26, 2017
    United States
    Hollister, CA
    Same, maybe its somewhere on 3dbrew
     
  12. wormdood

    wormdood pirate booty inspector

    Member
    3,371
    1,414
    Jan 3, 2014
    United States
    behind a parental advisory sticker
    agreed there was a time where pepole said "there is no way nintendo can ban you for using cfw!"

    i just want answers . . . presented with logic
     
    Last edited by wormdood, Sep 8, 2017
    Jayro likes this.
  13. ROMANREIGNS599
    This message by ROMANREIGNS599 has been removed from public view by porkiewpyne, Sep 14, 2017.
    Sep 9, 2017
  14. NekoMichi

    NekoMichi Retro Collector

    Member
    1,277
    907
    Jun 4, 2015
    Minus World
    It's probably more of a cost-benefit problem rather than a technical one. They can do that, but the amount of time researching and developing a way to out-exploit the exploit probably outweighs the benefits it brings to them because a patch like that targets less than 1% of all 3DS users while also posing potential risks to the 99% who aren't using CFW.
     
  15. ROMANREIGNS599
    This message by ROMANREIGNS599 has been removed from public view by porkiewpyne, Sep 14, 2017.
    Sep 9, 2017
  16. SANIC
    This message by SANIC has been removed from public view by porkiewpyne, Sep 14, 2017, Reason: Reply to trashed post.
    Sep 9, 2017
  17. Tony_93

    Tony_93 GBAtemp Addict

    Member
    2,171
    989
    Jun 13, 2015
    United States
    California
    I remember it being like this: bootrom initializes using some secret encrypted keys, then gets locked and the secret keys get cleared off the system by the time you get to the system menu.

    It was made this way to avoid people from tampering with the bootrom and for the most part it worked great, it took years for people to find access to these sections with already hacked consoles and kernel access.

    B9S uses an exploit that happens before boot, but in order to install a system update you obviously need to have accesed the system menu thus making systems updates unable to access and try to patch the bootrom since it's long locked away.

    Nintendo would have to make a completely new chip that works differently to remove the flaw... Which they didn't seem to bother with the N2DS XL.
     
  18. ROMANREIGNS599
    This message by ROMANREIGNS599 has been removed from public view by porkiewpyne, Sep 14, 2017.
    Sep 10, 2017
  19. NekoMichi

    NekoMichi Retro Collector

    Member
    1,277
    907
    Jun 4, 2015
    Minus World
    *snip*

    The answer is no. At the time of announcement, the latest firmware was 11.4. Therefore all 2DS XL units will ship with 11.4 or above and you won't be able to find one on 11.3 or below.

    I believe this question has already been answered in an earlier thread.
     
    Last edited by porkiewpyne, Sep 14, 2017
  20. SANIC
    This message by SANIC has been removed from public view by porkiewpyne, Sep 14, 2017, Reason: Reply to trashed post.
    Sep 10, 2017
  21. ROMANREIGNS599
    This message by ROMANREIGNS599 has been removed from public view by porkiewpyne, Sep 14, 2017.
    Sep 11, 2017
  22. wormdood
    This message by wormdood has been removed from public view by porkiewpyne, Sep 14, 2017, Reason: Reply to trashed post.
    Sep 11, 2017
  23. lidolinn

    lidolinn Member

    Newcomer
    29
    1
    Mar 27, 2011
    United States
    *snip*

    They already answered ur question earlier in this thread as well.

    1. 2ds xl does not come with firmware 11.3, only 11.4 and above
    2. You can install fbi on firmware above 11.3 with the help of a r4 cart. The reason is you need the r4 cart to install b9S hack. Once b9s is setup, you can install fbi, freeshop and whatever games that you want.

    Hope that is clear enough.
     
    Last edited by porkiewpyne, Sep 14, 2017
  24. ROMANREIGNS599
    This message by ROMANREIGNS599 has been removed from public view by porkiewpyne, Sep 14, 2017, Reason: Can we not?.
    Sep 14, 2017
  25. wormdood
    This message by wormdood has been removed from public view by porkiewpyne, Sep 14, 2017, Reason: Reply to trashed post.
    Sep 14, 2017
  26. DarkDante
    This message by DarkDante has been removed from public view by porkiewpyne, Sep 14, 2017.
    Sep 14, 2017
  27. SANIC
    This message by SANIC has been removed from public view by porkiewpyne, Sep 14, 2017.
    Sep 14, 2017